summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-12-21 17:46:59 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-12-21 17:46:59 +0000
commit9f28b353d34a1a3e469b13a9ce8bcba01df99e0f (patch)
treee8c149e344583747fc1c9eb3d1c6bc7ddd1011d8 /app-misc/sphinx
parentPass --enable-experimental to link against libgio-2.0.so wrt #245237. (diff)
downloadgentoo-2-9f28b353d34a1a3e469b13a9ce8bcba01df99e0f.tar.gz
gentoo-2-9f28b353d34a1a3e469b13a9ce8bcba01df99e0f.tar.bz2
gentoo-2-9f28b353d34a1a3e469b13a9ce8bcba01df99e0f.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.21-gentoo-r1 i686)
Diffstat (limited to 'app-misc/sphinx')
-rw-r--r--app-misc/sphinx/ChangeLog7
-rw-r--r--app-misc/sphinx/sphinx-0.9.9_rc1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/app-misc/sphinx/ChangeLog b/app-misc/sphinx/ChangeLog
index 3a10226dbfa4..42898a65f008 100644
--- a/app-misc/sphinx/ChangeLog
+++ b/app-misc/sphinx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/sphinx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.15 2008/11/10 00:33:05 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/ChangeLog,v 1.16 2008/12/21 17:46:59 caleb Exp $
+
+*sphinx-0.9.9_rc1 (21 Dec 2008)
+
+ 21 Dec 2008; Caleb Tennis <caleb@gentoo.org> +sphinx-0.9.9_rc1.ebuild:
+ Version bump
*sphinx-0.9.8.1 (10 Nov 2008)
diff --git a/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild b/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild
new file mode 100644
index 000000000000..19af056a93f3
--- /dev/null
+++ b/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/sphinx/sphinx-0.9.9_rc1.ebuild,v 1.1 2008/12/21 17:46:59 caleb Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_/-}
+
+DESCRIPTION="Full-text search engine with support for MySQL and PostgreSQL"
+HOMEPAGE="http://www.sphinxsearch.com/"
+SRC_URI="http://sphinxsearch.com/downloads/${MY_P}.tar.gz
+ stemmer? ( http://snowball.tartarus.org/dist/libstemmer_c.tgz )"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug mysql postgres stemmer test"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-base )"
+RDEPEND="${DEPEND}
+ test? ( dev-lang/php )"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use stemmer; then
+ cd "${S}"
+ unpack libstemmer_c.tgz
+ fi
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with stemmer libstemmer) \
+ $(use_with debug) || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc doc/* example.sql
+ dodir /etc/sphinx
+ insinto /etc/sphinx
+ doins sphinx.conf.dist
+
+ dodir /var/lib/sphinx
+ dodir /var/log/sphinx
+ dodir /var/run/sphinx
+}