summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-20 19:58:49 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-20 19:58:49 +0000
commitcbfc6caf6c37b0114714e33c20e25f57312b9399 (patch)
tree664932c88dfdc137c861923afca2dda8a29bf037 /app-misc/mc
parentVersion bump. Ebuild by Arfrever. (diff)
downloadgentoo-2-cbfc6caf6c37b0114714e33c20e25f57312b9399.tar.gz
gentoo-2-cbfc6caf6c37b0114714e33c20e25f57312b9399.tar.bz2
gentoo-2-cbfc6caf6c37b0114714e33c20e25f57312b9399.zip
Version bump. Don't require user to choose from ncurses/slang (bug #353679 by Ulrich Müller and others); use slang by default as less buggy implementation. New release among others fixes crash when ~/.config is not a dir (bug #406315 by Marcin Mirosław).
(Portage version: 2.2.0_alpha91/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/ChangeLog12
-rw-r--r--app-misc/mc/files/mc-4.8.2-missing-do_panel_cd_stub_env.c397
-rw-r--r--app-misc/mc/mc-4.8.2.ebuild84
-rw-r--r--app-misc/mc/mc-9999.ebuild8
-rw-r--r--app-misc/mc/metadata.xml1
5 files changed, 496 insertions, 6 deletions
diff --git a/app-misc/mc/ChangeLog b/app-misc/mc/ChangeLog
index ac3372818aa2..868c66ee958d 100644
--- a/app-misc/mc/ChangeLog
+++ b/app-misc/mc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-misc/mc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.247 2012/03/19 18:52:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/ChangeLog,v 1.248 2012/03/20 19:58:49 slyfox Exp $
+
+*mc-4.8.2 (20 Mar 2012)
+
+ 20 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/mc-4.8.2-missing-do_panel_cd_stub_env.c, +mc-4.8.2.ebuild,
+ mc-9999.ebuild, metadata.xml:
+ Version bump. Don't require user to choose from ncurses/slang (bug #353679 by
+ Ulrich Müller and others); use slang by default as less buggy implementation.
+ New release among others fixes crash when ~/.config is not a dir (bug #406315
+ by Marcin Mirosław).
19 Mar 2012; Raúl Porcel <armin76@gentoo.org> mc-4.8.1-r1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #401157
diff --git a/app-misc/mc/files/mc-4.8.2-missing-do_panel_cd_stub_env.c b/app-misc/mc/files/mc-4.8.2-missing-do_panel_cd_stub_env.c
new file mode 100644
index 000000000000..22fba1543ffd
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.2-missing-do_panel_cd_stub_env.c
@@ -0,0 +1,397 @@
+#include "src/subshell.h"
+#include "src/setup.h"
+
+
+panels_options_t panels_options;
+struct mc_fhl_struct *mc_filehighlight;
+int confirm_execute = 0;
+int auto_save_setup = 0;
+int free_space = 0;
+int horizontal_split = 0;
+int first_panel_size = 0;
+int default_source_codepage = 0;
+int menubar_visible = 1;
+WPanel *current_panel;
+WInput *cmdline;
+WMenuBar *the_menubar;
+const global_keymap_t *panel_map;
+gboolean command_prompt;
+int saving_setup;
+
+panels_layout_t panels_layout = {
+ .horizontal_split = 0,
+ .vertical_equal = 1,
+ .left_panel_size = 0,
+ .horizontal_equal = 1,
+ .top_panel_size = 0
+};
+
+WInput *
+command_new (int y, int x, int cols)
+{
+ WInput *cmd;
+ const input_colors_t command_colors = {
+ DEFAULT_COLOR,
+ COMMAND_MARK_COLOR,
+ DEFAULT_COLOR,
+ COMMAND_HISTORY_COLOR
+ };
+
+ cmd = input_new (y, x, (int *) command_colors, cols, "", "cmdline",
+ INPUT_COMPLETE_DEFAULT | INPUT_COMPLETE_CD | INPUT_COMPLETE_COMMANDS |
+ INPUT_COMPLETE_SHELL_ESC);
+
+ /* Add our hooks */
+ cmd->widget.callback = NULL;
+
+ return cmd;
+}
+
+int
+do_cd (const vfs_path_t *new_dir, enum cd_enum exact)
+{
+ (void) new_dir;
+ (void) exact;
+
+ return 0;
+}
+
+void
+do_subshell_chdir (const vfs_path_t * vpath, gboolean update_prompt, gboolean reset_prompt)
+{
+ (void) vpath;
+ (void) update_prompt;
+ (void) reset_prompt;
+}
+
+void
+shell_execute (const char *command, int flags)
+{
+ (void) command;
+ (void) flags;
+}
+
+void
+panel_load_setup (WPanel * panel, const char *section)
+{
+ (void) panel;
+ (void) section;
+}
+
+void
+panel_save_setup (WPanel * panel, const char *section)
+{
+ (void) panel;
+ (void) section;
+}
+
+void
+free_my_statfs (void)
+{
+
+}
+
+int
+select_charset (int center_y, int center_x, int current_charset, gboolean seldisplay)
+{
+ (void) center_y;
+ (void) center_x;
+ (void) current_charset;
+ (void) seldisplay;
+
+ return 0;
+}
+
+void
+update_xterm_title_path (void)
+{
+}
+
+void
+init_my_statfs (void)
+{
+}
+void
+my_statfs (struct my_statfs *myfs_stats, const char *path)
+{
+ (void) myfs_stats;
+ (void) path;
+}
+
+void
+clean_dir (dir_list * list, int count)
+{
+ (void) list;
+ (void) count;
+
+}
+
+struct Widget *
+get_panel_widget (int idx)
+{
+ (void) idx;
+
+ return NULL;
+}
+
+
+int
+do_load_dir (const char *path, dir_list * list, sortfn * sort, gboolean reverse,
+ gboolean case_sensitive, gboolean exec_ff, const char *fltr)
+{
+ (void) path;
+ (void) list;
+ (void) sort;
+ (void) reverse;
+ (void) case_sensitive;
+ (void) exec_ff;
+ (void) fltr;
+
+ return 0;
+}
+
+int
+do_reload_dir (const vfs_path_t * vpath, dir_list * list, sortfn * sort, int count,
+ gboolean reverse, gboolean case_sensitive, gboolean exec_ff, const char *fltr)
+{
+ (void) vpath;
+ (void) list;
+ (void) sort;
+ (void) count;
+ (void) reverse;
+ (void) case_sensitive;
+ (void) exec_ff;
+ (void) fltr;
+
+ return 0;
+
+}
+
+void
+do_sort (dir_list * list, sortfn * sort, int top, gboolean reverse,
+ gboolean case_sensitive, gboolean exec_ff)
+{
+ (void) list;
+ (void) sort;
+ (void) top;
+ (void) reverse;
+ (void) case_sensitive;
+ (void) exec_ff;
+}
+
+int
+regex_command (const vfs_path_t *filename, const char *action, int *move_dir)
+{
+ (void) filename;
+ (void) action;
+ (void) move_dir;
+
+ return 0;
+}
+
+gboolean
+if_link_is_exe (const vfs_path_t *full_name, const file_entry * file)
+{
+ (void) full_name;
+ (void) file;
+
+ return TRUE;
+}
+
+void
+change_panel (void)
+{
+}
+
+gboolean
+set_zero_dir (dir_list * list)
+{
+ (void) list;
+
+ return TRUE;
+}
+
+void
+load_hint (gboolean force)
+{
+ (void) force;
+}
+
+panel_view_mode_t
+get_display_type (int idx)
+{
+ (void) idx;
+ return view_listing;
+}
+
+panel_view_mode_t
+get_current_type (void)
+{
+ return view_listing;
+}
+
+panel_view_mode_t
+get_other_type (void)
+{
+ return view_listing;
+}
+
+int
+get_current_index (void)
+{
+ return 0;
+}
+
+int
+get_other_index (void)
+{
+ return 1;
+}
+
+int
+unsorted (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_name (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_vers (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_ext (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_time (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_atime (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_ctime (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_size (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+int
+sort_inode (file_entry * a, file_entry * b)
+{
+ (void) a;
+ (void) b;
+
+ return 0;
+}
+
+void
+set_display_type (int num, panel_view_mode_t type)
+{
+ (void) num;
+ (void) type;
+}
+
+void
+copy_cmd_local (void)
+{
+}
+
+void
+delete_cmd_local (void)
+{
+}
+
+void
+view_raw_cmd (void)
+{
+}
+
+void
+edit_cmd_new (void)
+{
+}
+
+void
+rename_cmd_local (void)
+{
+}
+
+void
+select_invert_cmd (void)
+{
+}
+
+void
+unselect_cmd (void)
+{
+}
+
+void
+select_cmd (void)
+{
+}
+
+struct WPanel *
+get_other_panel (void)
+{
+ return NULL;
+}
+
+const panel_field_t *
+sort_box (panel_sort_info_t * info)
+{
+ (void) info;
+
+ return NULL;
+}
+
+void
+midnight_set_buttonbar (WButtonBar * b)
+{
+ (void) b;
+}
diff --git a/app-misc/mc/mc-4.8.2.ebuild b/app-misc/mc/mc-4.8.2.ebuild
new file mode 100644
index 000000000000..512ae9d5836f
--- /dev/null
+++ b/app-misc/mc/mc-4.8.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.8.2.ebuild,v 1.1 2012/03/20 19:58:49 slyfox Exp $
+
+EAPI=4
+
+inherit flag-o-matic
+
+MY_P=${P/_/-}
+
+DESCRIPTION="GNU Midnight Commander is a text based file manager"
+HOMEPAGE="http://www.midnight-commander.org"
+SRC_URI="http://www.midnight-commander.org/downloads/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="+edit gpm mclib nls samba +slang test X +xdg"
+
+RDEPEND=">=dev-libs/glib-2.8:2
+ gpm? ( sys-libs/gpm )
+ kernel_linux? ( sys-fs/e2fsprogs )
+ samba? ( net-fs/samba )
+ slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libSM )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? ( dev-libs/check )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp "${FILESDIR}"/${P}-missing-do_panel_cd_stub_env.c \
+ tests/src/filemanager/do_panel_cd_stub_env.c || die
+}
+
+src_configure() {
+ local myscreen=ncurses
+ use slang && myscreen=slang
+ [[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"
+
+ local homedir=".mc"
+ use xdg && homedir="XDG"
+
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ --enable-vfs \
+ $(use_enable kernel_linux vfs-undelfs) \
+ --enable-charset \
+ $(use_with X x) \
+ $(use_enable samba vfs-smb) \
+ $(use_with gpm gpm-mouse) \
+ --with-screen=${myscreen} \
+ $(use_with edit) \
+ $(use_enable mclib) \
+ $(use_enable test tests) \
+ --with-homedir=${homedir}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README NEWS
+
+ # fix bug #334383
+ if use kernel_linux && [[ ${EUID} == 0 ]] ; then
+ fowners root:tty /usr/libexec/mc/cons.saver
+ fperms g+s /usr/libexec/mc/cons.saver
+ fi
+}
+
+pkg_postinst() {
+ elog "To enable exiting to latest working directory,"
+ elog "put this into your ~/.bashrc:"
+ elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
+}
diff --git a/app-misc/mc/mc-9999.ebuild b/app-misc/mc/mc-9999.ebuild
index f80284498a32..1bccab9568c1 100644
--- a/app-misc/mc/mc-9999.ebuild
+++ b/app-misc/mc/mc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-9999.ebuild,v 1.4 2012/02/11 19:54:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-9999.ebuild,v 1.5 2012/03/20 19:58:49 slyfox Exp $
EAPI=4
@@ -24,16 +24,14 @@ HOMEPAGE="http://www.midnight-commander.org"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+edit gpm mclib +ncurses nls samba slang test X +xdg"
-
-REQUIRED_USE="^^ ( ncurses slang )"
+IUSE="+edit gpm mclib nls samba +slang test X +xdg"
RDEPEND=">=dev-libs/glib-2.8:2
gpm? ( sys-libs/gpm )
kernel_linux? ( sys-fs/e2fsprogs )
- ncurses? ( sys-libs/ncurses )
samba? ( net-fs/samba )
slang? ( >=sys-libs/slang-2 )
+ !slang? ( sys-libs/ncurses )
X? ( x11-libs/libX11
x11-libs/libICE
x11-libs/libXau
diff --git a/app-misc/mc/metadata.xml b/app-misc/mc/metadata.xml
index 3334c7cec3d1..33496fe19c5f 100644
--- a/app-misc/mc/metadata.xml
+++ b/app-misc/mc/metadata.xml
@@ -13,6 +13,7 @@
<use>
<flag name="edit">Compile and install the mcedit application</flag>
<flag name="mclib">Compile and install the libmc.so shared library</flag>
+ <flag name="slang">Use <pkg>sys-libs/slang</pkg> instead of <pkg>sys-libs/ncurses</pkg>.</flag>
<flag name="xdg">Toggles mc's config dir location. Enable for $XDG_CONFIG_HOME/mc, disable for $HOME/.mc</flag>
</use>
</pkgmetadata>