summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-10 00:52:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-10 00:52:43 +0000
commitfd5248aefd01d531348b17c9b2a212e79f332bae (patch)
tree0204bd3bb502e756abf03e963c3156eda895ebde /app-misc/jq
parentFix gpg signing of manifest (diff)
downloadgentoo-2-fd5248aefd01d531348b17c9b2a212e79f332bae.tar.gz
gentoo-2-fd5248aefd01d531348b17c9b2a212e79f332bae.tar.bz2
gentoo-2-fd5248aefd01d531348b17c9b2a212e79f332bae.zip
Fix build with automake-1.14 (bug #493804).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/jq')
-rw-r--r--app-misc/jq/ChangeLog6
-rw-r--r--app-misc/jq/files/jq-1.3-automake-1.14.patch19
-rw-r--r--app-misc/jq/jq-1.3.ebuild5
3 files changed, 27 insertions, 3 deletions
diff --git a/app-misc/jq/ChangeLog b/app-misc/jq/ChangeLog
index 301c82c80123..92f92ec09852 100644
--- a/app-misc/jq/ChangeLog
+++ b/app-misc/jq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/jq
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/ChangeLog,v 1.10 2013/07/04 12:24:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/ChangeLog,v 1.11 2013/12/10 00:52:43 radhermit Exp $
+
+ 10 Dec 2013; Tim Harder <radhermit@gentoo.org> jq-1.3.ebuild,
+ +files/jq-1.3-automake-1.14.patch:
+ Fix build with automake-1.14 (bug #493804).
04 Jul 2013; Agostino Sarubbo <ago@gentoo.org> jq-1.3.ebuild:
Stable for x86, wrt bug #474936
diff --git a/app-misc/jq/files/jq-1.3-automake-1.14.patch b/app-misc/jq/files/jq-1.3-automake-1.14.patch
new file mode 100644
index 000000000000..343e7ca4185b
--- /dev/null
+++ b/app-misc/jq/files/jq-1.3-automake-1.14.patch
@@ -0,0 +1,19 @@
+--- jq-1.3/configure.ac
++++ jq-1.3/configure.ac
+@@ -4,7 +4,7 @@
+ dnl Created autoconf implementation thompson@dtosolutions, 26NOV12
+ AC_PREREQ([2.61])
+ AC_CONFIG_AUX_DIR([config])
+-AM_INIT_AUTOMAKE([parallel-tests foreign])
++AM_INIT_AUTOMAKE([parallel-tests foreign -Wall])
+ AM_SILENT_RULES([yes])
+ AC_PROG_CC
+ AC_PROG_CC_STDC
+@@ -59,7 +59,6 @@
+
+ dnl AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_HEADERS(config.h)
+-AM_INIT_AUTOMAKE([-Wall])
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
+
diff --git a/app-misc/jq/jq-1.3.ebuild b/app-misc/jq/jq-1.3.ebuild
index 2c6fb0450821..eb756fa9dbc2 100644
--- a/app-misc/jq/jq-1.3.ebuild
+++ b/app-misc/jq/jq-1.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/jq-1.3.ebuild,v 1.4 2013/07/04 12:24:59 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jq/jq-1.3.ebuild,v 1.5 2013/12/10 00:52:43 radhermit Exp $
EAPI=5
-inherit autotools
+inherit autotools eutils
DESCRIPTION="A lightweight and flexible command-line JSON processor"
HOMEPAGE="http://stedolan.github.com/jq/"
@@ -23,6 +23,7 @@ DOCS=( AUTHORS README )
src_prepare() {
sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ epatch "${FILESDIR}"/${P}-automake-1.14.patch
eautoreconf
}