summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-07-10 21:38:35 +0000
committerYixun Lan <dlan@gentoo.org>2014-07-10 21:38:35 +0000
commitabdf84e284da8a916887776dcccce7e8a4b46889 (patch)
tree23f15d579ba2c1d87f64c4fd480f4a37708cf512 /app-misc/jail
parentStable for amd64 wrt bug #509648 (diff)
downloadgentoo-2-abdf84e284da8a916887776dcccce7e8a4b46889.tar.gz
gentoo-2-abdf84e284da8a916887776dcccce7e8a4b46889.tar.bz2
gentoo-2-abdf84e284da8a916887776dcccce7e8a4b46889.zip
bug 514892, version bump, switch to new upstream, fix security issue, thanks Sergey Redin
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-misc/jail')
-rw-r--r--app-misc/jail/ChangeLog10
-rw-r--r--app-misc/jail/jail-2.0.ebuild70
-rw-r--r--app-misc/jail/metadata.xml10
3 files changed, 86 insertions, 4 deletions
diff --git a/app-misc/jail/ChangeLog b/app-misc/jail/ChangeLog
index 7079228b638f..0e8f4142ed06 100644
--- a/app-misc/jail/ChangeLog
+++ b/app-misc/jail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/jail
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/ChangeLog,v 1.31 2012/08/17 17:29:47 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/ChangeLog,v 1.32 2014/07/10 21:38:35 dlan Exp $
+
+*jail-2.0 (10 Jul 2014)
+
+ 10 Jul 2014; Yixun Lan <dlan@gentoo.org> +jail-2.0.ebuild, metadata.xml:
+ bug 514892, version bump, switch to new upstream, fix security issue, thanks
+ Sergey Redin
17 Aug 2012; Michael Palimaka <kensington@gentoo.org> -jail-1.9-r2.ebuild:
Remove old.
diff --git a/app-misc/jail/jail-2.0.ebuild b/app-misc/jail/jail-2.0.ebuild
new file mode 100644
index 000000000000..c07f836e839e
--- /dev/null
+++ b/app-misc/jail/jail-2.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jail/jail-2.0.ebuild,v 1.1 2014/07/10 21:38:35 dlan Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="a tool that builds a chroot and configures all the required files, directories and libraries"
+HOMEPAGE="https://github.com/spiculator/jail"
+SRC_URI="https://github.com/spiculator/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND="dev-lang/perl
+ dev-util/strace"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.9-gentoo.patch \
+ "${FILESDIR}"/${PN}-1.9-wrongshell.patch \
+ "${FILESDIR}"/${PN}-1.9-multiuser-rsa.patch \
+ "${FILESDIR}"/${PN}-1.9-ldflags.patch
+}
+
+src_compile() {
+ # configuration files should be installed in /etc not /usr/etc
+ sed -i "s:\$4/etc:\${D}/etc:g" install.sh || die
+
+ # the destination directory should be /usr not /usr/local
+ sed -i -e "s:usr/local:${D}/usr:g" \
+ -e "s:^COPT =.*:COPT = -Wl,-z,no:g" src/Makefile || die
+
+ # Below didn't work. Don't know why
+ #append-ldflags -Wl,-z,now
+ emake -C src CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake -C src install
+
+ # remove //var/tmp/portage/${P}/image//usr from files
+ FILES=( "${D}/usr/bin/mkjailenv"
+ "${D}/usr/bin/addjailsw"
+ "${D}/usr/bin/addjailuser"
+ "${D}/etc/jail.conf"
+ "${D}/usr/lib/libjail.pm"
+ "${D}/usr/lib/arch/generic/definitions"
+ "${D}/usr/lib/arch/generic/functions"
+ "${D}/usr/lib/arch/linux/definitions"
+ "${D}/usr/lib/arch/linux/functions"
+ "${D}/usr/lib/arch/freebsd/definitions"
+ "${D}/usr/lib/arch/freebsd/functions"
+ "${D}/usr/lib/arch/irix/definitions"
+ "${D}/usr/lib/arch/irix/functions"
+ "${D}/usr/lib/arch/solaris/definitions"
+ "${D}/usr/lib/arch/solaris/functions" )
+
+ for f in "${FILES[@]}"; do
+ sed -i "s:/${D}/usr:/usr:g" ${f} || die
+ done
+
+ sed -i "s:/usr/etc:/etc:" "${D}"/usr/lib/libjail.pm || die
+
+ dodoc doc/{CHANGELOG,INSTALL,README,SECURITY,VERSION}
+}
diff --git a/app-misc/jail/metadata.xml b/app-misc/jail/metadata.xml
index b2293010d124..48f89fef7f38 100644
--- a/app-misc/jail/metadata.xml
+++ b/app-misc/jail/metadata.xml
@@ -1,10 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
- <description>This package lacks a primary herd or maintainer.</description>
+ <email>spiculator@gmail.com</email>
+ <name>Sergey Redin</name>
+ <description>Maintainer, Assign bugs</description>
</maintainer>
+ <upstream>
+ <remote-id type="github">spiculator/jail</remote-id>
+ <bugs-to>https://github.com/spiculator/jail/issues</bugs-to>
+ </upstream>
<longdescription>
Jail Chroot Project is an attempt of write a tool that builds a chrooted environment.
The main goal of Jail is to be as simple as possible, and highly portable. The most