summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-06-20 00:53:27 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-06-20 00:53:27 +0000
commit4d26829cac93c33e892d9680ea8bbeb463e57cbd (patch)
tree9c1d1fe588aca611cb971cfa107105297e80c2c6 /app-misc/hilite/hilite-1.5.ebuild
parentVersion bump. Made CFLAGS aware and prevent stripping. (Manifest recommit) (diff)
downloadgentoo-2-4d26829cac93c33e892d9680ea8bbeb463e57cbd.tar.gz
gentoo-2-4d26829cac93c33e892d9680ea8bbeb463e57cbd.tar.bz2
gentoo-2-4d26829cac93c33e892d9680ea8bbeb463e57cbd.zip
new packagey goodness
Diffstat (limited to 'app-misc/hilite/hilite-1.5.ebuild')
-rw-r--r--app-misc/hilite/hilite-1.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/hilite/hilite-1.5.ebuild b/app-misc/hilite/hilite-1.5.ebuild
new file mode 100644
index 000000000000..9ca6d1558009
--- /dev/null
+++ b/app-misc/hilite/hilite-1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hilite/hilite-1.5.ebuild,v 1.1 2004/06/20 00:53:27 ciaranm Exp $
+
+HOMEPAGE="http://sourceforge.net/projects/hilite"
+SRC_URI="mirror://gentoo/${PN}-${PV}.c"
+DESCRIPTION="A utility which highlights stderr text in red"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~sparc ~mips"
+S=${WORKDIR}
+
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${WORKDIR}/
+}
+
+src_compile() {
+ ${CC:-gcc} ${CFLAGS} -o ${PN} ${PN}-${PV}.c \
+ || die "compile failed"
+}
+
+src_install() {
+ dobin ${WORKDIR}/hilite
+}
+