summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-01-13 14:58:18 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-01-13 14:58:18 +0000
commit15a6415e1d55dc1382e47503a51f9b4d21145fdb (patch)
treeab5ea7a7e1a1e9739ab401712345907d70cebfe3 /app-misc/gtypist
parentAdopting this (diff)
downloadgentoo-2-15a6415e1d55dc1382e47503a51f9b4d21145fdb.tar.gz
gentoo-2-15a6415e1d55dc1382e47503a51f9b4d21145fdb.tar.bz2
gentoo-2-15a6415e1d55dc1382e47503a51f9b4d21145fdb.zip
Version bump to 2.9.2 wrt to bug #451734
(Portage version: 2.1.11.31/cvs/Linux ppc64, unsigned Manifest commit)
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/ChangeLog9
-rw-r--r--app-misc/gtypist/gtypist-2.9.2.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/app-misc/gtypist/ChangeLog b/app-misc/gtypist/ChangeLog
index 5591dca86f75..15c7bf57a344 100644
--- a/app-misc/gtypist/ChangeLog
+++ b/app-misc/gtypist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gtypist
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.33 2012/12/07 04:24:33 pinkbyte Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.34 2013/01/13 14:58:18 ago Exp $
+
+*gtypist-2.9.2 (13 Jan 2013)
+
+ 13 Jan 2013; Agostino Sarubbo <ago@gentoo.org> +gtypist-2.9.2.ebuild:
+ Version bump to 2.9.2 wrt to bug #451734
07 Dec 2012; Sergey Popov <pinkbyte@gentoo.org> metadata.xml:
Assign David Abbott as primary maintainer, adding proxy maintainers herd
diff --git a/app-misc/gtypist/gtypist-2.9.2.ebuild b/app-misc/gtypist/gtypist-2.9.2.ebuild
new file mode 100644
index 000000000000..d097e5430fed
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.9.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.9.2.ebuild,v 1.1 2013/01/13 14:58:18 ago Exp $
+
+EAPI=4
+
+inherit eutils elisp-common
+
+DESCRIPTION="Universal typing tutor"
+HOMEPAGE="http://www.gnu.org/software/gtypist/"
+SRC_URI="mirror://gnu/gtypist/${P}.tar.xz
+ http://colemak.com/pub/learn/colemak.typ"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="nls emacs xemacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ emacs? ( virtual/emacs )
+ xemacs? ( !emacs? ( app-editors/xemacs app-xemacs/fsf-compat ) )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
+}
+
+src_configure() {
+ local lispdir=""
+ if use emacs; then
+ lispdir="${SITELISP}/${PN}"
+ einfo "Configuring to build with GNU Emacs support"
+ elif use xemacs; then
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/lisp/${PN}"
+ einfo "Configuring to build with XEmacs support"
+ fi
+
+ econf $(use_enable nls) \
+ EMACS=$(usev emacs || usev xemacs || echo no) \
+ --with-lispdir="${lispdir}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ insinto /usr/share/gtypist
+ doins "${DISTDIR}"/colemak.typ
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}