summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-21 20:03:01 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-21 20:03:01 +0000
commite1b56d251f8b517fc3f4b093c28a0601dd16a1b6 (patch)
treeb92a805e2f14f62044f51cd4a8114f90a8463ac3 /app-misc/gato
parentVersion bump for bug 181999. (diff)
downloadgentoo-2-e1b56d251f8b517fc3f4b093c28a0601dd16a1b6.tar.gz
gentoo-2-e1b56d251f8b517fc3f4b093c28a0601dd16a1b6.tar.bz2
gentoo-2-e1b56d251f8b517fc3f4b093c28a0601dd16a1b6.zip
Use newer features now available in portage.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-misc/gato')
-rw-r--r--app-misc/gato/ChangeLog8
-rw-r--r--app-misc/gato/files/gato-0.6.6-perms.patch13
-rw-r--r--app-misc/gato/gato-0.6.6.ebuild22
3 files changed, 31 insertions, 12 deletions
diff --git a/app-misc/gato/ChangeLog b/app-misc/gato/ChangeLog
index fc77febe9b9c..aa116d59b266 100644
--- a/app-misc/gato/ChangeLog
+++ b/app-misc/gato/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-misc/gato
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/ChangeLog,v 1.3 2006/08/19 18:14:48 wormo Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/ChangeLog,v 1.4 2007/07/21 20:03:01 vapier Exp $
+
+ 21 Jul 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/gato-0.6.6-perms.patch, gato-0.6.6.ebuild:
+ Use newer features now available in portage.
19 Aug 2006; Stephanie Lockwood-Childs <wormo@gentoo.org> gato-0.6.6.ebuild:
add RDEPEND on 'at', thanks to R. May (Bug #135751)
diff --git a/app-misc/gato/files/gato-0.6.6-perms.patch b/app-misc/gato/files/gato-0.6.6-perms.patch
new file mode 100644
index 000000000000..97709b53b1e1
--- /dev/null
+++ b/app-misc/gato/files/gato-0.6.6-perms.patch
@@ -0,0 +1,13 @@
+--- Makefile
++++ Makefile
+@@ -9,8 +9,8 @@
+ make -C src install
+
+ install.xpm::
+- install -d $(PREFIX)/share/gato
+- install xtra/xpm/*.xpm $(PREFIX)/share/gato
++ install -m755 -d $(PREFIX)/share/gato
++ install -m664 xtra/xpm/*.xpm $(PREFIX)/share/gato
+
+ clean::
+ make -C src clean
diff --git a/app-misc/gato/gato-0.6.6.ebuild b/app-misc/gato/gato-0.6.6.ebuild
index 337840abc376..eca32c27be24 100644
--- a/app-misc/gato/gato-0.6.6.ebuild
+++ b/app-misc/gato/gato-0.6.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/gato-0.6.6.ebuild,v 1.5 2006/08/19 18:14:48 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gato/gato-0.6.6.ebuild,v 1.6 2007/07/21 20:03:01 vapier Exp $
+
+inherit autotools eutils
DESCRIPTION="An interface to the at UNIX command"
HOMEPAGE="http://www.arquired.es/users/aldelgado/proy/gato/"
@@ -11,16 +13,15 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-RDEPEND="=x11-libs/gtk+-1*
+DEPEND="=x11-libs/gtk+-1*
sys-process/at"
-DEPEND="${RDEPEND}
- sys-devel/automake
- sys-devel/autoconf"
src_unpack() {
unpack ${A}
- cd "${S}/src"
- aclocal && autoheader && automake -a --foreign && autoconf || die "autotools failed"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-perms.patch
+ cd "${S}"/src
+ eautoreconf
}
src_compile() {
@@ -30,8 +31,9 @@ src_compile() {
}
src_install() {
- make install.xpm PREFIX="${D}/usr" || die "install.xpm failed"
+ emake install.xpm PREFIX="${D}/usr" || die "install.xpm failed"
+ chmod a-x "${D}"/usr/share/gato/* # fperms doesnt glob
dodoc AUTHOR CHANGELOG README TODO
cd src
- make install DESTDIR="${D}" || die "install failed"
+ emake install DESTDIR="${D}" || die "install failed"
}