summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2006-10-31 22:29:10 +0000
committerMarkus Ullmann <jokey@gentoo.org>2006-10-31 22:29:10 +0000
commit6bcd8a8dc8570c2f98dd6edde3150f8394a5bf6b (patch)
tree893884e097772164453d86bb8fc60eed8721995d /app-misc/g15daemon
parentAdd fix to enable compilation on Gentoo/FreeBSD, and keyword ~x86-fbsd. (diff)
downloadgentoo-2-6bcd8a8dc8570c2f98dd6edde3150f8394a5bf6b.tar.gz
gentoo-2-6bcd8a8dc8570c2f98dd6edde3150f8394a5bf6b.tar.bz2
gentoo-2-6bcd8a8dc8570c2f98dd6edde3150f8394a5bf6b.zip
Version bump
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'app-misc/g15daemon')
-rw-r--r--app-misc/g15daemon/ChangeLog8
-rw-r--r--app-misc/g15daemon/files/digest-g15daemon-1.2.33
-rw-r--r--app-misc/g15daemon/files/g15daemon-1.2.3.initd32
-rw-r--r--app-misc/g15daemon/g15daemon-1.2.3.ebuild131
4 files changed, 173 insertions, 1 deletions
diff --git a/app-misc/g15daemon/ChangeLog b/app-misc/g15daemon/ChangeLog
index db9659a3858e..58069be028c2 100644
--- a/app-misc/g15daemon/ChangeLog
+++ b/app-misc/g15daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/g15daemon
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.4 2006/10/24 07:57:04 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.5 2006/10/31 22:29:10 jokey Exp $
+
+*g15daemon-1.2.3 (31 Oct 2006)
+
+ 31 Oct 2006; Markus Ullmann <jokey@gentoo.org>
+ +files/g15daemon-1.2.3.initd, +g15daemon-1.2.3.ebuild:
+ Version bump
*g15daemon-1.2.1-r2 (24 Oct 2006)
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.2.3 b/app-misc/g15daemon/files/digest-g15daemon-1.2.3
new file mode 100644
index 000000000000..5691a01d5c9a
--- /dev/null
+++ b/app-misc/g15daemon/files/digest-g15daemon-1.2.3
@@ -0,0 +1,3 @@
+MD5 54b9b5b078680412db137fd373050234 g15daemon-1.2.3.tar.bz2 304548
+RMD160 897d80b4cea3aa98163b168638992f4daea4ccdd g15daemon-1.2.3.tar.bz2 304548
+SHA256 9bc3cecf17277825b8084d08e1ed6550c6e4a338cfee3604262908afac45bc9e g15daemon-1.2.3.tar.bz2 304548
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.3.initd b/app-misc/g15daemon/files/g15daemon-1.2.3.initd
new file mode 100644
index 000000000000..75350b5eaf04
--- /dev/null
+++ b/app-misc/g15daemon/files/g15daemon-1.2.3.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.2.3.initd,v 1.1 2006/10/31 22:29:10 jokey Exp $
+
+# Init script for g15daemon
+
+depend() {
+ after hotplug
+ after usb
+ after modules
+}
+
+start() {
+ ebegin "Starting g15daemon"
+
+ # Does the input device already exist?
+ if [[ -e /proc/modules && ! -e /dev/input/uinput ]] ; then
+ # We can load modules, but uinput device does not exist
+ einfo "Loading uinput module"
+ /sbin/modprobe uinput &> /dev/null
+ fi
+
+ start-stop-daemon --start --background --pidfile /var/run/g15daemon.pid --exec /usr/sbin/g15daemon
+ eend $? "Failed to start g15daemon."
+}
+
+stop() {
+ ebegin "Stopping g15daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/g15daemon.pid
+ eend $?
+}
diff --git a/app-misc/g15daemon/g15daemon-1.2.3.ebuild b/app-misc/g15daemon/g15daemon-1.2.3.ebuild
new file mode 100644
index 000000000000..037be5726a8b
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-1.2.3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.3.ebuild,v 1.1 2006/10/31 22:29:10 jokey Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils linux-info perl-module python autotools
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="perl python"
+
+DEPEND="dev-libs/libusb
+ dev-libs/libdaemon
+ dev-libs/libg15
+ perl? ( >=dev-perl/Inline-0.4 )
+ python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ linux_chkconfig_present INPUT_UINPUT
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ die "INPUT_UINPUT support not detected!"
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+}
+
+src_unpack() {
+ unpack ${A}
+ if use perl; then
+ unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+ cd "${S}"
+
+ # needed because the shipped ltmain is old and
+ # to avoid regeneration of configure by the program itself
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "configure failed"
+
+ emake || die "make failed"
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS NEWS README TODO ChangeLog
+
+ insinto /usr/share/g15daemon/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newinitd "${FILESDIR}/g15daemon-${PV}.initd" g15daemon
+
+ if use perl; then
+ einfo "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_install
+ fi
+
+ if use python; then
+ einfo "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/pyg15daemon"
+ python_version
+
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
+ doins g15daemon.py
+ newdoc AUTHORS pyg15daemon_AUTHORS
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+ einfo ""
+ fi
+
+ einfo "To use g15daemon, you need to add g15daemon to the default runlevel."
+ einfo "This can be done with:"
+ einfo "# /sbin/rc-update add g15daemon default"
+ einfo ""
+ einfo "To have all new keys working in X11,"
+ einfo "you'll need create a specific xmodmap in your home directory"
+ einfo "or edit the existant one."
+ einfo ""
+ einfo "create the xmodmap:"
+ einfo "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ einfo ""
+ einfo "adding keycodes to an existing xmodmap:"
+ einfo "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+ fi
+} \ No newline at end of file