summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-27 01:10:54 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-27 01:10:54 +0000
commit93b556867d9d7ee8692bed1a55ac6b8d51c6a71d (patch)
tree335cd38df6bb95f1d25f39410c356b367c6eecba /app-misc/dvtm
parentVersion bumped, bug #388547. (diff)
downloadgentoo-2-93b556867d9d7ee8692bed1a55ac6b8d51c6a71d.tar.gz
gentoo-2-93b556867d9d7ee8692bed1a55ac6b8d51c6a71d.tar.bz2
gentoo-2-93b556867d9d7ee8692bed1a55ac6b8d51c6a71d.zip
Version bump.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/dvtm')
-rw-r--r--app-misc/dvtm/ChangeLog8
-rw-r--r--app-misc/dvtm/dvtm-0.7.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/app-misc/dvtm/ChangeLog b/app-misc/dvtm/ChangeLog
index 8644938f4b77..03832a17cc4b 100644
--- a/app-misc/dvtm/ChangeLog
+++ b/app-misc/dvtm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/dvtm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dvtm/ChangeLog,v 1.7 2011/06/02 12:15:00 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dvtm/ChangeLog,v 1.8 2011/10/27 01:10:54 chithanh Exp $
+
+*dvtm-0.7 (27 Oct 2011)
+
+ 27 Oct 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +dvtm-0.7.ebuild:
+ Version bump.
02 Jun 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
-dvtm-0.5.2.ebuild:
diff --git a/app-misc/dvtm/dvtm-0.7.ebuild b/app-misc/dvtm/dvtm-0.7.ebuild
new file mode 100644
index 000000000000..1b934980fc2d
--- /dev/null
+++ b/app-misc/dvtm/dvtm-0.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dvtm/dvtm-0.7.ebuild,v 1.1 2011/10/27 01:10:54 chithanh Exp $
+
+EAPI=3
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Dynamic virtual terminal manager"
+HOMEPAGE="http://www.brain-dump.org/projects/dvtm/"
+SRC_URI="http://www.brain-dump.org/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+DEPEND="sys-libs/ncurses[unicode?]"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ sed -i \
+ -e 's|FLAGS =|FLAGS +=|' \
+ -e 's|-I/usr/local/include||' \
+ -e 's|-L/usr/local/lib||' \
+ -e 's|-Os||' \
+ config.mk || die "sed config.mk failed"
+ use unicode || {
+ sed -i \
+ -e 's|-lncursesw|-lncurses|' \
+ config.mk || die "sed config.mk failed"
+ }
+ sed -i \
+ -e '/strip/d' \
+ Makefile || die "sed Makefile failed"
+
+ use savedconfig && restore_config config.h
+}
+
+src_compile() {
+ local msg=""
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) ${PN} || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h || die "newins failed"
+
+ dodoc README || die "dodoc failed"
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ elog "This ebuild has support for user defined configs"
+ elog "Please read this ebuild for more details and re-emerge as needed"
+ elog "if you want to add or remove functionality for ${PN}"
+}