summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-20 08:21:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-20 08:21:28 +0000
commita1b9b04a46a858425ad404edbf151de7275408cc (patch)
tree6dcafafcb28de5e8e2faa6d5eb3b4f39126bad17 /app-misc/ddccontrol/ddccontrol-0.2.ebuild
parentBug #103062, use a slightly better PCI bug patch. (diff)
downloadgentoo-2-a1b9b04a46a858425ad404edbf151de7275408cc.tar.gz
gentoo-2-a1b9b04a46a858425ad404edbf151de7275408cc.tar.bz2
gentoo-2-a1b9b04a46a858425ad404edbf151de7275408cc.zip
Bug #102383, version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-misc/ddccontrol/ddccontrol-0.2.ebuild')
-rw-r--r--app-misc/ddccontrol/ddccontrol-0.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/ddccontrol/ddccontrol-0.2.ebuild b/app-misc/ddccontrol/ddccontrol-0.2.ebuild
new file mode 100644
index 000000000000..c0e9693451a2
--- /dev/null
+++ b/app-misc/ddccontrol/ddccontrol-0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ddccontrol/ddccontrol-0.2.ebuild,v 1.1 2005/08/20 08:21:28 robbat2 Exp $
+
+DESCRIPTION="DDCControl"
+HOMEPAGE="http://ddccontrol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gtk doc nls"
+
+RDEPEND="dev-libs/libxml2
+ gtk? ( >=x11-libs/gtk+-2.4 )
+ sys-apps/pciutils
+ nls? ( sys-devel/gettext )
+ >=app-misc/ddccontrol-db-20050813"
+DEPEND="${RDEPEND}
+ doc? ( >=app-text/docbook-xsl-stylesheets-1.65.1
+ >=dev-libs/libxslt-1.1.6
+ app-text/htmltidy )
+ sys-kernel/linux-headers"
+
+src_compile() {
+ econf $(use_enable doc) \
+ $(use_enable gtk gnome) \
+ $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" htmldir="/usr/share/doc/${PF}/html" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}