summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-16 17:03:57 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-16 17:03:57 +0000
commita36269968f6202510ec5eeae20256fd0fff2709c (patch)
tree7a9ac4a9c19053925ca7115721008fbb33e6fdfd /app-misc/cw/cw-1.0.16-r1.ebuild
parentvirtual/glut -> media-libs/glut (diff)
downloadgentoo-2-a36269968f6202510ec5eeae20256fd0fff2709c.tar.gz
gentoo-2-a36269968f6202510ec5eeae20256fd0fff2709c.tar.bz2
gentoo-2-a36269968f6202510ec5eeae20256fd0fff2709c.zip
Fix patch to really respect LDFLAGS and to compile something useful, by Czeryna Karol (bug #337509).
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'app-misc/cw/cw-1.0.16-r1.ebuild')
-rw-r--r--app-misc/cw/cw-1.0.16-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/cw/cw-1.0.16-r1.ebuild b/app-misc/cw/cw-1.0.16-r1.ebuild
new file mode 100644
index 000000000000..de4de575744a
--- /dev/null
+++ b/app-misc/cw/cw-1.0.16-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/cw-1.0.16-r1.ebuild,v 1.1 2010/09/16 17:03:57 jer Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A non-intrusive real-time ANSI color wrapper for common unix-based commands"
+HOMEPAGE="http://cwrapper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cwrapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ sed -i 's|\(CWLIB=\)/usr/local/lib/cw|\1/usr/libexec/cw|' bin/colorcfg || \
+ die "sed failed"
+ tc-export CC
+}
+
+src_compile() {
+ emake local || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/share/cw
+ doins etc/* || die
+
+ exeinto /usr/libexec/cw
+ doexe def/* || die
+
+ doman man/* || die
+ dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README* || die
+
+ dobin bin/{cw,cwu,colorcfg} || die
+ # app-misc/color currently conflicts; hopefully 'colors' is safe
+ newbin bin/color colors
+}
+
+pkg_postinst() {
+ ebegin "Updating definition files"
+ cwu /usr/libexec/cw /usr/bin/cw >/dev/null
+ eend $?
+
+ elog "To enable color-wrapper, as your user, run:"
+ elog " colorcfg [1|2|3]"
+ elog "to add relevant environment variables to your ~/.bash_profile"
+ elog "Run colorcfg without options to see what [1|2|3] means."
+ elog
+ elog "After sourcing your ~/.bash_profile, commands for which definitions"
+ elog "are provided should have colored output."
+ elog
+ elog "To enable/disable colored output, run: 'colors [on|off]'."
+}