summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-12-16 02:28:10 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-12-16 02:28:10 +0000
commited909a1038624a89e003bb8737a7dcf676f022d6 (patch)
treec06aedca2da01b87d05aaa3a5ee7003e9d053ef8 /app-misc/beagle
parentStable for HPPA (bug #158182). (diff)
downloadgentoo-2-ed909a1038624a89e003bb8737a7dcf676f022d6.tar.gz
gentoo-2-ed909a1038624a89e003bb8737a7dcf676f022d6.tar.bz2
gentoo-2-ed909a1038624a89e003bb8737a7dcf676f022d6.zip
Version Bump. This release got the xdg autostart files fixes bug #128839.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-misc/beagle')
-rw-r--r--app-misc/beagle/ChangeLog7
-rw-r--r--app-misc/beagle/beagle-0.2.14.ebuild142
-rw-r--r--app-misc/beagle/files/digest-beagle-0.2.143
3 files changed, 151 insertions, 1 deletions
diff --git a/app-misc/beagle/ChangeLog b/app-misc/beagle/ChangeLog
index c8514471079f..3b1e24b564a8 100644
--- a/app-misc/beagle/ChangeLog
+++ b/app-misc/beagle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/beagle
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.40 2006/11/20 22:13:23 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/ChangeLog,v 1.41 2006/12/16 02:28:10 metalgod Exp $
+
+*beagle-0.2.14 (16 Dec 2006)
+
+ 16 Dec 2006; Luis Medinas <metalgod@gentoo.org> +beagle-0.2.14.ebuild:
+ Version Bump. This release got the xdg autostart files fixes bug #128839.
*beagle-0.2.13 (20 Nov 2006)
diff --git a/app-misc/beagle/beagle-0.2.14.ebuild b/app-misc/beagle/beagle-0.2.14.ebuild
new file mode 100644
index 000000000000..53beb25373e1
--- /dev/null
+++ b/app-misc/beagle/beagle-0.2.14.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/beagle/beagle-0.2.14.ebuild,v 1.1 2006/12/16 02:28:10 metalgod Exp $
+
+inherit gnome.org eutils autotools mono
+
+DESCRIPTION="search tool that ransacks your personal information space to find whatever you're looking for"
+HOMEPAGE="http://www.beagle-project.org/"
+
+LICENSE="MIT Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="chm debug doc evo galago gtk ole pdf python thunderbird"
+
+RDEPEND="
+ >=dev-lang/mono-1.1.16.1
+ app-shells/bash
+ app-arch/zip
+ sys-devel/gettext
+ >=x11-libs/gtk+-2.6.0
+ >=dev-libs/atk-1.2.4
+ >=dev-libs/gmime-2.2.1
+ >=dev-dotnet/gtk-sharp-2.8
+ >=gnome-base/librsvg-2.0
+ >=media-libs/libexif-0.6.0
+ >=dev-libs/libxml2-2.6.19
+ >=dev-dotnet/gsf-sharp-0.6
+
+ || ( >=dev-db/sqlite-3.3.1
+ =dev-db/sqlite-2* )
+
+ || ( ( x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXt )
+ virtual/x11 )
+
+ gtk? ( >=dev-dotnet/gconf-sharp-2.8
+ >=dev-dotnet/glade-sharp-2.8
+ >=dev-dotnet/gnome-sharp-2.8 )
+
+ python? ( >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6 )
+
+ evo? ( >=dev-dotnet/evolution-sharp-0.10.2
+ >=dev-dotnet/gconf-sharp-2.3 )
+
+ ole? ( >=app-text/wv-1.2.0
+ >=app-office/gnumeric-1.4.3-r3 )
+ pdf? ( >=app-text/poppler-0.5.1 )
+ chm? ( app-doc/chmlib )
+ galago? ( >=dev-dotnet/galago-sharp-0.5.0 )
+ doc? ( dev-util/gtk-doc )
+ thunderbird? ( >=mail-client/mozilla-thunderbird-1.5 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( ( x11-proto/xproto
+ x11-proto/scrnsaverproto )
+ virtual/x11 )"
+
+pkg_setup() {
+ if built_with_use dev-libs/gmime mono
+ then
+ einfo "Mono support enabled in dev-libs/gmime, I will continue..."
+ else
+ eerror "Please rebuild dev-libs/gmime, with mono support enabled!"
+ eerror "Try USE=\"mono\" emerge dev-libs/gmime,"
+ eerror "or add \"mono\" to your USE string in /etc/make.conf and"
+ eerror "emerge dev-libs/gmime."
+ die "Mono USE flag must be enabled in dev-libs/gmime"
+ fi
+
+ enewgroup beagleindex
+ enewuser beagleindex -1 -1 /var/lib/cache/beagle beagleindex
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # To prevent excessive revdep-rebuild, gentoo's libexif is sticking to
+ # soversion 10 for now.
+ sed -i -e 's/EXIF_SOVERSION=12/EXIF_SOVERSION=10/' configure.in
+
+ # Multilib fix
+ sed -i -e 's:prefix mono`/lib:libdir mono`:' \
+ ${S}/configure.in || die "sed failed"
+
+ # Don't log so much
+ ! use debug && sed -i -e \
+ 's/defaultLevel = LogLevel.Debug/defaultLevel = LogLevel.Info/' \
+ Util/Logger.cs
+
+ epatch ${FILESDIR}/${PN}-0.2.7-crawltweek.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable thunderbird) \
+ $(use_enable evo evolution) \
+ $(use_enable gtk gui) \
+ $(use_enable python ) \
+ --enable-libbeagle \
+ || die "configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed!"
+
+ dodir /usr/share/beagle
+ insinto /usr/share/beagle
+ doins mozilla-extension/beagle.xpi
+
+ dodoc AUTHORS INSTALL NEWS README
+
+ sed -i 's/CRAWL_ENABLED="yes"/CRAWL_ENABLED="no"/' ${D}/etc/beagle/crawl-*
+
+ insinto /etc/beagle
+ doins ${FILESDIR}/crawl-portage
+
+ keepdir /usr/$(get_libdir)/beagle/Backends
+ diropts -o beagleindex -g beagleindex
+ keepdir /var/lib/cache/beagle/indexes
+}
+
+pkg_postinst() {
+ einfo "If available, Beagle greatly benefits from using certain operating"
+ einfo "system features such as Extended Attributes and inotify."
+ echo
+ einfo "If you want static queryables such as the portage tree and system"
+ einfo "documentation you will need to edit the /etc/beagle/crawl-* files"
+ einfo "and change CRAWL_ENABLE from 'no' to 'yes'."
+ echo
+ einfo "For more info on how to create the optimal beagle environment, and"
+ einfo "basic usage info, see the Gentoo page of the Beagle website:"
+ einfo " http://www.beagle-project.org/Gentoo_Installation"
+}
+
diff --git a/app-misc/beagle/files/digest-beagle-0.2.14 b/app-misc/beagle/files/digest-beagle-0.2.14
new file mode 100644
index 000000000000..4c8e3c844473
--- /dev/null
+++ b/app-misc/beagle/files/digest-beagle-0.2.14
@@ -0,0 +1,3 @@
+MD5 c3eeccdafc030a7d283bf85b75f5c0bb beagle-0.2.14.tar.bz2 1568139
+RMD160 f5c8eedfc390422708708730e8f0f8d2733987fc beagle-0.2.14.tar.bz2 1568139
+SHA256 115119b74ec263c9ca2e6d91a41ad65126d2a2d342fa4a8c4e3002c4c3551388 beagle-0.2.14.tar.bz2 1568139