summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-03-14 19:50:09 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-03-14 19:50:09 +0000
commitbfac657d740bd54af583174aff438f2c8c293f2e (patch)
tree67d5df650fe5ea957c1980d66bbf1bf1cc692143 /app-misc/actkbd
parentFix nssbits handling when cross-compiling. (diff)
downloadgentoo-2-bfac657d740bd54af583174aff438f2c8c293f2e.tar.gz
gentoo-2-bfac657d740bd54af583174aff438f2c8c293f2e.tar.bz2
gentoo-2-bfac657d740bd54af583174aff438f2c8c293f2e.zip
Revision bump to add initscript and config file. Bump the ebuild to eapi5. The new layout utilizes initscript rather than udev rule which didn't want to behave correctly on my machine.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-misc/actkbd')
-rw-r--r--app-misc/actkbd/ChangeLog13
-rw-r--r--app-misc/actkbd/actkbd-0.2.8-r1.ebuild49
-rw-r--r--app-misc/actkbd/files/actkbd.confd13
-rw-r--r--app-misc/actkbd/files/actkbd.initd32
4 files changed, 104 insertions, 3 deletions
diff --git a/app-misc/actkbd/ChangeLog b/app-misc/actkbd/ChangeLog
index e9dabaf8f549..ec300683dda0 100644
--- a/app-misc/actkbd/ChangeLog
+++ b/app-misc/actkbd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-misc/actkbd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/actkbd/ChangeLog,v 1.9 2011/03/04 08:12:18 tomka Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/actkbd/ChangeLog,v 1.10 2013/03/14 19:50:09 scarabeus Exp $
+
+*actkbd-0.2.8-r1 (14 Mar 2013)
+
+ 14 Mar 2013; Tomáš Chvátal <scarabeus@gentoo.org> +actkbd-0.2.8-r1.ebuild,
+ +files/actkbd.confd, +files/actkbd.initd:
+ Revision bump to add initscript and config file. Bump the ebuild to eapi5. The
+ new layout utilizes initscript rather than udev rule which didn't want to
+ behave correctly on my machine.
04 Mar 2011; Thomas Kahle <tomka@gentoo.org> actkbd-0.2.8.ebuild:
x86 stable per bug 345203
@@ -39,4 +47,3 @@
07 Mar 2006; Sven Wegener <swegener@gentoo.org> +metadata.xml,
+actkbd-0.2.2.ebuild:
Initial commit, ebuild written by me.
-
diff --git a/app-misc/actkbd/actkbd-0.2.8-r1.ebuild b/app-misc/actkbd/actkbd-0.2.8-r1.ebuild
new file mode 100644
index 000000000000..b115631288bf
--- /dev/null
+++ b/app-misc/actkbd/actkbd-0.2.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/actkbd/actkbd-0.2.8-r1.ebuild,v 1.1 2013/03/14 19:50:09 scarabeus Exp $
+
+EAPI=5
+
+inherit linux-info eutils toolchain-funcs
+
+DESCRIPTION="A keyboard shortcut daemon"
+HOMEPAGE="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/"
+SRC_URI="http://users.softlab.ece.ntua.gr/~thkala/projects/actkbd/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+CONFIG_CHECK="~INPUT_EVDEV"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.2.7-amd64.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin actkbd
+ dodoc AUTHORS ChangeLog FAQ README TODO
+ docinto samples
+ dodoc samples/actkbd.conf
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}
+
+pkg_postinst() {
+ elog
+ elog "System-wide configuration file is /etc/actkbd.conf."
+ elog "Use actkbd.conf from usr/share/doc/${PF}/samples as a template."
+ elog "You need to create the config and set right input device from"
+ elog "/dev/input/event* in /etc/conf.d/actkbd"
+ elog
+ elog "To obtain keycodes for pressed combinations/keys just run:"
+ elog " # actkbd -s -d /dev/input/event<MYDEVICENUMBER>"
+}
diff --git a/app-misc/actkbd/files/actkbd.confd b/app-misc/actkbd/files/actkbd.confd
new file mode 100644
index 000000000000..9c6c850c8280
--- /dev/null
+++ b/app-misc/actkbd/files/actkbd.confd
@@ -0,0 +1,13 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/actkbd/files/actkbd.confd,v 1.1 2013/03/14 19:50:09 scarabeus Exp $
+
+# Configuration file
+CONFIG="/etc/actkbd.conf"
+
+# Event provider providing the keypress events
+EVENT_DEVICE="/dev/input/<DEVICE>"
+
+# PID
+PIDFILE="/var/run/actkbd.pid"
+
diff --git a/app-misc/actkbd/files/actkbd.initd b/app-misc/actkbd/files/actkbd.initd
new file mode 100644
index 000000000000..67dc29a3f8f8
--- /dev/null
+++ b/app-misc/actkbd/files/actkbd.initd
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/actkbd/files/actkbd.initd,v 1.1 2013/03/14 19:50:09 scarabeus Exp $
+
+checkconfig() {
+ if [ ! -f ${CONFIG} ] ; then
+ eerror "Config file \"${CONFIG}\" does not exist. Create it prior launching the daemon."
+ return 1
+ fi
+ if [ ! -c ${EVENT_DEVICE} ] ; then
+ eerror "Device \"${EVENT_DEVICE}\" is not valid pointer to input provider."
+ return 1
+ fi
+}
+
+depend() {
+ before acpid
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting actkbd"
+ start-stop-daemon --start --quiet --pidfile ${PIDFILE} --exec /usr/bin/actkbd -- -c "${CONFIG}" -D -q -x -l -p "${PIDFILE}" -d "${EVENT_DEVICE}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping actkbd"
+ start-stop-daemon --stop --quiet --pidfile ${PIDFILE} --exec /usr/bin/actkbd
+ eend $?
+}