summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-12-04 00:31:06 +0000
committerMichael Weber <xmw@gentoo.org>2012-12-04 00:31:06 +0000
commit0c87935fb17a61e509a6c496441b39ae6a9576f3 (patch)
tree3310c4f253f71894f567a5b1f58dad116eef065a /app-laptop
parentminor patch to 2.48-r2, fixes bug #425748 , thanks to Alexey Kretov (domini ... (diff)
downloadgentoo-2-0c87935fb17a61e509a6c496441b39ae6a9576f3.tar.gz
gentoo-2-0c87935fb17a61e509a6c496441b39ae6a9576f3.tar.bz2
gentoo-2-0c87935fb17a61e509a6c496441b39ae6a9576f3.zip
Revbump to respect config file.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/ChangeLog8
-rw-r--r--app-laptop/thinkfan/files/thinkfan-0.8.1-openrc.patch11
-rw-r--r--app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild39
3 files changed, 57 insertions, 1 deletions
diff --git a/app-laptop/thinkfan/ChangeLog b/app-laptop/thinkfan/ChangeLog
index 4fdc21f1e9e2..b64a4bd13b77 100644
--- a/app-laptop/thinkfan/ChangeLog
+++ b/app-laptop/thinkfan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/thinkfan
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.9 2012/10/06 09:46:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.10 2012/12/04 00:31:06 xmw Exp $
+
+*thinkfan-0.8.1-r1 (04 Dec 2012)
+
+ 04 Dec 2012; Michael Weber <xmw@gentoo.org> +thinkfan-0.8.1-r1.ebuild,
+ +files/thinkfan-0.8.1-openrc.patch:
+ Revbump to respect config file.
*thinkfan-0.8.1 (06 Oct 2012)
diff --git a/app-laptop/thinkfan/files/thinkfan-0.8.1-openrc.patch b/app-laptop/thinkfan/files/thinkfan-0.8.1-openrc.patch
new file mode 100644
index 000000000000..82acbe91de39
--- /dev/null
+++ b/app-laptop/thinkfan/files/thinkfan-0.8.1-openrc.patch
@@ -0,0 +1,11 @@
+--- thinkfan-0.8.1/rcscripts/thinkfan.gentoo
++++ thinkfan-0.8.1/rcscripts/thinkfan.gentoo
+@@ -11,7 +11,7 @@
+
+ start() {
+ ebegin "Starting thinkfan"
+- start-stop-daemon --start --exec /usr/sbin/thinkfan -- -q -s5
++ start-stop-daemon --start --exec /usr/sbin/thinkfan -- -q -s5 -c /etc/thinkfan.conf
+ eend $?
+ }
+
diff --git a/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild b/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..072889cad162
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/thinkfan-0.8.1-r1.ebuild,v 1.1 2012/12/04 00:31:06 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openrc.patch
+ tc-export CC
+}
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd rcscripts/thinkfan.gentoo ${PN}
+
+ doman ${PN}.1
+ dodoc ChangeLog NEWS README \
+ examples/${PN}.conf.{complex,sysfs,thinkpad}
+}
+
+pkg_postinst() {
+ elog "Please read the documentation and copy an"
+ elog "appropriate file to /etc/thinkfan.conf."
+}