summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-02-22 15:21:10 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-02-22 15:21:10 +0000
commit05e73506e30f92262068c1269bc3c3c0b0ac3d27 (patch)
treebb6a7dee88fe3455911a08ad8017b1ef769377ee /app-laptop/fnfx
parentremove openmotif and gimp-print (diff)
downloadgentoo-2-05e73506e30f92262068c1269bc3c3c0b0ac3d27.tar.gz
gentoo-2-05e73506e30f92262068c1269bc3c3c0b0ac3d27.tar.bz2
gentoo-2-05e73506e30f92262068c1269bc3c3c0b0ac3d27.zip
Moved from net-wireless/fnfx to app-laptop/fnfx.
Diffstat (limited to 'app-laptop/fnfx')
-rw-r--r--app-laptop/fnfx/ChangeLog20
-rw-r--r--app-laptop/fnfx/Manifest5
-rw-r--r--app-laptop/fnfx/files/digest-fnfx-0.31
-rw-r--r--app-laptop/fnfx/files/fnfxd19
-rw-r--r--app-laptop/fnfx/fnfx-0.3.ebuild32
-rw-r--r--app-laptop/fnfx/metadata.xml5
6 files changed, 82 insertions, 0 deletions
diff --git a/app-laptop/fnfx/ChangeLog b/app-laptop/fnfx/ChangeLog
new file mode 100644
index 000000000000..126ebb9ebc03
--- /dev/null
+++ b/app-laptop/fnfx/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for net-wireless/fnfx
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/fnfx/ChangeLog,v 1.1 2005/02/22 15:21:10 genstef Exp $
+
+*fnfx-0.3 (22 Feb 2005)
+
+ 22 Feb 2005; Stefan Schweizer <genstef@gentoo.org> +metadata.xml,
+ +files/fnfxd, +fnfx-0.3.ebuild:
+ Moved from net-wireless/fnfx to app-laptop/fnfx.
+
+*fnfx-0.3 (28 Jan 2005)
+
+ 28 Jan 2005; Stefan Schweizer <genstef@gentoo.org> +metadata.xml,
+ +files/fnfxd, +fnfx-0.3.ebuild:
+ New ebuild thanks to stephan <stephan-01@gmx.de>, Ben Ford
+ <ben@kalifornia.com>, Julioromano <romanomarco@tin.it>, Kalin KOZHUHAROV
+ <kalin@ThinRope.net>, Nik Raub <niknik79@bossmail.de>, azote
+ <azote@slinux.net>, Claudio Corsi <corsic@cli.di.unipi.it> and Wolfgang
+ Frisch <xororand@frexx.de> in bug 33335
+
diff --git a/app-laptop/fnfx/Manifest b/app-laptop/fnfx/Manifest
new file mode 100644
index 000000000000..113a563806ac
--- /dev/null
+++ b/app-laptop/fnfx/Manifest
@@ -0,0 +1,5 @@
+MD5 4cf6c0a8ae7464c53fac1f8ad6f423c1 fnfx-0.3.ebuild 841
+MD5 c0a335c1da2b403686658f7f18e3cec1 ChangeLog 651
+MD5 19fd766bac8e110b4620363a1ace26dd metadata.xml 159
+MD5 9ddd5b781f32238c2f6797c0e6dfae19 files/fnfxd 411
+MD5 8d3d676799a48f69c783751321267157 files/digest-fnfx-0.3 59
diff --git a/app-laptop/fnfx/files/digest-fnfx-0.3 b/app-laptop/fnfx/files/digest-fnfx-0.3
new file mode 100644
index 000000000000..967679d6a082
--- /dev/null
+++ b/app-laptop/fnfx/files/digest-fnfx-0.3
@@ -0,0 +1 @@
+MD5 2487730494a8ff86d83d9cf7e6a67325 fnfx-0.3.tar.gz 98430
diff --git a/app-laptop/fnfx/files/fnfxd b/app-laptop/fnfx/files/fnfxd
new file mode 100644
index 000000000000..31af8f7a837e
--- /dev/null
+++ b/app-laptop/fnfx/files/fnfxd
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Enabling Toshiba function keys"
+ start-stop-daemon --start --quiet --exec /usr/sbin/fnfxd
+ eend ${?}
+}
+
+stop() {
+ ebegin "Disabling Toshiba function keys"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/fnfxd
+ eend ${?}
+}
diff --git a/app-laptop/fnfx/fnfx-0.3.ebuild b/app-laptop/fnfx/fnfx-0.3.ebuild
new file mode 100644
index 000000000000..912fae7c0218
--- /dev/null
+++ b/app-laptop/fnfx/fnfx-0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/fnfx/fnfx-0.3.ebuild,v 1.1 2005/02/22 15:21:10 genstef Exp $
+
+DESCRIPTION="Daemon and client allowing use of Toshiba special keys"
+HOMEPAGE="http://fnfx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fnfx/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/fnfxd fnfxd
+
+ dodoc AUTHORS README ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ einfo
+ einfo "The Fnfx Toshiba function key package has been installed."
+ einfo
+ einfo "If you would like the service to start automatically on boot"
+ einfo "please execute the command rc-update add fnfxd default."
+ einfo
+ echo
+}
diff --git a/app-laptop/fnfx/metadata.xml b/app-laptop/fnfx/metadata.xml
new file mode 100644
index 000000000000..b27ff8eb4ed6
--- /dev/null
+++ b/app-laptop/fnfx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>mobile</herd>
+</pkgmetadata>