summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-06-26 12:21:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-06-26 12:21:20 +0000
commita6b48bf29e073f4accbd91d8f11bdceefaa0c73a (patch)
tree5289a7de7e0aa849e05c3d5ae5cb947275cda7be /app-laptop/configure-trackpoint
parentVersion bump. Don't use versionator.eclass. Remove old. (diff)
downloadgentoo-2-a6b48bf29e073f4accbd91d8f11bdceefaa0c73a.tar.gz
gentoo-2-a6b48bf29e073f4accbd91d8f11bdceefaa0c73a.tar.bz2
gentoo-2-a6b48bf29e073f4accbd91d8f11bdceefaa0c73a.zip
Initial commit of configure-trackpoint, a configuration utility for app-laptop/tp_smapi
(Portage version: 2.1.9.49/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/configure-trackpoint')
-rw-r--r--app-laptop/configure-trackpoint/ChangeLog11
-rw-r--r--app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild44
-rw-r--r--app-laptop/configure-trackpoint/metadata.xml18
3 files changed, 73 insertions, 0 deletions
diff --git a/app-laptop/configure-trackpoint/ChangeLog b/app-laptop/configure-trackpoint/ChangeLog
new file mode 100644
index 000000000000..a61eb80055ac
--- /dev/null
+++ b/app-laptop/configure-trackpoint/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-laptop/configure-trackpoint
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/ChangeLog,v 1.1 2011/06/26 12:21:20 hwoarang Exp $
+
+*configure-trackpoint-0.7 (26 Jun 2011)
+
+ 26 Jun 2011; Markos Chandras <hwoarang@gentoo.org>
+ +configure-trackpoint-0.7.ebuild, +metadata.xml:
+ Initial commit of configure-trackpoint, a configuration utility for
+ app-laptop/tp_smapi
+
diff --git a/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild b/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild
new file mode 100644
index 000000000000..93528bb53161
--- /dev/null
+++ b/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/configure-trackpoint/configure-trackpoint-0.7.ebuild,v 1.1 2011/06/26 12:21:20 hwoarang Exp $
+
+EAPI=2
+inherit gnome2
+
+DESCRIPTION="Thinkpad GNOME configuration utility for tp_smapi"
+HOMEPAGE="http://tpctl.sourceforge.net/configure-thinkpad.html"
+SRC_URI="mirror://sourceforge/tpctl/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-laptop/tp_smapi
+ >=x11-libs/gtk+-2.2:2
+ || ( x11-libs/gksu kde-base/kdesu )
+ >=gnome-base/libgnomeui-2.4
+ >=sys-devel/gettext-0.11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ if has_version kde-base/kdesu && ! has_version x11-libs/gksu; then
+ sed -i -e "/^Exec/s:gksu:kdesu:" ${PN}.desktop \
+ || die "Failed to replace gksu with kdesu"
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ G2CONF="--disable-dependency-tracking --disable-maintainer-mode"
+ gnome2_src_configure
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog
+ elog "The ${PN} does not automatically load the app-laptop/tp_smapi modules"
+ elog "so you need to do it manually"
+ elog
+}
diff --git a/app-laptop/configure-trackpoint/metadata.xml b/app-laptop/configure-trackpoint/metadata.xml
new file mode 100644
index 000000000000..12fba324e931
--- /dev/null
+++ b/app-laptop/configure-trackpoint/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer>
+<email>orfanosm@ceid.upatras.gr</email>
+<name>Markellos Orfanos</name>
+<description>Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+