summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-03-06 20:24:54 +0000
committerYixun Lan <dlan@gentoo.org>2015-03-06 20:24:54 +0000
commitf376b53c6efb28ec61f97e6eca079b41d73eb0aa (patch)
tree07691dba4c342e33aea19c7a8044a37e97203f6a /app-i18n
parentStable for amd64 wrt bug #538176 (diff)
downloadgentoo-2-f376b53c6efb28ec61f97e6eca079b41d73eb0aa.tar.gz
gentoo-2-f376b53c6efb28ec61f97e6eca079b41d73eb0aa.tar.bz2
gentoo-2-f376b53c6efb28ec61f97e6eca079b41d73eb0aa.zip
version bump, bug 542188, thanks Brendan Horan
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-cangjie/ChangeLog7
-rw-r--r--app-i18n/ibus-cangjie/ibus-cangjie-2.3.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-i18n/ibus-cangjie/ChangeLog b/app-i18n/ibus-cangjie/ChangeLog
index f0c285dae7b9..eb2d5c86d14a 100644
--- a/app-i18n/ibus-cangjie/ChangeLog
+++ b/app-i18n/ibus-cangjie/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-cangjie
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-cangjie/ChangeLog,v 1.4 2015/02/28 07:57:50 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-cangjie/ChangeLog,v 1.5 2015/03/06 20:24:54 dlan Exp $
+
+*ibus-cangjie-2.3 (06 Mar 2015)
+
+ 06 Mar 2015; Yixun Lan <dlan@gentoo.org> +ibus-cangjie-2.3.ebuild:
+ version bump, bug 542188, thanks Brendan Horan
*ibus-cangjie-2.2 (27 Feb 2015)
diff --git a/app-i18n/ibus-cangjie/ibus-cangjie-2.3.ebuild b/app-i18n/ibus-cangjie/ibus-cangjie-2.3.ebuild
new file mode 100644
index 000000000000..98a92691a5a6
--- /dev/null
+++ b/app-i18n/ibus-cangjie/ibus-cangjie-2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-cangjie/ibus-cangjie-2.3.ebuild,v 1.1 2015/03/06 20:24:54 dlan Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3,3_4} )
+
+inherit autotools-utils gnome2-utils python-r1 eutils
+
+DESCRIPTION="The IBus engine for users of the Cangjie and Quick input methods"
+HOMEPAGE="http://cangjians.github.io"
+SRC_URI="https://github.com/Cangjians/ibus-cangjie/releases/download/v${PV}/ibus-cangjie-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/ibus-1.4.1
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ dev-util/intltool
+ sys-devel/gettext"
+
+RDEPEND=">=app-i18n/ibus-1.4.1
+ app-i18n/libcangjie
+ dev-python/cangjie[${PYTHON_USEDEP}]
+ virtual/libintl
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}