summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-08-15 01:21:59 +0000
committerNaohiro Aota <naota@gentoo.org>2012-08-15 01:21:59 +0000
commita3cd827ca485899ef82aaa8ff167944b80e86e18 (patch)
tree43e174c86e357a98c2f6c86bf39b08411dd5e6c4 /app-i18n
parentStable ppc, bug #429076 (diff)
downloadgentoo-2-a3cd827ca485899ef82aaa8ff167944b80e86e18.tar.gz
gentoo-2-a3cd827ca485899ef82aaa8ff167944b80e86e18.tar.bz2
gentoo-2-a3cd827ca485899ef82aaa8ff167944b80e86e18.zip
version bump. #430410
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim/ChangeLog8
-rw-r--r--app-i18n/scim/scim-1.4.14.ebuild91
2 files changed, 97 insertions, 2 deletions
diff --git a/app-i18n/scim/ChangeLog b/app-i18n/scim/ChangeLog
index 50a4ee8a78bb..2ef6314e2b6d 100644
--- a/app-i18n/scim/ChangeLog
+++ b/app-i18n/scim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.157 2012/08/05 18:03:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/ChangeLog,v 1.158 2012/08/15 01:21:59 naota Exp $
+
+*scim-1.4.14 (15 Aug 2012)
+
+ 15 Aug 2012; Naohiro Aota <naota@gentoo.org> +scim-1.4.14.ebuild:
+ version bump. #430410
05 Aug 2012; Raúl Porcel <armin76@gentoo.org> scim-1.4.11-r1.ebuild:
alpha/sparc stable wrt #422875
@@ -660,4 +665,3 @@
25 May 2003; Alastair Tse <liquidx@gentoo.org> scim-0.4.1.ebuild:
New ebuild of another Chinese Input System
-
diff --git a/app-i18n/scim/scim-1.4.14.ebuild b/app-i18n/scim/scim-1.4.14.ebuild
new file mode 100644
index 000000000000..e54fe25d8594
--- /dev/null
+++ b/app-i18n/scim/scim-1.4.14.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim/scim-1.4.14.ebuild,v 1.1 2012/08/15 01:21:59 naota Exp $
+
+EAPI="4"
+inherit eutils flag-o-matic multilib gnome2-utils autotools-utils
+
+DESCRIPTION="Smart Common Input Method (SCIM) is an Input Method (IM) development platform"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="mirror://sourceforge/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/libX11
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ >=dev-libs/atk-1
+ >=x11-libs/pango-1
+ !app-i18n/scim-cvs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ >=app-text/docbook-xsl-stylesheets-1.73.1 )
+ dev-lang/perl
+ virtual/pkgconfig
+ >=dev-util/intltool-0.33
+ sys-devel/libtool"
+DOCS=(
+ README
+ AUTHORS
+ ChangeLog
+ docs/developers
+ docs/scim.cfg
+)
+
+src_configure() {
+ # bug #83625
+ filter-flags -fvisibility-inlines-hidden -fvisibility=hidden
+ local myeconfargs=(
+ $(use_with doc doxygen)
+ --enable-ld-version-script
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
+ autotools-utils_src_install
+
+ sed -e "s:@EPREFIX@:${EPREFIX}:" "${FILESDIR}/xinput-${PN}" > "${T}/${PN}.conf" || die
+ insinto /etc/X11/xinit/xinput.d
+ doins "${T}/${PN}.conf"
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=\"scim\""
+ elog "export QT_IM_MODULE=\"scim\""
+ elog
+ elog "where 'your_language' can be zh_CN, zh_TW, ja_JP.eucJP or any other"
+ elog "UTF-8 locale such as en_US.UTF-8 or ja_JP.UTF-8"
+ elog
+ elog "To use Chinese input methods:"
+ elog " # emerge app-i18n/scim-tables app-i18n/scim-pinyin"
+ elog "To use Korean input methods:"
+ elog " # emerge app-i18n/scim-hangul"
+ elog "To use Japanese input methods:"
+ elog " # emerge app-i18n/scim-anthy"
+ elog "To use various input methods (more than 30 languages):"
+ elog " # emerge app-i18n/scim-m17n"
+ elog
+ elog "Please modify ${EPREFIX}/etc/scim/global and add your UTF-8 locale to"
+ elog "/SupportedUnicodeLocales entry."
+ elog
+ ewarn
+ ewarn "If you upgraded from scim-1.2.x or scim-1.0.x, you should remerge all SCIM modules."
+ ewarn
+
+ gnome2_query_immodules_gtk2
+}
+
+pkg_postrm() {
+ gnome2_query_immodules_gtk2
+}