summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2012-07-10 07:32:25 +0000
committerNaohiro Aota <naota@gentoo.org>2012-07-10 07:32:25 +0000
commit5db9e8d594b7438a162644f002ed6bd57a72fd96 (patch)
treed2887fe4e4b1f3049e4ed2db64cdb9546f642444 /app-i18n
parentmarked x86 per bug 425614 (diff)
downloadgentoo-2-5db9e8d594b7438a162644f002ed6bd57a72fd96.tar.gz
gentoo-2-5db9e8d594b7438a162644f002ed6bd57a72fd96.tar.bz2
gentoo-2-5db9e8d594b7438a162644f002ed6bd57a72fd96.zip
Support MAKEOPTS=-j (without a number) #425144 Suggested-By: Tomoh K.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-mozc/ChangeLog6
-rw-r--r--app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild9
2 files changed, 9 insertions, 6 deletions
diff --git a/app-i18n/ibus-mozc/ChangeLog b/app-i18n/ibus-mozc/ChangeLog
index c51fc6641df0..c3145480d19b 100644
--- a/app-i18n/ibus-mozc/ChangeLog
+++ b/app-i18n/ibus-mozc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-i18n/ibus-mozc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-mozc/ChangeLog,v 1.32 2012/06/13 11:55:41 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-mozc/ChangeLog,v 1.33 2012/07/10 07:32:25 naota Exp $
+
+ 10 Jul 2012; Naohiro Aota <naota@gentoo.org> ibus-mozc-1.5.1090.102.ebuild:
+ Support MAKEOPTS=-j (without a number) #425144 Suggested-By: Tomoh K.
*ibus-mozc-1.5.1090.102 (13 Jun 2012)
@@ -180,4 +183,3 @@
+ibus-mozc-0.11.365.102.ebuild,
+files/ibus-mozc-0.11.365.102-gentoo.patch, +metadata.xml:
Initial import.
-
diff --git a/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild b/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild
index d4515ea35459..dc25491855ef 100644
--- a/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild
+++ b/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild,v 1.1 2012/06/13 11:55:41 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-mozc/ibus-mozc-1.5.1090.102.ebuild,v 1.2 2012/07/10 07:32:25 naota Exp $
EAPI="3"
PYTHON_DEPEND="2"
-inherit elisp-common eutils multilib python toolchain-funcs
+inherit elisp-common eutils multilib multiprocessing python toolchain-funcs
DESCRIPTION="The Mozc engine for IBus Framework"
HOMEPAGE="http://code.google.com/p/mozc/"
@@ -73,8 +73,9 @@ src_configure() {
src_compile() {
tc-export CC CXX AR AS RANLIB LD
- local myjobs=`expr match "${MAKEOPTS}" '.*\(-j[0-9]*\)'`
- test -z "${myjobs}" && myjobs="-j1"
+ local my_makeopts=$(makeopts_jobs)
+ # This is for a safety. -j without a number, makeopts_jobs returns 999.
+ local myjobs=-j${my_makeopts/999/1}
local mytarget="server/server.gyp:mozc_server"
use emacs && mytarget="${mytarget} unix/emacs/emacs.gyp:mozc_emacs_helper"