summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2013-05-04 03:47:12 +0000
committerNaohiro Aota <naota@gentoo.org>2013-05-04 03:47:12 +0000
commit4c6f02f523b994362310f44c314399d14304c83f (patch)
tree518986deb62d6b54dd7612b906a6276b54fa3ab5 /app-i18n
parentversion bump (diff)
downloadgentoo-2-4c6f02f523b994362310f44c314399d14304c83f.tar.gz
gentoo-2-4c6f02f523b994362310f44c314399d14304c83f.tar.bz2
gentoo-2-4c6f02f523b994362310f44c314399d14304c83f.zip
Fix makefile to respect parallel compile; Respect LDFLAGS #336943; Move eof check around to get the data generated properly #390007
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/xsim/ChangeLog7
-rw-r--r--app-i18n/xsim/files/xsim-0.3.9.4-eof.patch92
-rw-r--r--app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch153
-rw-r--r--app-i18n/xsim/xsim-0.3.9.4-r5.ebuild12
4 files changed, 259 insertions, 5 deletions
diff --git a/app-i18n/xsim/ChangeLog b/app-i18n/xsim/ChangeLog
index ab5ddbfd04e1..86b48123a6cc 100644
--- a/app-i18n/xsim/ChangeLog
+++ b/app-i18n/xsim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/xsim
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.23 2013/04/15 05:36:34 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/ChangeLog,v 1.24 2013/05/04 03:47:12 naota Exp $
+
+ 04 May 2013; Naohiro Aota <naota@gentoo.org> +files/xsim-0.3.9.4-eof.patch,
+ +files/xsim-0.3.9.4-makefile.patch, xsim-0.3.9.4-r5.ebuild:
+ Fix makefile to respect parallel compile; Respect LDFLAGS #336943; Move eof
+ check around to get the data generated properly #390007
15 Apr 2013; Naohiro Aota <naota@gentoo.org> files/xsim-0.3.9.4-gcc-3.4.patch:
Re-generate xsim-0.3.9.5-gcc-3.4.patch not to include relative path.
diff --git a/app-i18n/xsim/files/xsim-0.3.9.4-eof.patch b/app-i18n/xsim/files/xsim-0.3.9.4-eof.patch
new file mode 100644
index 000000000000..3982bf2703c9
--- /dev/null
+++ b/app-i18n/xsim/files/xsim-0.3.9.4-eof.patch
@@ -0,0 +1,92 @@
+diff --git a/plugins/IMs/jianpin/dict/char2db.cpp b/plugins/IMs/jianpin/dict/char2db.cpp
+index f36dda9..fb17c6e 100644
+--- a/plugins/IMs/jianpin/dict/char2db.cpp
++++ b/plugins/IMs/jianpin/dict/char2db.cpp
+@@ -166,6 +166,8 @@ int main(int argc, char * argv[])
+ int i = 0;
+ for (;;){
+ in >> mark;
++ if (in.eof())
++ break;
+ in.unget();
+ if (mark == '%'){ //for comments
+ in.getline(dummy, 255);
+@@ -175,9 +177,6 @@ int main(int argc, char * argv[])
+ }
+ in >> ckey.py >> c;
+
+- if (in.eof())
+- break;
+-
+ if (strlen(c) != 2){
+ cout << "error on line: " << i << endl;
+ exit(1);
+diff --git a/plugins/IMs/jianpin/dict/word2db.cpp b/plugins/IMs/jianpin/dict/word2db.cpp
+index 6b6b8e0..f9a6d0b 100644
+--- a/plugins/IMs/jianpin/dict/word2db.cpp
++++ b/plugins/IMs/jianpin/dict/word2db.cpp
+@@ -103,6 +103,8 @@ int main(int argc, char * argv[])
+ rec.access_count = MAX_ACCESS_COUNT;
+ for (;;){
+ in >> mark;
++ if (in.eof())
++ break;
+ in.unget();
+ if (mark == '%'){ //for comments
+ in.getline(wk.py, sizeof(wk.py));
+@@ -113,9 +115,6 @@ int main(int argc, char * argv[])
+
+ in >> w >> wk.py;
+
+- if (in.eof())
+- break;
+-
+ if ((wk.py[0] < 'a') || (wk.py[0] > 'z')){
+ cerr << " error on line:" << i << endl;
+ db.close(0);
+diff --git a/plugins/IMs/table/dict/word2db.cpp b/plugins/IMs/table/dict/word2db.cpp
+index aa19a60..f0368ce 100644
+--- a/plugins/IMs/table/dict/word2db.cpp
++++ b/plugins/IMs/table/dict/word2db.cpp
+@@ -112,6 +112,8 @@ int main(int argc, char * argv[])
+ for (;;){
+ j++;
+ in >> mark;
++ if (in.eof())
++ break;
+ in.unget();
+ if ((mark == '%') || (mark == '#')){ //for comments
+ in.getline((char *)wbuf, 1000);
+@@ -123,9 +125,6 @@ int main(int argc, char * argv[])
+
+ in >> wk.key >> w;
+
+- if (in.eof())
+- break;
+-
+ if ((wk.key[0] < 'a') || (wk.key[0] > 'z')){
+ //cerr << " error on line:" << j << endl;
+ errcnt ++;
+diff --git a/plugins/IMs/wubi/dict/word2db.cpp b/plugins/IMs/wubi/dict/word2db.cpp
+index a1df52b..3fe1e3e 100644
+--- a/plugins/IMs/wubi/dict/word2db.cpp
++++ b/plugins/IMs/wubi/dict/word2db.cpp
+@@ -103,6 +103,8 @@ int main(int argc, char * argv[])
+ for (;;){
+ j++;
+ in >> mark;
++ if (in.eof())
++ break;
+ in.unget();
+ if (mark == '%'){ //for comments
+ in.getline(wk.key, sizeof(wk.key));
+@@ -114,9 +116,6 @@ int main(int argc, char * argv[])
+
+ in >> wk.key >> w;
+
+- if (in.eof())
+- break;
+-
+ if ((wk.key[0] < 'a') || (wk.key[0] > 'z')){
+ //cerr << " error on line:" << j << endl;
+ errcnt ++;
diff --git a/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch b/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch
new file mode 100644
index 000000000000..8488d1bf135b
--- /dev/null
+++ b/app-i18n/xsim/files/xsim-0.3.9.4-makefile.patch
@@ -0,0 +1,153 @@
+diff --git a/Makefile.in b/Makefile.in
+index 6a7a195..6d2b4e6 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -36,7 +36,7 @@ distclean: clean
+ done && test -z "$$fail"
+
+ install-data:
+- cd plugins/IMs;make install-data
++ cd plugins/IMs;$(MAKE) install-data
+
+ uninstall:
+ @for dir in ${subdirs}; do \
+diff --git a/plugins/IMs/jianpin/Makefile.in b/plugins/IMs/jianpin/Makefile.in
+index cbbac33..50d7ef0 100644
+--- a/plugins/IMs/jianpin/Makefile.in
++++ b/plugins/IMs/jianpin/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=simpleim.o simpleimc.o pyphraser.o
+ TARGET=jianpin.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ jianpin.so:$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -41,20 +41,20 @@ pyphraser.o:pyphraser.cpp pyphraser.h simpleimc.h $(include_path)wstring.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict;make uninstall
++ cd dict;$(MAKE) uninstall
+diff --git a/plugins/IMs/table/Makefile.in b/plugins/IMs/table/Makefile.in
+index a747560..cbc67bc 100644
+--- a/plugins/IMs/table/Makefile.in
++++ b/plugins/IMs/table/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=tableim.o tableimc.o
+ TARGET=table.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ $(TARGET):$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -38,20 +38,20 @@ tableimc.o:tableimc.h tableimc.cpp $(include_path)wstring.h $(include_path)imc.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict; make uninstall
++ cd dict; $(MAKE) uninstall
+diff --git a/plugins/IMs/wubi/Makefile.in b/plugins/IMs/wubi/Makefile.in
+index 031f1a7..c3d0f88 100644
+--- a/plugins/IMs/wubi/Makefile.in
++++ b/plugins/IMs/wubi/Makefile.in
+@@ -25,7 +25,7 @@ OBJS=wubiim.o wubiimc.o
+ TARGET=wubi.so
+
+ all:$(TARGET)
+- cd dict; make
++ cd dict; $(MAKE)
+
+ $(TARGET):$(OBJS)
+ $(LD_SHAREEXE) -shared -o $(TARGET) $(OBJS) $(LDFLAGS) -L$(bdblibs) $(LIBS) -l$(bdblib) $(gcclib)
+@@ -38,20 +38,20 @@ wubiimc.o:wubiimc.h wubiimc.cpp $(include_path)wstring.h $(include_path)imc.h
+
+ clean:
+ rm -f *.o $(TARGET) core *~ *.bak
+- cd dict; make clean
++ cd dict; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile
+- cd dict; make distclean
++ cd dict; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_libp)
+ cp -f $(TARGET) $(xsim_libp)
+- cd dict; make install
++ cd dict; $(MAKE) install
+
+ install-data:
+- cd dict;make install-data
++ cd dict;$(MAKE) install-data
+
+ uninstall:
+ cd $(xsim_libp); rm -f $(TARGET)
+- cd dict; make uninstall
++ cd dict; $(MAKE) uninstall
+diff --git a/xsim/Makefile.in b/xsim/Makefile.in
+index d618a2c..bbe1599 100644
+--- a/xsim/Makefile.in
++++ b/xsim/Makefile.in
+@@ -58,15 +58,15 @@ wstring.o:wstring.h wstring.cpp
+ $(CXX) -c wstring.cpp $(CXXFLAGS) -I./IMdkit
+
+ IMdkit/libXimd.a:
+- cd IMdkit;make
++ cd IMdkit;$(MAKE)
+
+ clean:
+ rm -f *.o xsim core *~ *.bak
+- cd IMdkit; make clean
++ cd IMdkit; $(MAKE) clean
+
+ distclean:clean
+ rm -rf Makefile tags
+- cd IMdkit; make distclean
++ cd IMdkit; $(MAKE) distclean
+
+ install:all
+ $(topdir)/mkinstalldirs $(xsim_binp)
diff --git a/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild b/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild
index 98226b1ff7ae..005c9d9619fa 100644
--- a/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild
+++ b/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild,v 1.3 2009/10/21 15:11:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xsim/xsim-0.3.9.4-r5.ebuild,v 1.4 2013/05/04 03:47:12 naota Exp $
EAPI=2
inherit db-use eutils flag-o-matic multilib
@@ -26,11 +26,15 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-64bit.patch
# bug 227117
epatch "${FILESDIR}"/${P}-gcc-4.3.patch
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-eof.patch
- append-flags -DPIC -fPIC -fno-strict-aliasing
+ append-cppflags -DPIC
+ append-flags -fPIC -fno-strict-aliasing
dbver="$(db_findver sys-libs/db)"
sed -i -e "s/\(CFLAGS.*\)-O2/\1${CFLAGS}/" \
+ -e "s/LDFLAGS=\"/LDFLAGS=\"${LDFLAGS} /" \
-e "s/libdb_cxx.so/libdb_cxx-${dbver}.so/" \
-e "s/bdblib=\"db_cxx\"/bdblib=\"db_cxx-${dbver}\"/" configure* || die
@@ -57,7 +61,7 @@ src_install() {
xsim_libp="${D}"usr/$(get_libdir)/xsim/plugins \
xsim_binp="${D}"/usr/bin \
xsim_etcp="${D}"/etc \
- install-data install || die
+ install install-data || die
dodoc ChangeLog KNOWNBUG README* TODO
}