summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-01-05 11:17:11 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-01-05 11:17:11 +0000
commitcaecda5f79c121ee06c1a664533dec2ae8b38b22 (patch)
tree07ee74221b47a5a197ff8a2ceb67da63cb276109 /app-i18n/uim
parentCosmetics: gle -> PN (diff)
downloadgentoo-2-caecda5f79c121ee06c1a664533dec2ae8b38b22.tar.gz
gentoo-2-caecda5f79c121ee06c1a664533dec2ae8b38b22.tar.bz2
gentoo-2-caecda5f79c121ee06c1a664533dec2ae8b38b22.zip
Fixed Qt4 issue, bug #349859. Fixed gtk issue, bug #350207. These patches are submitted by Muneyuki Noguchi. Respect CXX and LDFLAGS, bug #349689.
(Portage version: 2.1.9.28/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/uim')
-rw-r--r--app-i18n/uim/ChangeLog15
-rw-r--r--app-i18n/uim/files/uim-1.5.6-toplevel-delete-event.patch33
-rw-r--r--app-i18n/uim/files/uim-1.6.0-gettext.patch16
-rw-r--r--app-i18n/uim/files/uim-1.6.0-linker.patch149
-rw-r--r--app-i18n/uim/files/uim-1.6.0-xcompose.patch16
-rw-r--r--app-i18n/uim/files/uim-disable-notify.diff50
-rw-r--r--app-i18n/uim/uim-1.5.6-r1.ebuild197
-rw-r--r--app-i18n/uim/uim-1.5.6-r4.ebuild200
-rw-r--r--app-i18n/uim/uim-1.6.0-r2.ebuild (renamed from app-i18n/uim/uim-1.6.0.ebuild)14
9 files changed, 203 insertions, 487 deletions
diff --git a/app-i18n/uim/ChangeLog b/app-i18n/uim/ChangeLog
index 79a9bc729c9e..cc3f00ecbc6c 100644
--- a/app-i18n/uim/ChangeLog
+++ b/app-i18n/uim/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-i18n/uim
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.225 2010/12/26 17:29:08 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/ChangeLog,v 1.226 2011/01/05 11:17:11 matsuu Exp $
+
+*uim-1.6.0-r2 (05 Jan 2011)
+
+ 05 Jan 2011; MATSUU Takuto <matsuu@gentoo.org> -uim-1.5.6-r1.ebuild,
+ -uim-1.5.6-r4.ebuild, -files/uim-1.5.6-toplevel-delete-event.patch,
+ -uim-1.6.0.ebuild, +uim-1.6.0-r2.ebuild, +files/uim-1.6.0-gettext.patch,
+ +files/uim-1.6.0-linker.patch, +files/uim-1.6.0-xcompose.patch,
+ -files/uim-disable-notify.diff:
+ Fixed Qt4 issue, bug #349859. Fixed gtk issue, bug #350207. These patches are
+ submitted by Muneyuki Noguchi. Respect CXX and LDFLAGS, bug #349689. Removed
+ old versions.
26 Dec 2010; Jeroen Roovers <jer@gentoo.org> uim-1.6.0.ebuild,
uim-1.6.0-r1.ebuild:
diff --git a/app-i18n/uim/files/uim-1.5.6-toplevel-delete-event.patch b/app-i18n/uim/files/uim-1.5.6-toplevel-delete-event.patch
deleted file mode 100644
index adc0902d8059..000000000000
--- a/app-i18n/uim/files/uim-1.5.6-toplevel-delete-event.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Index: gtk/gtk-im-uim.c
-===================================================================
---- gtk/gtk-im-uim.c (revision 6061)
-+++ gtk/gtk-im-uim.c (revision 6062)
-@@ -329,6 +329,12 @@
- }
-
- static void
-+cur_toplevel_deleted(GtkWidget *widget, gpointer data)
-+{
-+ cur_toplevel = NULL;
-+}
-+
-+static void
- update_cur_toplevel(IMUIMContext *uic)
- {
- /* Don't set our candwin's text widget as cur_toplevel */
-@@ -358,6 +364,9 @@
- cur_key_release_handler_id = g_signal_connect(cur_toplevel,
- "key-release-event",
- G_CALLBACK(handle_key_on_toplevel), uic);
-+ g_signal_connect(cur_toplevel,
-+ "delete_event",
-+ G_CALLBACK(cur_toplevel_deleted), NULL);
- }
- } else
- remove_cur_toplevel();
-
-Property changes on: gtk
-___________________________________________________________________
-Added: svn:mergeinfo
- Merged /trunk/gtk:r5963,5967,6039,6061
-
diff --git a/app-i18n/uim/files/uim-1.6.0-gettext.patch b/app-i18n/uim/files/uim-1.6.0-gettext.patch
new file mode 100644
index 000000000000..aa3a056cec61
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.6.0-gettext.patch
@@ -0,0 +1,16 @@
+Index: qt4/qtgettext.h
+===================================================================
+--- qt4/qtgettext.h (revision 6847)
++++ qt4/qtgettext.h (revision 6848)
+@@ -61,6 +61,11 @@
+ #else /* ENABLE_NLS */
+
+ #define mygettext(String) QString::fromLocal8Bit(String)
++/* undef original _(String) macro to use QString */
++#ifdef _
++#undef _
++#endif
++#define _(String) mygettext(String)
+ #define UIC_(String, dummy) (String)
+ #endif /* ENABLE_NLS */
+
diff --git a/app-i18n/uim/files/uim-1.6.0-linker.patch b/app-i18n/uim/files/uim-1.6.0-linker.patch
new file mode 100644
index 000000000000..ada64cacefac
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.6.0-linker.patch
@@ -0,0 +1,149 @@
+diff -Naur uim-1.6.0.orig/configure.ac uim-1.6.0/configure.ac
+--- uim-1.6.0.orig/configure.ac 2010-08-02 09:30:14.000000000 +0900
++++ uim-1.6.0/configure.ac 2011-01-03 11:43:06.375239564 +0900
+@@ -1826,6 +1826,7 @@
+ qt4/chardict/uim-chardict-qt4.pro
+ qt4/chardict/po/Makefile.in
+ qt4/edittest/Makefile
++ qt4/edittest/edittest.pro
+ qt4/immodule/quiminputcontextplugin.pro
+ qt4/immodule/Makefile
+ qt4/pref/uim-pref-qt4.pro
+diff -Naur uim-1.6.0.orig/qt4/candwin/uim-candwin-qt4.pro.in uim-1.6.0/qt4/candwin/uim-candwin-qt4.pro.in
+--- uim-1.6.0.orig/qt4/candwin/uim-candwin-qt4.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/candwin/uim-candwin-qt4.pro.in 2011-01-05 09:27:14.905438175 +0900
+@@ -16,6 +16,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+
+diff -Naur uim-1.6.0.orig/qt4/chardict/uim-chardict-qt4.pro.in uim-1.6.0/qt4/chardict/uim-chardict-qt4.pro.in
+--- uim-1.6.0.orig/qt4/chardict/uim-chardict-qt4.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/chardict/uim-chardict-qt4.pro.in 2011-01-05 09:27:14.905438175 +0900
+@@ -16,6 +16,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+
+diff -Naur uim-1.6.0.orig/qt4/edittest/Makefile.am uim-1.6.0/qt4/edittest/Makefile.am
+--- uim-1.6.0.orig/qt4/edittest/Makefile.am 2010-03-30 13:24:26.000000000 +0900
++++ uim-1.6.0/qt4/edittest/Makefile.am 2011-01-03 11:41:06.643957761 +0900
+@@ -12,8 +12,8 @@
+ $(MAKE) $(AM_MAKEFLAGS) -f Makefile.qmake $@
+ $(MAKE) $(AM_MAKEFLAGS) distclean-am
+ endif
+- -rm -f Makefile
++ -rm -f Makefile edittest.pro
+
+ FORCE:
+
+-EXTRA_DIST = README edittest.pro main.cpp
++EXTRA_DIST = README edittest.pro.in main.cpp
+diff -Naur uim-1.6.0.orig/qt4/edittest/edittest.pro uim-1.6.0/qt4/edittest/edittest.pro
+--- uim-1.6.0.orig/qt4/edittest/edittest.pro 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/edittest/edittest.pro 1970-01-01 09:00:00.000000000 +0900
+@@ -1,14 +0,0 @@
+-######################################################################
+-# Automatically generated by qmake (1.08a) Tue Aug 24 01:02:27 2004
+-######################################################################
+-
+-TEMPLATE = app
+-CONFIG -= moc
+-DEPENDPATH += .
+-INCLUDEPATH += .
+-CONFIG += qt warn_on debug
+-
+-QMAKE_STRIP =
+-
+-# Input
+-SOURCES += main.cpp
+diff -Naur uim-1.6.0.orig/qt4/edittest/edittest.pro.in uim-1.6.0/qt4/edittest/edittest.pro.in
+--- uim-1.6.0.orig/qt4/edittest/edittest.pro.in 1970-01-01 09:00:00.000000000 +0900
++++ uim-1.6.0/qt4/edittest/edittest.pro.in 2011-01-05 09:27:14.909438151 +0900
+@@ -0,0 +1,24 @@
++######################################################################
++# Automatically generated by qmake (1.08a) Tue Aug 24 01:02:27 2004
++######################################################################
++
++TEMPLATE = app
++CONFIG -= moc
++DEPENDPATH += .
++INCLUDEPATH += .
++CONFIG += qt warn_on debug
++
++QMAKE_CC = @CC@
++QMAKE_CFLAGS_DEBUG += @CFLAGS@ @X_CFLAGS@
++QMAKE_CFLAGS_RELEASE += @CFLAGS@ @X_CFLAGS@
++QMAKE_CXX = @CXX@
++QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
++
++QMAKE_STRIP =
++
++# Input
++SOURCES += main.cpp
+diff -Naur uim-1.6.0.orig/qt4/immodule/quiminputcontextplugin.pro.in uim-1.6.0/qt4/immodule/quiminputcontextplugin.pro.in
+--- uim-1.6.0.orig/qt4/immodule/quiminputcontextplugin.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/immodule/quiminputcontextplugin.pro.in 2011-01-05 09:27:14.913438127 +0900
+@@ -22,6 +22,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+
+diff -Naur uim-1.6.0.orig/qt4/pref/uim-pref-qt4.pro.in uim-1.6.0/qt4/pref/uim-pref-qt4.pro.in
+--- uim-1.6.0.orig/qt4/pref/uim-pref-qt4.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/pref/uim-pref-qt4.pro.in 2011-01-05 09:27:14.913438127 +0900
+@@ -16,6 +16,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+ QMAKE_UIC = $$QMAKE_UIC -tr UIC_
+diff -Naur uim-1.6.0.orig/qt4/switcher/uim-im-switcher-qt4.pro.in uim-1.6.0/qt4/switcher/uim-im-switcher-qt4.pro.in
+--- uim-1.6.0.orig/qt4/switcher/uim-im-switcher-qt4.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/switcher/uim-im-switcher-qt4.pro.in 2011-01-05 09:27:14.917438104 +0900
+@@ -16,6 +16,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+
+diff -Naur uim-1.6.0.orig/qt4/toolbar/uim-toolbar-qt4.pro.in uim-1.6.0/qt4/toolbar/uim-toolbar-qt4.pro.in
+--- uim-1.6.0.orig/qt4/toolbar/uim-toolbar-qt4.pro.in 2010-08-09 13:09:35.000000000 +0900
++++ uim-1.6.0/qt4/toolbar/uim-toolbar-qt4.pro.in 2011-01-05 09:27:14.917438104 +0900
+@@ -16,6 +16,9 @@
+ QMAKE_CXX = @CXX@
+ QMAKE_CXXFLAGS_DEBUG += @CXXFLAGS@ @X_CFLAGS@
+ QMAKE_CXXFLAGS_RELEASE += @CXXFLAGS@ @X_CFLAGS@
++QMAKE_LINK = @CXX@
++QMAKE_LFLAGS_DEBUG += @LDFLAGS@
++QMAKE_LFLAGS_RELEASE += @LDFLAGS@
+
+ QMAKE_STRIP =
+
diff --git a/app-i18n/uim/files/uim-1.6.0-xcompose.patch b/app-i18n/uim/files/uim-1.6.0-xcompose.patch
new file mode 100644
index 000000000000..48a56c32921c
--- /dev/null
+++ b/app-i18n/uim/files/uim-1.6.0-xcompose.patch
@@ -0,0 +1,16 @@
+Index: gtk/compose.c
+===================================================================
+--- gtk/compose.c (revision 6879)
++++ gtk/compose.c (revision 6880)
+@@ -621,7 +621,10 @@
+ {
+ char *result;
+ result = g_locale_to_utf8(rhs_string_mb, -1, NULL, NULL, NULL);
+- rhs_string_utf8 = strdup(result);
++ if (!result)
++ rhs_string_utf8 = strdup("");
++ else
++ rhs_string_utf8 = strdup(result);
+ g_free(result);
+ }
+
diff --git a/app-i18n/uim/files/uim-disable-notify.diff b/app-i18n/uim/files/uim-disable-notify.diff
deleted file mode 100644
index cbb33a82494d..000000000000
--- a/app-i18n/uim/files/uim-disable-notify.diff
+++ /dev/null
@@ -1,50 +0,0 @@
-Index: uim/uim-notify.c
-===================================================================
---- uim/uim-notify.c (revision 5997)
-+++ uim/uim-notify.c (working copy)
-@@ -111,6 +111,8 @@
-
- if (strcmp(agent->desc()->name, name) == 0) {
- return UIM_TRUE;
-+ } if (getenv("UIM_DISABLE_NOTIFY") != NULL) {
-+ return UIM_TRUE;
- } else if (strcmp(name, "stderr") == 0) {
- agent->quit();
- if (notify_dlhandle)
-@@ -238,6 +240,10 @@
- MAKE_STR(desc->name),
- MAKE_STR(desc->desc)),
- uim_scm_null());
-+
-+ if (getenv("UIM_DISABLE_NOTIFY") != NULL)
-+ return uim_scm_callf("reverse", "o", ret_);
-+
- dirp = opendir(NOTIFY_PLUGIN_PATH);
- if (dirp) {
- while ((dp = readdir(dirp)) != NULL) {
-Index: scm/Makefile.am
-===================================================================
---- scm/Makefile.am (revision 5997)
-+++ scm/Makefile.am (working copy)
-@@ -97,7 +97,8 @@
- UIM_MODULE_MANAGER_ENV = \
- LIBUIM_SYSTEM_SCM_FILES=$(abs_top_srcdir)/sigscheme/lib \
- LIBUIM_SCM_FILES=$(abs_srcdir) \
-- LIBUIM_PLUGIN_LIB_DIR=$(abs_top_builddir)/uim/.libs
-+ LIBUIM_PLUGIN_LIB_DIR=$(abs_top_builddir)/uim/.libs \
-+ UIM_DISABLE_NOTIFY=1
-
- installed-modules.scm loader.scm: $(SCM_FILES)
- $(MAKE) $(AM_MAKEFLAGS) -C $(top_builddir)/uim uim-module-manager && \
---- scm/Makefile.in.orig Tue Sep 15 02:01:18 2009
-+++ scm/Makefile.in Tue Sep 15 02:01:36 2009
-@@ -363,7 +363,8 @@
- UIM_MODULE_MANAGER_ENV = \
- LIBUIM_SYSTEM_SCM_FILES=$(abs_top_srcdir)/sigscheme/lib \
- LIBUIM_SCM_FILES=$(abs_srcdir) \
-- LIBUIM_PLUGIN_LIB_DIR=$(abs_top_builddir)/uim/.libs
-+ LIBUIM_PLUGIN_LIB_DIR=$(abs_top_builddir)/uim/.libs \
-+ UIM_DISABLE_NOTIFY=1
-
- all: all-am
-
diff --git a/app-i18n/uim/uim-1.5.6-r1.ebuild b/app-i18n/uim/uim-1.5.6-r1.ebuild
deleted file mode 100644
index ba889349534c..000000000000
--- a/app-i18n/uim/uim-1.5.6-r1.ebuild
+++ /dev/null
@@ -1,197 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.5.6-r1.ebuild,v 1.11 2010/01/04 03:58:18 yngwin Exp $
-
-EAPI="2"
-inherit autotools eutils multilib elisp-common flag-o-matic
-
-DESCRIPTION="Simple, secure and flexible input method library"
-HOMEPAGE="http://code.google.com/p/uim/"
-SRC_URI="http://uim.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86"
-IUSE="+anthy canna eb emacs gnome gtk libedit libnotify m17n-lib ncurses nls prime qt4 unicode X xft linguas_zh_CN linguas_zh_TW linguas_ja linguas_ko"
-
-RDEPEND="X? (
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXext
- x11-libs/libXrender
- )
- anthy? (
- unicode? ( >=app-i18n/anthy-8622 )
- !unicode? ( app-i18n/anthy )
- )
- canna? ( app-i18n/canna )
- eb? ( dev-libs/eb )
- emacs? ( virtual/emacs )
- gnome? ( >=gnome-base/gnome-panel-2.14 )
- gtk? ( >=x11-libs/gtk+-2.4 )
- libedit? ( dev-libs/libedit )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- m17n-lib? ( >=dev-libs/m17n-lib-1.3.1 )
- ncurses? ( sys-libs/ncurses )
- nls? ( virtual/libintl )
- prime? ( app-i18n/prime )
- qt4? ( x11-libs/qt-gui:4[qt3support] )
- !app-i18n/uim-svn
- !<app-i18n/prime-0.9.4"
-# mana? ( app-i18n/mana )
-# scim? ( >=app-i18n/scim-1.3.0 ) # broken
-# sj3? ( >=app-i18n/sj3-2.0.1.21 )
-# wnn? ( app-i18n/wnn )
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-devel/gettext-0.15
- X? (
- x11-proto/xextproto
- x11-proto/xproto
- )"
-
-RDEPEND="${RDEPEND}
- X? (
- media-fonts/font-sony-misc
- linguas_zh_CN? (
- || ( media-fonts/font-isas-misc media-fonts/intlfonts )
- )
- linguas_zh_TW? (
- media-fonts/intlfonts
- )
- linguas_ja? (
- || ( media-fonts/font-jis-misc media-fonts/intlfonts )
- )
- linguas_ko? (
- || ( media-fonts/font-daewoo-misc media-fonts/intlfonts )
- )
- )"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- # An arch specific config directory is used on multilib systems
- has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.5.4-gentoo.patch"
- epatch "${FILESDIR}/${PN}-1.5.4-gcc43.patch"
- epatch "${FILESDIR}/${PN}-1.5.4-zhTW.patch"
-
- # bug 275420
- sed -i -e "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac || die
- eautoconf
-}
-
-src_configure() {
- local myconf
-
- if use gtk && (use anthy || use canna) ; then
- myconf="${myconf} --enable-dict"
- else
- myconf="${myconf} --disable-dict"
- fi
-
- if use gtk; then
- myconf="${myconf} --enable-pref"
- else
- myconf="${myconf} --disable-pref"
- fi
-
- if use anthy ; then
- if use unicode ; then
- myconf="${myconf} --with-anthy-utf8"
- else
- myconf="${myconf} --with-anthy"
- fi
- else
- myconf="${myconf} --without-anthy"
- fi
-
- if use libnotify ; then
- myconf="${myconf} --enable-notify=libnotify"
- fi
-
- econf $(use_with X x) \
- $(use_with canna) \
- $(use_with eb) \
- $(use_enable emacs) \
- $(use_with emacs lispdir "${SITELISP}") \
- $(use_enable gnome gnome-applet) \
- $(use_with gtk gtk2) \
- $(use_with libedit) \
- --disable-kde-applet \
- $(use_with m17n-lib m17nlib) \
- $(use_enable ncurses fep) \
- $(use_enable nls) \
- $(use_with prime) \
- --without-qt \
- --without-qt-immodule \
- $(use_with qt4 qt4-immodule) \
- $(use_with xft) \
- ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use emacs; then
- cd emacs
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- # parallel make install b0rked, bug #222677
- emake -j1 INSTALL_ROOT="${D}" DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog* NEWS README RELNOTE
- if use emacs; then
- elisp-install uim-el emacs/*.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" uim-el \
- || die "elisp-site-file-install failed"
- fi
-}
-
-pkg_postinst() {
- elog
- elog "To use uim-skk you should emerge app-i18n/skk-jisyo."
- elog
- elog "New input method switcher has been introduced. You need to set"
- elog
- elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
- elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
- elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
- elog
- elog "If you would like to use uim-anthy as default input method, put"
- elog "(define default-im-name 'anthy)"
- elog "to your ~/.uim."
- elog
- elog "All input methods can be found by running uim-im-switcher-gtk"
- elog "or uim-im-switcher-qt."
- elog
- elog "If you upgrade from a version of uim older than 1.4.0,"
- elog "you should run revdep-rebuild."
-
- use gtk && gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
- if use emacs; then
- elisp-site-regen
- echo
- elog "uim is autoloaded with Emacs with a minimal set of features:"
- elog "There is no keybinding defined to call it directly, so please"
- elog "create one yourself and choose an input method."
- elog "Integration with LEIM is not done with this ebuild, please have"
- elog "a look at the documentation how to achieve this."
- fi
-}
-
-pkg_postrm() {
- use gtk && gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
- use emacs && elisp-site-regen
-}
diff --git a/app-i18n/uim/uim-1.5.6-r4.ebuild b/app-i18n/uim/uim-1.5.6-r4.ebuild
deleted file mode 100644
index cd10bbe56a47..000000000000
--- a/app-i18n/uim/uim-1.5.6-r4.ebuild
+++ /dev/null
@@ -1,200 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.5.6-r4.ebuild,v 1.3 2010/01/04 03:58:18 yngwin Exp $
-
-EAPI="2"
-inherit autotools eutils multilib elisp-common flag-o-matic
-
-DESCRIPTION="Simple, secure and flexible input method library"
-HOMEPAGE="http://code.google.com/p/uim/"
-SRC_URI="http://uim.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+anthy canna eb emacs gnome gtk libedit libnotify m17n-lib ncurses nls prime qt4 unicode X xft linguas_zh_CN linguas_zh_TW linguas_ja linguas_ko"
-
-RDEPEND="X? (
- x11-libs/libX11
- x11-libs/libXft
- x11-libs/libXt
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libXext
- x11-libs/libXrender
- )
- anthy? (
- unicode? ( >=app-i18n/anthy-8622 )
- !unicode? ( app-i18n/anthy )
- )
- canna? ( app-i18n/canna )
- eb? ( dev-libs/eb )
- emacs? ( virtual/emacs )
- gnome? ( >=gnome-base/gnome-panel-2.14 )
- gtk? ( >=x11-libs/gtk+-2.4 )
- libedit? ( dev-libs/libedit )
- libnotify? ( >=x11-libs/libnotify-0.4 )
- m17n-lib? ( >=dev-libs/m17n-lib-1.3.1 )
- ncurses? ( sys-libs/ncurses )
- nls? ( virtual/libintl )
- prime? ( app-i18n/prime )
- qt4? ( x11-libs/qt-gui:4[qt3support] )
- !app-i18n/uim-svn
- !<app-i18n/prime-0.9.4"
-# mana? ( app-i18n/mana )
-# scim? ( >=app-i18n/scim-1.3.0 ) # broken
-# sj3? ( >=app-i18n/sj3-2.0.1.21 )
-# wnn? ( app-i18n/wnn )
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=sys-devel/gettext-0.15
- X? (
- x11-proto/xextproto
- x11-proto/xproto
- )"
-
-RDEPEND="${RDEPEND}
- X? (
- media-fonts/font-sony-misc
- linguas_zh_CN? (
- || ( media-fonts/font-isas-misc media-fonts/intlfonts )
- )
- linguas_zh_TW? (
- media-fonts/intlfonts
- )
- linguas_ja? (
- || ( media-fonts/font-jis-misc media-fonts/intlfonts )
- )
- linguas_ko? (
- || ( media-fonts/font-daewoo-misc media-fonts/intlfonts )
- )
- )"
-
-SITEFILE=50${PN}-gentoo.el
-
-pkg_setup() {
- # An arch specific config directory is used on multilib systems
- has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
- GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0/}
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}/${PN}-1.5.4-gentoo.patch" \
- "${FILESDIR}/${PN}-1.5.4-gcc43.patch" \
- "${FILESDIR}/${PN}-1.5.4-zhTW.patch" \
- "${FILESDIR}/${PN}-disable-notify.diff" \
- "${FILESDIR}/${P}-toplevel-delete-event.patch"
-
- # bug 275420
- sed -i -e "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac || die
- eautoconf
-}
-
-src_configure() {
- local myconf
-
- if use gtk && (use anthy || use canna) ; then
- myconf="${myconf} --enable-dict"
- else
- myconf="${myconf} --disable-dict"
- fi
-
- if use gtk; then
- myconf="${myconf} --enable-pref"
- else
- myconf="${myconf} --disable-pref"
- fi
-
- if use anthy ; then
- if use unicode ; then
- myconf="${myconf} --with-anthy-utf8"
- else
- myconf="${myconf} --with-anthy"
- fi
- else
- myconf="${myconf} --without-anthy"
- fi
-
- if use libnotify ; then
- myconf="${myconf} --enable-notify=libnotify"
- fi
-
- econf $(use_with X x) \
- $(use_with canna) \
- $(use_with eb) \
- $(use_enable emacs) \
- $(use_with emacs lispdir "${SITELISP}") \
- $(use_enable gnome gnome-applet) \
- $(use_with gtk gtk2) \
- $(use_with libedit) \
- --disable-kde-applet \
- $(use_with m17n-lib m17nlib) \
- $(use_enable ncurses fep) \
- $(use_enable nls) \
- $(use_with prime) \
- --without-qt \
- --without-qt-immodule \
- $(use_with qt4 qt4-immodule) \
- $(use_with xft) \
- ${myconf}
-}
-
-src_compile() {
- emake || die "emake failed"
-
- if use emacs; then
- cd emacs
- elisp-compile *.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- # parallel make install b0rked, bug #222677
- emake -j1 INSTALL_ROOT="${D}" DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog* NEWS README RELNOTE
- if use emacs; then
- elisp-install uim-el emacs/*.elc || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" uim-el \
- || die "elisp-site-file-install failed"
- fi
-}
-
-pkg_postinst() {
- elog
- elog "To use uim-skk you should emerge app-i18n/skk-jisyo."
- elog
- elog "New input method switcher has been introduced. You need to set"
- elog
- elog "% GTK_IM_MODULE=uim ; export GTK_IM_MODULE"
- elog "% QT_IM_MODULE=uim ; export QT_IM_MODULE"
- elog "% XMODIFIERS=@im=uim ; export XMODIFIERS"
- elog
- elog "If you would like to use uim-anthy as default input method, put"
- elog "(define default-im-name 'anthy)"
- elog "to your ~/.uim."
- elog
- elog "All input methods can be found by running uim-im-switcher-gtk"
- elog "or uim-im-switcher-qt."
- elog
- elog "If you upgrade from a version of uim older than 1.4.0,"
- elog "you should run revdep-rebuild."
-
- use gtk && gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
- if use emacs; then
- elisp-site-regen
- echo
- elog "uim is autoloaded with Emacs with a minimal set of features:"
- elog "There is no keybinding defined to call it directly, so please"
- elog "create one yourself and choose an input method."
- elog "Integration with LEIM is not done with this ebuild, please have"
- elog "a look at the documentation how to achieve this."
- fi
-}
-
-pkg_postrm() {
- use gtk && gtk-query-immodules-2.0 > "${ROOT}/${GTK2_CONFDIR}/gtk.immodules"
- use emacs && elisp-site-regen
-}
diff --git a/app-i18n/uim/uim-1.6.0.ebuild b/app-i18n/uim/uim-1.6.0-r2.ebuild
index 891dad31a376..cb8d76277e9c 100644
--- a/app-i18n/uim/uim-1.6.0.ebuild
+++ b/app-i18n/uim/uim-1.6.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.6.0.ebuild,v 1.2 2010/12/26 17:29:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/uim/uim-1.6.0-r2.ebuild,v 1.1 2011/01/05 11:17:11 matsuu Exp $
EAPI="3"
inherit autotools eutils multilib elisp-common flag-o-matic
@@ -12,7 +12,6 @@ SRC_URI="http://uim.googlecode.com/files/${P}.tar.bz2"
LICENSE="BSD GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="+anthy canna curl eb emacs ffi gnome gtk kde libedit libnotify m17n-lib ncurses nls prime qt4 skk sqlite ssl test unicode X xft linguas_zh_CN linguas_zh_TW linguas_ja linguas_ko"
RESTRICT="test"
@@ -95,11 +94,16 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}/${P}-gentoo.patch" \
- "${FILESDIR}/${PN}-1.5.4-zhTW.patch"
+ "${FILESDIR}/${PN}-1.5.4-zhTW.patch" \
+ "${FILESDIR}/${P}-sandbox-violation.patch" \
+ "${FILESDIR}/${P}-gettext.patch" \
+ "${FILESDIR}/${P}-xcompose.patch" \
+ "${FILESDIR}/${P}-linker.patch"
# bug 275420
sed -i -e "s:\$libedit_path/lib:/$(get_libdir):g" configure.ac || die
- eautoconf
+ #./autogen.sh
+ AT_NO_RECURSIVE=1 eautoreconf
}
src_configure() {