summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-08-30 09:03:33 +0000
committerMamoru Komachi <usata@gentoo.org>2004-08-30 09:03:33 +0000
commitd0384ea48c10f1325ca415e8cf8b5a1b5c7b8fed (patch)
tree33881c7174cec341b33a6ac029530164790e36af /app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild
parentUse wxwidgets eclass (#61871). (Manifest recommit) (diff)
downloadgentoo-2-d0384ea48c10f1325ca415e8cf8b5a1b5c7b8fed.tar.gz
gentoo-2-d0384ea48c10f1325ca415e8cf8b5a1b5c7b8fed.tar.bz2
gentoo-2-d0384ea48c10f1325ca415e8cf8b5a1b5c7b8fed.zip
Version bumped.
Diffstat (limited to 'app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild')
-rw-r--r--app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild b/app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild
new file mode 100644
index 000000000000..cd3b5d868bcd
--- /dev/null
+++ b/app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-m17n/scim-m17n-0.1.3.ebuild,v 1.1 2004/08/30 09:03:33 usata Exp $
+
+DESCRIPTION="scim-m17n is an input module for Smart Common Input Method (SCIM) which uses m17n as backend"
+HOMEPAGE="http://freedesktop.org/~suzhe/"
+SRC_URI="http://freedesktop.org/~suzhe/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~amd64"
+IUSE=""
+
+DEPEND="|| ( >=app-i18n/scim-0.99.8 >=app-i18n/scim-cvs-0.99.8 )
+ >=dev-libs/m17n-lib-1.0.2-r1"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog THANKS README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use SCIM with both GTK2 and XIM, you should use the following"
+ einfo "in your user startup scripts such as .gnomerc or .xinitrc:"
+ einfo
+ einfo "LANG='your_language' scim -d"
+ einfo "export XMODIFIERS=@im=SCIM"
+ einfo
+}