summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-10-26 17:24:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-10-26 17:24:46 +0000
commit0f466b1fed4652503d0841a26ddf2e16b6e113b1 (patch)
tree8bb6a4de504c5c60b444000745ad0c0ad37b893b /app-i18n/ibus-skk
parentInitial import (diff)
downloadgentoo-2-0f466b1fed4652503d0841a26ddf2e16b6e113b1.tar.gz
gentoo-2-0f466b1fed4652503d0841a26ddf2e16b6e113b1.tar.bz2
gentoo-2-0f466b1fed4652503d0841a26ddf2e16b6e113b1.zip
Version bumped.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-skk')
-rw-r--r--app-i18n/ibus-skk/ChangeLog7
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-i18n/ibus-skk/ChangeLog b/app-i18n/ibus-skk/ChangeLog
index 723899bc7dc3..b0e532ff3f92 100644
--- a/app-i18n/ibus-skk/ChangeLog
+++ b/app-i18n/ibus-skk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-skk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.12 2010/09/17 00:19:29 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ChangeLog,v 1.13 2010/10/26 17:24:46 matsuu Exp $
+
+*ibus-skk-1.3.2 (26 Oct 2010)
+
+ 26 Oct 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-skk-1.3.2.ebuild:
+ Version bumped.
*ibus-skk-1.3.0 (17 Sep 2010)
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild
new file mode 100644
index 000000000000..5d8f16467550
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.2.ebuild,v 1.1 2010/10/26 17:24:46 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}