summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-06-18 16:00:09 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-06-18 16:00:09 +0000
commite41d986fcc31c1d937bd14d9f5a2a72f53a38f5d (patch)
tree943b479e71439c583fa1e294eb3923722e7ccc8b /app-i18n/ibus-anthy
parentfix patch filename (diff)
downloadgentoo-2-e41d986fcc31c1d937bd14d9f5a2a72f53a38f5d.tar.gz
gentoo-2-e41d986fcc31c1d937bd14d9f5a2a72f53a38f5d.tar.bz2
gentoo-2-e41d986fcc31c1d937bd14d9f5a2a72f53a38f5d.zip
Force buildsystem to use python2, bug #420213
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/ibus-anthy')
-rw-r--r--app-i18n/ibus-anthy/ChangeLog7
-rw-r--r--app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/app-i18n/ibus-anthy/ChangeLog b/app-i18n/ibus-anthy/ChangeLog
index 654663051836..0a12fc905116 100644
--- a/app-i18n/ibus-anthy/ChangeLog
+++ b/app-i18n/ibus-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-anthy
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.35 2012/06/08 11:51:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ChangeLog,v 1.36 2012/06/18 16:00:09 maksbotan Exp $
+
+*ibus-anthy-1.2.7-r1 (18 Jun 2012)
+
+ 18 Jun 2012; Maxim Koltsov <maksbotan@gentoo.org> +ibus-anthy-1.2.7-r1.ebuild:
+ Force buildsystem to use python2, bug #420213
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> ibus-anthy-1.2.7.ebuild:
x86 stable wrt bug #418583
diff --git a/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild b/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..38d077d77e61
--- /dev/null
+++ b/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-anthy/ibus-anthy-1.2.7-r1.ebuild,v 1.1 2012/06/18 16:00:09 maksbotan Exp $
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+inherit eutils python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.2.0.20100111
+ app-i18n/anthy
+ >=dev-python/pygtk-2.15.2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/intltool
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ >py-compile #397497
+}
+
+src_configure() {
+ PYTHON="$(PYTHON -a)" econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "app-dicts/kasumi is not required but probably useful for you."
+ elog
+ elog "# emerge app-dicts/kasumi"
+ elog
+
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}