summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2014-01-20 15:12:27 +0000
committerBen de Groot <yngwin@gentoo.org>2014-01-20 15:12:27 +0000
commit76ecbb9dbc6c9e5da7cb84d8408c5b5a95c6f0af (patch)
tree4bff7eab8144abe311670eea8422d6daf12f9e03 /app-i18n/fcitx-configtool
parentversion bump (diff)
downloadgentoo-2-76ecbb9dbc6c9e5da7cb84d8408c5b5a95c6f0af.tar.gz
gentoo-2-76ecbb9dbc6c9e5da7cb84d8408c5b5a95c6f0af.tar.bz2
gentoo-2-76ecbb9dbc6c9e5da7cb84d8408c5b5a95c6f0af.zip
version bump
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x0F9C590B7FF324F6!)
Diffstat (limited to 'app-i18n/fcitx-configtool')
-rw-r--r--app-i18n/fcitx-configtool/ChangeLog9
-rw-r--r--app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-i18n/fcitx-configtool/ChangeLog b/app-i18n/fcitx-configtool/ChangeLog
index 1ac38b0dedd5..170392ad9e0c 100644
--- a/app-i18n/fcitx-configtool/ChangeLog
+++ b/app-i18n/fcitx-configtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/fcitx-configtool
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/ChangeLog,v 1.22 2013/08/03 14:48:22 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/ChangeLog,v 1.23 2014/01/20 15:12:27 yngwin Exp $
+
+*fcitx-configtool-0.4.8 (20 Jan 2014)
+
+ 20 Jan 2014; Ben de Groot <yngwin@gentoo.org> +fcitx-configtool-0.4.8.ebuild:
+ version bump
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> fcitx-configtool-0.4.6.ebuild:
Stable for ppc, wrt bug #461512
diff --git a/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild
new file mode 100644
index 000000000000..cb8089f512bc
--- /dev/null
+++ b/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/fcitx-configtool/fcitx-configtool-0.4.8.ebuild,v 1.1 2014/01/20 15:12:27 yngwin Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A GTK+ GUI configuration tool for fcitx"
+HOMEPAGE="http://fcitx-im.org/"
+SRC_URI="http://download.fcitx-im.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk +gtk3"
+REQUIRED_USE="|| ( gtk gtk3 )"
+
+RDEPEND=">=app-i18n/fcitx-4.2.8
+ dev-libs/glib:2
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )"
+DEPEND="${RDEPEND}
+ app-text/iso-codes
+ dev-libs/libunique:1
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable gtk GTK2)
+ $(cmake-utils_use_enable gtk3 GTK3)"
+ cmake-utils_src_configure
+}