summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-10-03 15:00:26 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-10-03 15:00:26 +0000
commit2cde44ea86aa605832142adeea1b8e4ad5e36572 (patch)
tree78f2da0049415a37ff61b19c1a9bc4737236e27c /app-forensics
parentVersion bump. (diff)
downloadgentoo-2-2cde44ea86aa605832142adeea1b8e4ad5e36572.tar.gz
gentoo-2-2cde44ea86aa605832142adeea1b8e4ad5e36572.tar.bz2
gentoo-2-2cde44ea86aa605832142adeea1b8e4ad5e36572.zip
Revision bump. Fixes bug #410525, thanks to Ian Delaney. Also contains a lot of enhancements, described in bug's comments
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/air/ChangeLog8
-rw-r--r--app-forensics/air/air-2.0.0-r1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/app-forensics/air/ChangeLog b/app-forensics/air/ChangeLog
index 2465d2bec6f6..195ecf4871ed 100644
--- a/app-forensics/air/ChangeLog
+++ b/app-forensics/air/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/air
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/air/ChangeLog,v 1.20 2012/09/08 02:18:05 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/air/ChangeLog,v 1.21 2012/10/03 15:00:26 pinkbyte Exp $
+
+*air-2.0.0-r1 (03 Oct 2012)
+
+ 03 Oct 2012; Sergey Popov <pinkbyte@gentoo.org> +air-2.0.0-r1.ebuild:
+ Revision bump. Fixes bug #410525, thanks to Ian Delaney. Also contains a lot
+ of enhancements, described in bug's comments
08 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
diff --git a/app-forensics/air/air-2.0.0-r1.ebuild b/app-forensics/air/air-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..e46ab251eee1
--- /dev/null
+++ b/app-forensics/air/air-2.0.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/air/air-2.0.0-r1.ebuild,v 1.1 2012/10/03 15:00:26 pinkbyte Exp $
+
+EAPI="4"
+
+DESCRIPTION="A GUI front-end to dd/dc3dd"
+HOMEPAGE="http://air-imager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/air-imager/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+# coreutils are needed for /usr/bin/split binary
+COMMON_DEPEND="userland_GNU? ( sys-apps/coreutils )"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-perl/perl-tk-804.27.0
+ userland_GNU? ( app-arch/sharutils )"
+
+# TODO: air can utilize dc3dd, but it is not in portage ATM
+RDEPEND="${COMMON_DEPEND}
+ app-arch/mt-st
+ net-analyzer/netcat
+ crypt? ( net-analyzer/cryptcat )"
+
+src_install() {
+ export PERLTK_VER=`perl -e 'use Tk;print "$Tk::VERSION";'`
+
+ env INTERACTIVE=no INSTALL_DIR="${D}/usr" TEMP_DIR="${T}" \
+ FINAL_INSTALL_DIR=/usr \
+ ./install-${P} \
+ || die "failed to install - please attach ${T}/air-install.log to a bug report at http://bugs.gentoo.org"
+
+ dodoc README
+
+ dodoc "${T}/air-install.log"
+
+ fowners root:users /usr/share/air/logs
+ fperms ug+rwx /usr/share/air/logs
+ fperms a+x /usr/bin/air
+
+ mkfifo "${D}usr/share/air/air-fifo" || die "pipe creation failed"
+ fperms ug+rw /usr/share/air/air-fifo
+ fowners root:users /usr/share/air/air-fifo
+}
+
+pkg_postinst() {
+ elog "The author, steve@unixgurus.com, would appreciate an email of the install file /usr/share/doc/${PF}/air-install.log"
+}