summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-02-15 11:27:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-02-15 11:27:02 +0000
commit28f5016260283d727c61f1d0632ef1a14288c869 (patch)
treea44fd73d82e55dd115c3ce2d9ecc79085708fb1a /app-forensics
parentUpdate manifest files, upstream changed packages without versioning, bug #258509 (diff)
downloadgentoo-2-28f5016260283d727c61f1d0632ef1a14288c869.tar.gz
gentoo-2-28f5016260283d727c61f1d0632ef1a14288c869.tar.bz2
gentoo-2-28f5016260283d727c61f1d0632ef1a14288c869.zip
Fixing the location of the rkhunter binary, closes #258732
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/ChangeLog8
-rw-r--r--app-forensics/rkhunter/rkhunter-1.2.9-r1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index c382e417375e..77365a22d321 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/rkhunter
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.67 2009/01/18 00:20:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.68 2009/02/15 11:27:02 patrick Exp $
+
+*rkhunter-1.2.9-r1 (15 Feb 2009)
+
+ 15 Feb 2009; Patrick Lauer <patrick@gentoo.org> +rkhunter-1.2.9-r1.ebuild:
+ Fixing rkhunter 1.2.9 binary path to match the cron and be consistent with
+ 1.3.4. Fixes bug #258732
*rkhunter-1.3.4-r2 (18 Jan 2009)
diff --git a/app-forensics/rkhunter/rkhunter-1.2.9-r1.ebuild b/app-forensics/rkhunter/rkhunter-1.2.9-r1.ebuild
new file mode 100644
index 000000000000..ab7376d62365
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.2.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.2.9-r1.ebuild,v 1.1 2009/02/15 11:27:02 patrick Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/rkhunter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 mips ppc sparc x86"
+IUSE=""
+
+RDEPEND="virtual/mta
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof"
+
+S="${WORKDIR}/${P}/files"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.1-create-tmpdir.diff
+ epatch "${FILESDIR}"/${PN}-1.2.9-ppc64.patch
+}
+
+src_install() {
+ insinto /usr/lib/rkhunter/db
+ doins *.dat || die "failed to install dat files"
+
+ exeinto /usr/lib/rkhunter/scripts
+ doexe *.pl check_update.sh || die "failed to install scripts"
+
+ dosbin rkhunter || die "failed to install rkhunter script"
+
+ insinto /etc
+ doins rkhunter.conf || die "failed to install rkhunter.conf"
+ dosed 's:^#\(DBDIR=.*\)local\(.*\)$:\1lib\2\nINSTALLDIR=/usr:' \
+ /etc/rkhunter.conf || die "sed rkhunter.conf failed"
+
+ doman development/rkhunter.8 || die "doman failed"
+ dodoc CHANGELOG LICENSE README WISHLIST || die "dodoc failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/rkhunter.cron rkhunter || \
+ die "failed to install cron script"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+}
+
+pkg_postinst() {
+ echo
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ echo
+ bash-completion_pkg_postinst
+}
+
+pkg_prerm() {
+ rm -rf /usr/lib/rkhunter/tmp
+}