summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-14 05:39:32 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-14 05:39:32 +0000
commit1804bc5288426f5792e88120980ad29239cd81f7 (patch)
tree17099a69bb4f3b7014634b59d809dae6a4b85cbb /app-forensics
parentSupport for py2.5 dropped due to test failure, support for multiple 'impls' s... (diff)
downloadgentoo-2-1804bc5288426f5792e88120980ad29239cd81f7.tar.gz
gentoo-2-1804bc5288426f5792e88120980ad29239cd81f7.tar.bz2
gentoo-2-1804bc5288426f5792e88120980ad29239cd81f7.zip
Revision bump. Add fuse, uuid, and ssl use flags and fix deps.
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog10
-rw-r--r--app-forensics/libewf/libewf-20121209-r1.ebuild48
-rw-r--r--app-forensics/libewf/metadata.xml2
3 files changed, 58 insertions, 2 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index ac82efe59cdd..7ed95e8e427e 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-forensics/libewf
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.29 2012/12/10 05:17:10 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.30 2013/01/14 05:39:32 radhermit Exp $
+
+*libewf-20121209-r1 (14 Jan 2013)
+
+ 14 Jan 2013; Tim Harder <radhermit@gentoo.org> +libewf-20121209-r1.ebuild,
+ metadata.xml:
+ Revision bump. Add fuse, uuid, and ssl use flags and fix deps.
*libewf-20121209 (10 Dec 2012)
diff --git a/app-forensics/libewf/libewf-20121209-r1.ebuild b/app-forensics/libewf/libewf-20121209-r1.ebuild
new file mode 100644
index 000000000000..dc682615ae07
--- /dev/null
+++ b/app-forensics/libewf/libewf-20121209-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20121209-r1.ebuild,v 1.1 2013/01/14 05:39:32 radhermit Exp $
+
+EAPI="5"
+
+inherit autotools-utils
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug ewf +fuse rawio +ssl static-libs +uuid unicode"
+
+DEPEND="
+ sys-libs/zlib
+ fuse? ( sys-fs/fuse )
+ uuid? ( sys-apps/util-linux )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=( AUTHORS ChangeLog NEWS README documents/header.txt documents/header2.txt )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug debug-output)
+ $(use_enable debug verbose-output)
+ $(use_enable ewf v1-api)
+ $(use_enable rawio low-level-functions)
+ $(use_enable unicode wide-character-type)
+ $(use_with ssl openssl)
+ $(use_with uuid libuuid)
+ $(use_with fuse libfuse)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ doman manuals/*.1 manuals/*.3
+}
diff --git a/app-forensics/libewf/metadata.xml b/app-forensics/libewf/metadata.xml
index cd98ec55dea2..f014d1166d39 100644
--- a/app-forensics/libewf/metadata.xml
+++ b/app-forensics/libewf/metadata.xml
@@ -6,5 +6,7 @@
<flag name="rawio">Enables raw IO handling</flag>
<flag name="ewf2">Enables the v2 API</flag>
<flag name="ewf">Enables the v1 API</flag>
+ <flag name="fuse">Enable fuse support for ewfmount</flag>
+ <flag name="uuid">Enable UUID support in the ewftools</flag>
</use>
</pkgmetadata>