summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-01 04:34:18 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-01 04:34:18 +0000
commit113ff2b8f74c258eb26bb368003dcda2cdb0d3e1 (patch)
treed6a88c6f20ffc4a068f6ec9f74c92635a62759f9 /app-forensics
parentStable for HPPA (bug #410957). (diff)
downloadgentoo-2-113ff2b8f74c258eb26bb368003dcda2cdb0d3e1.tar.gz
gentoo-2-113ff2b8f74c258eb26bb368003dcda2cdb0d3e1.tar.bz2
gentoo-2-113ff2b8f74c258eb26bb368003dcda2cdb0d3e1.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/rkhunter/ChangeLog7
-rw-r--r--app-forensics/rkhunter/rkhunter-1.4.0.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-forensics/rkhunter/ChangeLog b/app-forensics/rkhunter/ChangeLog
index 4c8323fd9af4..faf81835b385 100644
--- a/app-forensics/rkhunter/ChangeLog
+++ b/app-forensics/rkhunter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/rkhunter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.90 2012/04/09 03:43:46 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/ChangeLog,v 1.91 2012/05/01 04:34:18 radhermit Exp $
+
+*rkhunter-1.4.0 (01 May 2012)
+
+ 01 May 2012; Tim Harder <radhermit@gentoo.org> +rkhunter-1.4.0.ebuild:
+ Version bump.
*rkhunter-1.3.8-r1 (09 Apr 2012)
diff --git a/app-forensics/rkhunter/rkhunter-1.4.0.ebuild b/app-forensics/rkhunter/rkhunter-1.4.0.ebuild
new file mode 100644
index 000000000000..71de21a8bc31
--- /dev/null
+++ b/app-forensics/rkhunter/rkhunter-1.4.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/rkhunter/rkhunter-1.4.0.ebuild,v 1.1 2012/05/01 04:34:18 radhermit Exp $
+
+EAPI=4
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Rootkit Hunter scans for known and unknown rootkits, backdoors, and sniffers."
+HOMEPAGE="http://rkhunter.sf.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ dev-lang/perl
+ sys-process/lsof
+ virtual/cron
+"
+
+S="${WORKDIR}/${P}/files"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}.conf.patch"
+}
+
+src_install() {
+ # rkhunter requires to be root
+ dosbin ${PN}
+
+ # rkhunter doesn't create it by itself
+ dodir /var/lib/${PN}/tmp
+
+ insinto /etc
+ doins ${PN}.conf
+
+ exeinto /usr/lib/${PN}/scripts
+ doexe *.pl
+
+ insinto /var/lib/${PN}/db
+ doins *.dat
+
+ insinto /var/lib/${PN}/db/i18n
+ doins i18n/*
+
+ doman ${PN}.8
+ dodoc ACKNOWLEDGMENTS CHANGELOG FAQ README
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}-1.3.cron" ${PN}
+
+ newbashcomp "${FILESDIR}/${PN}.bash-completion" ${PN}
+}
+
+pkg_postinst() {
+ elog "A cron script has been installed to /etc/cron.daily/rkhunter."
+ elog "To enable it, edit /etc/cron.daily/rkhunter and follow the"
+ elog "directions."
+ elog "If you want ${PN} to send mail, you will need to install"
+ elog "virtual/mailx or alter the EMAIL_CMD variable in the"
+ elog "cron script and possibly the MAIL_CMD variable in the"
+ elog "${PN}.conf file to use another mail client."
+}