summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-16 02:27:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-16 02:27:44 +0000
commitf5d83012a51800dcbeca0cb78aa35971fcf958eb (patch)
tree3eac57e0c9367288542ec655fbd08ecfd0162439 /app-emulation
parentuse DESTDIR now (diff)
downloadgentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.tar.gz
gentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.tar.bz2
gentoo-2-f5d83012a51800dcbeca0cb78aa35971fcf958eb.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-5.1.ebuild61
-rw-r--r--app-emulation/cedega/files/digest-cedega-5.13
-rw-r--r--app-emulation/wine/ChangeLog8
-rw-r--r--app-emulation/wine/files/digest-wine-0.9.83
-rw-r--r--app-emulation/wine/files/wine-0.9.8-destdir.patch11
-rw-r--r--app-emulation/wine/wine-0.9.8.ebuild132
7 files changed, 223 insertions, 2 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 97b15282c32c..5494139ec230 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.22 2006/02/11 05:41:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.23 2006/02/16 02:27:44 vapier Exp $
+
+*cedega-5.1 (16 Feb 2006)
+
+ 16 Feb 2006; Mike Frysinger <vapier@gentoo.org> +cedega-5.1.ebuild:
+ Version bump.
11 Feb 2006; Mike Frysinger <vapier@gentoo.org> cedega-4.0.ebuild,
cedega-4.0.1.ebuild, cedega-4.1.ebuild, cedega-4.1.1.ebuild,
diff --git a/app-emulation/cedega/cedega-5.1.ebuild b/app-emulation/cedega/cedega-5.1.ebuild
new file mode 100644
index 000000000000..76ef6e4c35e7
--- /dev/null
+++ b/app-emulation/cedega/cedega-5.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-5.1.ebuild,v 1.1 2006/02/16 02:27:44 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="|| ( ( x11-libs/libX11 ) virtual/x11 )
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ rmdir "${WORKDIR}"/usr/share/* >& /dev/null
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-5.1 b/app-emulation/cedega/files/digest-cedega-5.1
new file mode 100644
index 000000000000..0459f4606853
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-5.1
@@ -0,0 +1,3 @@
+MD5 c0d1215c71358f1f46c264522f737f6b cedega-small-5.1.tgz 1179565
+RMD160 07232527fec76f8e821f88a3722bad3938a4dcfb cedega-small-5.1.tgz 1179565
+SHA256 b64a78b693835f0395b4df9e54be39bd97adfb34f0c6092e260bbe040efc13c0 cedega-small-5.1.tgz 1179565
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index 7479180b1f6e..0841f2955655 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.127 2006/02/05 13:45:51 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.128 2006/02/16 02:26:02 vapier Exp $
+
+*wine-0.9.8 (16 Feb 2006)
+
+ 16 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/wine-0.9.8-destdir.patch, +wine-0.9.8.ebuild:
+ Version bump.
05 Feb 2006; Simon Stelling <blubb@gentoo.org> wine-0.9.5-r1.ebuild,
wine-0.9.7.ebuild, wine-9999.ebuild:
diff --git a/app-emulation/wine/files/digest-wine-0.9.8 b/app-emulation/wine/files/digest-wine-0.9.8
new file mode 100644
index 000000000000..d84b4eaca9c0
--- /dev/null
+++ b/app-emulation/wine/files/digest-wine-0.9.8
@@ -0,0 +1,3 @@
+MD5 a3b3914c9e34df910045384d64baee87 wine-0.9.8.tar.bz2 10563571
+RMD160 54b44b3733cb1628189830e3e8295efa848af6f1 wine-0.9.8.tar.bz2 10563571
+SHA256 6e6442aec2a889f04897ad739b863abec05c320a6f43c12198914cf7f830ee48 wine-0.9.8.tar.bz2 10563571
diff --git a/app-emulation/wine/files/wine-0.9.8-destdir.patch b/app-emulation/wine/files/wine-0.9.8-destdir.patch
new file mode 100644
index 000000000000..fd9488d19e7d
--- /dev/null
+++ b/app-emulation/wine/files/wine-0.9.8-destdir.patch
@@ -0,0 +1,11 @@
+--- programs/Makefile.in
++++ programs/Makefile.in
+@@ -152,7 +152,7 @@ install-apploader: wineapploader dummy
+ $(INSTALL_SCRIPT) wineapploader $(DESTDIR)$(bindir)/wineapploader
+
+ $(INSTALLPROGS:%=%/__installprog__): install-apploader
+- $(RM) $(DESTDIR)$(bindir)/`dirname $@` && $(LN) $(DESTDIR)$(bindir)/wineapploader $(DESTDIR)$(bindir)/`dirname $@`
++ $(RM) $(DESTDIR)$(bindir)/`dirname $@` && $(LN) wineapploader $(DESTDIR)$(bindir)/`dirname $@`
+
+ install-progs.so: $(INSTALLPROGS:%=%/__installprog__)
+ $(RM) $(DESTDIR)$(bindir)/wineapploader
diff --git a/app-emulation/wine/wine-0.9.8.ebuild b/app-emulation/wine/wine-0.9.8.ebuild
new file mode 100644
index 000000000000..9c9c7af5ea65
--- /dev/null
+++ b/app-emulation/wine/wine-0.9.8.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.8.ebuild,v 1.1 2006/02/16 02:26:02 vapier Exp $
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.com/"
+SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml2 X"
+RESTRICT="test" #72375
+
+RDEPEND=">=media-libs/freetype-2.0.0
+ media-fonts/corefonts
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ X? ( || ( ( x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
+ arts? ( kde-base/arts )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ glut? ( virtual/glut )
+ lcms? ( media-libs/lcms )
+ xml2? ( dev-libs/libxml2 dev-libs/libxslt )
+ truetype? ( media-libs/freetype )
+ scanner? ( media-gfx/sane-backends )
+ amd64? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ >=sys-kernel/linux-headers-2.6
+ )"
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ use amd64 && has_multilib_profile && export ABI=x86
+}
+
+src_unpack() {
+ unpack wine-${PV}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/wine-0.9.6-force-ddraw-gamma.patch #119931
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
+ epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+config_cache() {
+ local h ans="no"
+ use $1 && ans="yes"
+ shift
+ for h in "$@" ; do
+ [[ ${h} == *.h ]] \
+ && h=header_${h} \
+ || h=lib_${h}
+ export ac_cv_${h//[:\/.]/_}=${ans}
+ done
+}
+
+src_compile() {
+ export LDCONFIG=/bin/true
+# use arts || export ARTSCCONFIG=""
+# use esd || export ESDCONFIG=""
+# use scanner || export sane_devel="no"
+# config_cache jack jack/jack.h
+# config_cache cups cups/cups.h
+# config_cache alsa alsa/asoundlib.h sys/asoundlib.h asound:snd_pcm_open
+# config_cache nas audio/audiolib.h audio/soundlib.h
+# config_cache xml2 libxml/parser.h libxslt/pattern.h libxslt/transform.h
+# config_cache ldap ldap.h lber.h
+# config_cache gif gif_lib.h
+# config_cache glut glut:glutMainLoop
+# config_cache jpeg jpeglib.h
+# config_cache oss sys/soundcard.h machine/soundcard.h soundcard.h
+# config_cache lcms lcms.h
+ use x86 && config_cache truetype freetype:FT_Init_FreeType
+
+ strip-flags
+# use lcms && append-flags -I"${ROOT}"/usr/include/lcms
+
+ # $(use_enable amd64 win64)
+ econf \
+ CC=$(tc-getCC) \
+ --sysconfdir=/etc/wine \
+ $(use_with ncurses curses) \
+ $(use_with opengl) \
+ $(use_with X x) \
+ $(use_enable debug trace) \
+ $(use_enable debug) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+ emake all || die "all"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS ChangeLog DEVELOPERS-HINTS README
+}
+
+pkg_postinst() {
+ einfo "~/.wine/config is now deprecated. For configuration either use"
+ einfo "winecfg or regedit HKCU\\Software\\Wine"
+}