summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2005-09-15 21:16:21 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2005-09-15 21:16:21 +0000
commitc6454dd8e105357dd0db76f31f2fc29523ffae8e (patch)
tree98c7364247f212ea81b0bca45342742037490bf6 /app-emulation
parentMark 0.7.21 stable on alpha (diff)
downloadgentoo-2-c6454dd8e105357dd0db76f31f2fc29523ffae8e.tar.gz
gentoo-2-c6454dd8e105357dd0db76f31f2fc29523ffae8e.tar.bz2
gentoo-2-c6454dd8e105357dd0db76f31f2fc29523ffae8e.zip
bug 69831 and stuff
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/simh/ChangeLog9
-rw-r--r--app-emulation/simh/Manifest4
-rw-r--r--app-emulation/simh/files/digest-simh-3.5.01
-rw-r--r--app-emulation/simh/simh-3.3.0.ebuild17
-rw-r--r--app-emulation/simh/simh-3.5.0.ebuild50
5 files changed, 72 insertions, 9 deletions
diff --git a/app-emulation/simh/ChangeLog b/app-emulation/simh/ChangeLog
index 34bbfcb4bfc0..0aa9248ab71c 100644
--- a/app-emulation/simh/ChangeLog
+++ b/app-emulation/simh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/simh
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.1 2005/08/27 20:59:39 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.2 2005/09/15 21:16:21 vanquirius Exp $
+
+*simh-3.5.0 (15 Sep 2005)
+
+ 15 Sep 2005; Marcelo Goes <vanquirius@gentoo.org> simh-3.3.0.ebuild,
+ +simh-3.5.0.ebuild:
+ Add DEPEND on app-arch/unzip for bug 69831, fix hardcoded SRC_URI, version
+ bump and other QA stuff.
27 Aug 2005; <rphillips@gentoo.org> :
New ebuild. Thanks to Emil Skoldberg. Fixes #73996
diff --git a/app-emulation/simh/Manifest b/app-emulation/simh/Manifest
index af5e9895e8dc..511629d3e85c 100644
--- a/app-emulation/simh/Manifest
+++ b/app-emulation/simh/Manifest
@@ -1,5 +1,7 @@
-MD5 24ce35f1d11838c35c482ea4fb750a19 simh-3.3.0.ebuild 950
+MD5 f373ff97a53c0583f2909797eb785b45 simh-3.5.0.ebuild 1115
+MD5 1460710d9a7db854b07302825cd5a0ce simh-3.3.0.ebuild 1114
MD5 8d29123aba71179ef9974e37c84c16a2 ChangeLog 306
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 1dc0c3f3a27cb7fb307f8d027cb65f85 files/makefile.patch 383
MD5 ff5b80de0c6ccbeb7007cd208b3882d1 files/digest-simh-3.3.0 59
+MD5 106dbb8bf6477a1d79d4eced5719a9a8 files/digest-simh-3.5.0 59
diff --git a/app-emulation/simh/files/digest-simh-3.5.0 b/app-emulation/simh/files/digest-simh-3.5.0
new file mode 100644
index 000000000000..4cedf3f9d99b
--- /dev/null
+++ b/app-emulation/simh/files/digest-simh-3.5.0
@@ -0,0 +1 @@
+MD5 2778b3ecbde57edd85e23bed723b58ff simhv35-0.zip 2232587
diff --git a/app-emulation/simh/simh-3.3.0.ebuild b/app-emulation/simh/simh-3.3.0.ebuild
index 2cb2328b7e4b..0958f4263d29 100644
--- a/app-emulation/simh/simh-3.3.0.ebuild
+++ b/app-emulation/simh/simh-3.3.0.ebuild
@@ -1,32 +1,35 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.3.0.ebuild,v 1.1 2005/08/27 20:59:39 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.3.0.ebuild,v 1.2 2005/09/15 21:16:21 vanquirius Exp $
-inherit eutils
+inherit eutils versionator
+MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
HOMEPAGE="http://simh.trailing-edge.com/"
-SRC_URI="http://simh.trailing-edge.com/sources/simhv33-0.zip"
+SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
-DEPEND="net-libs/libpcap"
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
-S=${WORKDIR}
+S="${WORKDIR}"
MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
src_unpack() {
- mkdir ${WORKDIR}/BIN
+ mkdir "${WORKDIR}/BIN"
unpack ${A}
# convert makefile from dos format to unix format
sed -i 's/.$//' makefile
- epatch ${FILESDIR}/makefile.patch
+ epatch "${FILESDIR}/makefile.patch"
}
src_compile() {
diff --git a/app-emulation/simh/simh-3.5.0.ebuild b/app-emulation/simh/simh-3.5.0.ebuild
new file mode 100644
index 000000000000..319bb92cbe1f
--- /dev/null
+++ b/app-emulation/simh/simh-3.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.5.0.ebuild,v 1.1 2005/09/15 21:16:21 vanquirius Exp $
+
+inherit eutils versionator
+
+MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
+DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
+HOMEPAGE="http://simh.trailing-edge.com/"
+SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
+
+
+src_unpack() {
+ mkdir "${WORKDIR}/BIN"
+ unpack ${A}
+
+ # convert makefile from dos format to unix format
+ sed -i 's/.$//' makefile
+
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}/BIN"
+ for BINFILE in *; do
+ newbin ${BINFILE} "simh-${BINFILE}"
+ done
+
+ cd ${S}
+ dodir /usr/share/simh
+ insinto /usr/share/simh
+ doins VAX/*.bin
+ dodoc *.txt */*.txt
+}