summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-05-17 14:13:26 +0000
committerDan Armak <danarmak@gentoo.org>2002-05-17 14:13:26 +0000
commitc5f98707cc7c2fb569f01a24439dc7c422f81ad2 (patch)
tree2c0a95d4163622738875b1c425dcf1fbc291b051 /app-emulation
parentnew version (diff)
downloadgentoo-2-c5f98707cc7c2fb569f01a24439dc7c422f81ad2.tar.gz
gentoo-2-c5f98707cc7c2fb569f01a24439dc7c422f81ad2.tar.bz2
gentoo-2-c5f98707cc7c2fb569f01a24439dc7c422f81ad2.zip
fix bugs #2746, #2783 - add patch removing a comment line from a .asm source which confused nasm
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/zsnes/ChangeLog7
-rw-r--r--app-emulation/zsnes/files/zsnes-1.337-gentoo.patch12
-rw-r--r--app-emulation/zsnes/zsnes-1.337-r2.ebuild36
3 files changed, 54 insertions, 1 deletions
diff --git a/app-emulation/zsnes/ChangeLog b/app-emulation/zsnes/ChangeLog
index e866004be651..94faf88d73a6 100644
--- a/app-emulation/zsnes/ChangeLog
+++ b/app-emulation/zsnes/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for app-emulation/zsnes
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.3 2002/05/08 08:48:20 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zsnes/ChangeLog,v 1.4 2002/05/17 14:13:25 danarmak Exp $
+*zsnes-1.337-r2 (17 May 2002)
+
+ 17 May 2002; Dan Armak <danarmak@gentoo.org> changelog:
+
+ Fix bugs #2746, #2783 - remove a comment from init.asm which confused nasm.
*zsnes-1.337-r1 (7 May 2002)
7 May 2002; Spider <spider@gentoo.org> zsnes-1.337-r1.ebuild zsnes-1.337.ebuild :
diff --git a/app-emulation/zsnes/files/zsnes-1.337-gentoo.patch b/app-emulation/zsnes/files/zsnes-1.337-gentoo.patch
new file mode 100644
index 000000000000..1800f664442c
--- /dev/null
+++ b/app-emulation/zsnes/files/zsnes-1.337-gentoo.patch
@@ -0,0 +1,12 @@
+diff -NruB zsnes/src/init.asm zsnes.new/src/init.asm
+--- zsnes/src/init.asm Thu May 16 14:29:18 2002
++++ zsnes.new/src/init.asm Thu May 16 14:27:24 2002
+@@ -4602,7 +4602,6 @@
+ ; check for 2nd+ part of file
+ mov edi,fname+1
+ mov byte[.cchar],'\'
+- ; get position of . or \
+ .nextsearch
+ cmp byte[edi],0
+ je .nomore
+
diff --git a/app-emulation/zsnes/zsnes-1.337-r2.ebuild b/app-emulation/zsnes/zsnes-1.337-r2.ebuild
new file mode 100644
index 000000000000..58d75b8e5b87
--- /dev/null
+++ b/app-emulation/zsnes/zsnes-1.337-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/app-emulation/zsnes/zsnes-1.337-r1.ebuild,v 1.2 2002/05/08 08:48:20 spider Exp
+# Don't attempt to introduce $CFLAGS usage, docs say result will be slower.
+
+S=${WORKDIR}/${P}
+DESCRIPTION="zsnes is an excellent snes (super nintendo) emulator"
+SRC_URI="ftp://prdownloads.sourceforge.net/zsnes/zsnes1337src.tar.gz"
+HOMEPAGE="http://www.zsnes.com/"
+
+RDEPEND="opengl? ( virtual/opengl )
+ virtual/x11
+ >=media-libs/libsdl-1.2.0
+ sys-libs/zlib
+ media-libs/libpng"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/nasm-0.98"
+
+
+src_compile() {
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch
+ cd ${S}/src
+ use opengl || myconf="--without-opengl"
+ ./configure --prefix=/usr --host=${CHOST} $myconf || die
+ make || die
+}
+src_install () {
+ cd ${S}/src
+ into /usr
+ dobin zsnes
+ doman linux/zsnes.man
+ cd ${S}
+ dodoc *.txt linux/*
+}