summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-08 20:48:24 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-08 20:48:24 +0000
commit5264712c40e61ec3428fe110971e033be957cba3 (patch)
tree3f4d683e31ad486500d6a8dd07d07a43c0ef461d /app-emulation
parent2.1_pre10-r5 bug fix revbump (diff)
downloadgentoo-2-5264712c40e61ec3428fe110971e033be957cba3.tar.gz
gentoo-2-5264712c40e61ec3428fe110971e033be957cba3.tar.bz2
gentoo-2-5264712c40e61ec3428fe110971e033be957cba3.zip
gcc 4.1 fixes thanks to Nicolas Boichat <nicolas@boichat.ch> in bug 131676
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/kqemu/ChangeLog6
-rw-r--r--app-emulation/kqemu/kqemu-0.7.2.ebuild3
-rw-r--r--app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild3
3 files changed, 9 insertions, 3 deletions
diff --git a/app-emulation/kqemu/ChangeLog b/app-emulation/kqemu/ChangeLog
index db2d9bef5921..84b2d5b638dc 100644
--- a/app-emulation/kqemu/ChangeLog
+++ b/app-emulation/kqemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/kqemu
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.10 2006/05/07 20:28:32 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/ChangeLog,v 1.11 2006/05/08 20:48:24 genstef Exp $
+
+ 08 May 2006; Stefan Schweizer <genstef@gentoo.org> kqemu-0.7.2.ebuild,
+ kqemu-1.3.0_pre7.ebuild:
+ gcc 4.1 fixes thanks to Nicolas Boichat <nicolas@boichat.ch> in bug 131676
07 May 2006; Luca Barbato <lu_zero@gentoo.org> ChangeLog:
New version
diff --git a/app-emulation/kqemu/kqemu-0.7.2.ebuild b/app-emulation/kqemu/kqemu-0.7.2.ebuild
index 06814d35aaf6..a8174ca576c5 100644
--- a/app-emulation/kqemu/kqemu-0.7.2.ebuild
+++ b/app-emulation/kqemu/kqemu-0.7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-0.7.2.ebuild,v 1.5 2006/04/19 21:54:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-0.7.2.ebuild,v 1.6 2006/05/08 20:48:24 genstef Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -35,6 +35,7 @@ src_unpack() {
mv ${WORKDIR}/kqemu ${S}
cd ${S}/kqemu
+ sed -i 's:MODULE_PARM(\([^,]*\),"i");:module_param(\1, int, 0);:' kqemu-linux.c
sed -i -e 's:#ifndef PAGE_KERNEL_EXEC:#if 1:' ${S}/kqemu/kqemu-linux.c
# The class_simple interfaces were removed in 2.6.13-rc1, leaving only
# GPL symbols behind, which this module can't use. Until there's a fix
diff --git a/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild b/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild
index c23e3091ed31..816cd9d2d707 100644
--- a/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild
+++ b/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild,v 1.1 2006/05/07 20:28:32 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/kqemu/kqemu-1.3.0_pre7.ebuild,v 1.2 2006/05/08 20:48:24 genstef Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -34,6 +34,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd ${S}
+ sed -i 's:MODULE_PARM(\([^,]*\),"i");:module_param(\1, int, 0);:' kqemu-linux.c
}
src_compile() {