summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-03-22 23:25:57 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-03-22 23:25:57 +0000
commit50f0f97d99542895493ebb27292d827dff68dc1e (patch)
tree72c3c60c8495e7fbe4db017939683817ab6d0791 /app-emulation
parentbugfix release (diff)
downloadgentoo-2-50f0f97d99542895493ebb27292d827dff68dc1e.tar.gz
gentoo-2-50f0f97d99542895493ebb27292d827dff68dc1e.tar.bz2
gentoo-2-50f0f97d99542895493ebb27292d827dff68dc1e.zip
bugfix release
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/qemu-user-0.10.1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index af3e6e5a9cc4..e2e69d3646f3 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.36 2009/03/12 13:12:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.37 2009/03/22 23:25:57 lu_zero Exp $
+
+*qemu-user-0.10.1 (22 Mar 2009)
+
+ 22 Mar 2009; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.10.1.ebuild:
+ Bugfix release
12 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
qemu-user-0.10.0.ebuild:
diff --git a/app-emulation/qemu-user/qemu-user-0.10.1.ebuild b/app-emulation/qemu-user/qemu-user-0.10.1.ebuild
new file mode 100644
index 000000000000..3fcf893fc5ba
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.10.1.ebuild,v 1.1 2009/03/22 23:25:57 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+MY_PN=${PN/-user/}
+MY_P=${P/-user/}
+
+SRC_URI="http://savannah.nongnu.org/download/${MY_PN}/${MY_P}.tar.gz"
+
+DESCRIPTION="Open source dynamic translator"
+HOMEPAGE="http://bellard.org/qemu/index.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+RESTRICT="strip test"
+
+DEPEND="app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # prevent docs to get automatically installed
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ # Alter target makefiles to accept CFLAGS set via flag-o
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # avoid strip
+ sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' Makefile
+}
+
+src_compile() {
+ local mycc conf_opts
+
+ conf_opts="--enable-linux-user"
+ conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
+ conf_opts="${conf_opts} --disable-system"
+ conf_opts="${conf_opts} --disable-vnc-tls"
+ conf_opts="$conf_opts --disable-curses"
+ conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
+ conf_opts="$conf_opts --disable-vde"
+ conf_opts="$conf_opts --disable-kqemu"
+# use fdt || conf_opts="--disable-fdt"
+
+ conf_opts="$conf_opts --prefix=/usr --disable-bluez --disable-kvm"
+
+ filter-flags -fpie -fstack-protector
+
+ ./configure ${conf_opts} || die "econf failed"
+
+ emake || die "emake qemu failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -fR "${D}/usr/share"
+ dohtml qemu-doc.html
+ dohtml qemu-tech.html
+}