summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-20 00:35:29 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-20 00:35:29 +0000
commit2eb2e7018f288ab94f4210bd959ec517b6b6b3f4 (patch)
treeeccc3c90776d292eb755e2e4b04b035a358ed97a /app-emulation
parentopenmotif stable on amd64 (diff)
downloadgentoo-2-2eb2e7018f288ab94f4210bd959ec517b6b6b3f4.tar.gz
gentoo-2-2eb2e7018f288ab94f4210bd959ec517b6b6b3f4.tar.bz2
gentoo-2-2eb2e7018f288ab94f4210bd959ec517b6b6b3f4.zip
initial ebuild
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vgba/ChangeLog8
-rw-r--r--app-emulation/vgba/Manifest3
-rw-r--r--app-emulation/vgba/files/digest-vgba-2.01
-rw-r--r--app-emulation/vgba/vgba-2.0.ebuild28
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vgba/ChangeLog b/app-emulation/vgba/ChangeLog
new file mode 100644
index 000000000000..e6da5a2b6679
--- /dev/null
+++ b/app-emulation/vgba/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/vgba
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vgba/ChangeLog,v 1.1 2003/07/20 00:35:17 vapier Exp $
+
+*vgba-2.0 (19 Jul 2003)
+
+ 19 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/app-emulation/vgba/Manifest b/app-emulation/vgba/Manifest
new file mode 100644
index 000000000000..08059356a76d
--- /dev/null
+++ b/app-emulation/vgba/Manifest
@@ -0,0 +1,3 @@
+MD5 9a595d006fd249f4a87f1163047220ea ChangeLog 334
+MD5 d17c9a99f420e96a9bcefe0896777eb9 files/digest-vgba-2.0 73
+MD5 d540f5670a23f589e259ab1fcc2c010e vgba-2.0.ebuild 645
diff --git a/app-emulation/vgba/files/digest-vgba-2.0 b/app-emulation/vgba/files/digest-vgba-2.0
new file mode 100644
index 000000000000..26d33409e1cb
--- /dev/null
+++ b/app-emulation/vgba/files/digest-vgba-2.0
@@ -0,0 +1 @@
+MD5 6756c007468b3ca1eb9c3aa333d4ea7b VGBA20-Linux-80x86-bin.tar.Z 290664
diff --git a/app-emulation/vgba/vgba-2.0.ebuild b/app-emulation/vgba/vgba-2.0.ebuild
new file mode 100644
index 000000000000..250f42a59572
--- /dev/null
+++ b/app-emulation/vgba/vgba-2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vgba/vgba-2.0.ebuild,v 1.1 2003/07/20 00:35:17 vapier Exp $
+
+inherit games
+
+DESCRIPTION="emulator of the GameBoy Advance"
+HOMEPAGE="http://www.komkon.org/fms/VGBA/"
+SRC_URI="http://fms.komkon.org/VGBA/VGBA${PV/.}-Linux-80x86-bin.tar.Z"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="virtual/x11"
+
+S=${WORKDIR}
+
+src_install() {
+ dogamesbin vgba
+ dohtml VGBA.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ ewarn "You must run X in 16bit color for the emu to work"
+}