summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2009-10-29 14:14:52 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2009-10-29 14:14:52 +0000
commit288ad328034a834b23053312763ce8f29ed40eee (patch)
treed57d7891c630dac7c4bceb6c2e1093fc50d275fd /app-emulation
parentopen-vm-tools kernel modules (diff)
downloadgentoo-2-288ad328034a834b23053312763ce8f29ed40eee.tar.gz
gentoo-2-288ad328034a834b23053312763ce8f29ed40eee.tar.bz2
gentoo-2-288ad328034a834b23053312763ce8f29ed40eee.zip
version bump. ebuild split.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog10
-rw-r--r--app-emulation/open-vm-tools/files/default-scripts1.patch163
-rw-r--r--app-emulation/open-vm-tools/files/wiper-warning-fix.patch14
-rw-r--r--app-emulation/open-vm-tools/metadata.xml1
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild130
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild129
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20091015.201664.ebuild106
7 files changed, 279 insertions, 274 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 1b777fe9059a..ad94d754203e 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.25 2009/08/27 19:03:47 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.26 2009/10/29 14:14:51 vadimk Exp $
+
+*open-vm-tools-0.0.20091015.201664 (29 Oct 2009)
+
+ 29 Oct 2009; Vadim Kuznetsov vadimk@gentoo.org
+ +files/default-scripts1.patch, -open-vm-tools-0.0.20090522.167859.ebuild,
+ -open-vm-tools-0.0.20090618.172495.ebuild,
+ +open-vm-tools-0.0.20091015.201664.ebuild, -files/wiper-warning-fix.patch:
+ version bump. ebuild split. see open-vm-tools-kmod.
*open-vm-tools-0.0.20090824.187411 (27 Aug 2009)
diff --git a/app-emulation/open-vm-tools/files/default-scripts1.patch b/app-emulation/open-vm-tools/files/default-scripts1.patch
new file mode 100644
index 000000000000..d89ff907805f
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/default-scripts1.patch
@@ -0,0 +1,163 @@
+diff -ur scripts.orig/linux/resume-vm-default scripts/linux/resume-vm-default
+--- scripts.orig/linux/resume-vm-default 2009-10-26 14:08:44.000000000 -0400
++++ scripts/linux/resume-vm-default 2009-10-26 14:07:29.000000000 -0400
+@@ -25,37 +25,6 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ save_active_NIC_list() {
+ ifconfig_path=`which ifconfig 2>/dev/null`
+ if [ $? ]; then
+@@ -73,7 +42,7 @@
+ rescue_NIC() {
+ niclist="/var/run/vmware-active-nics"
+
+- ifup_path=`which ifup 2>/dev/null`;
++ ifup_path="/etc/init.d/net.";
+ if [ $? -ne 0 ]; then
+ return 1;
+ fi
+@@ -90,7 +59,7 @@
+ else
+ echo `date` "[rescue_nic] activating $nic ..."
+
+- $ifup_path $nic
++ $ifup_path$nic restart
+ fi
+ done < $niclist
+
+@@ -120,7 +89,7 @@
+ # NetworkManager 0.6
+ $dbusSend --system --dest=org.freedesktop.NetworkManager \
+ /org/freedesktop/NetworkManager \
+- org.freedesktop.NetworkManager.wake
++ org.freedesktop.NetworkManager.Sleep boolean:false
+ # NetworkManager 0.7.0
+ $dbusSend --system --dest=org.freedesktop.NetworkManager \
+ /org/freedesktop/NetworkManager \
+@@ -139,15 +108,8 @@
+
+ wakeNetworkManager
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" restart
+- # Continue even if the networking init script wasn't successful.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++# Continue even if the networking init script wasn't successful.
++status=0
+
+ if [ $status -eq 0 ]; then
+ rescue_NIC
+diff -ur scripts.orig/linux/suspend-vm-default scripts/linux/suspend-vm-default
+--- scripts.orig/linux/suspend-vm-default 2009-10-26 14:08:44.000000000 -0400
++++ scripts/linux/suspend-vm-default 2009-10-25 16:27:09.000000000 -0400
+@@ -25,37 +25,6 @@
+ echo `date` ": Executing '$0'"
+ echo
+
+-find_networking_script() {
+- local script="error"
+- for dir in "/etc/init.d" "/sbin/init.d" "/etc" "/etc/rc.d" ; do
+- if [ -d "$dir/rc0.d" ] &&
+- [ -d "$dir/rc1.d" ] &&
+- [ -d "$dir/rc2.d" ] &&
+- [ -d "$dir/rc3.d" ] &&
+- [ -d "$dir/rc4.d" ] &&
+- [ -d "$dir/rc5.d" ] &&
+- [ -d "$dir/rc6.d" ]; then
+-
+- # Now find the appropriate networking script.
+- if [ -d "$dir/init.d" ]; then
+- if [ -x "$dir/init.d/network" ]; then
+- script="$dir/init.d/network"
+- elif [ -x "$dir/init.d/networking" ]; then
+- script="$dir/init.d/networking"
+- fi
+- else
+- if [ -x "$dir/network" ]; then
+- script="$dir/network"
+- elif [ -x "$dir/networking" ]; then
+- script="$dir/networking"
+- fi
+- fi
+- fi
+- done
+-
+- echo "$script"
+-}
+-
+ save_active_NIC_list() {
+ ifconfig_path=`which ifconfig 2>/dev/null`
+ if [ $? ]; then
+@@ -82,11 +51,6 @@
+ # `which' may be a bit noisy, so we'll shush it.
+ dbusSend=`which dbus-send 2>/dev/null`
+ if [ $? -eq 0 ]; then
+- # NetworkManager 0.6
+- $dbusSend --system --dest=org.freedesktop.NetworkManager \
+- /org/freedesktop/NetworkManager \
+- org.freedesktop.NetworkManager.sleep
+- # NetworkManager 0.7.0
+ $dbusSend --system --dest=org.freedesktop.NetworkManager \
+ /org/freedesktop/NetworkManager \
+ org.freedesktop.NetworkManager.Sleep boolean:true
+@@ -107,16 +71,13 @@
+
+ save_active_NIC_list
+
+-network=`find_networking_script`
+-if [ "$network" != "error" ]; then
+- "$network" stop
+- # If the network is down, this may fail but that's not a good reason
+- # to prevent the suspend.
+- status=0
+-else
+- echo "networking script not found"
+- status=1
+-fi
++for network in `ls /etc/init.d/net.*`;
++do
++ "$network" stop
++done
++# If the network is down, this may fail but that's not a good reason
++# to prevent the suspend.
++status=0
+
+ tranquilizeNetworkManager
+
diff --git a/app-emulation/open-vm-tools/files/wiper-warning-fix.patch b/app-emulation/open-vm-tools/files/wiper-warning-fix.patch
deleted file mode 100644
index 0c36733b53be..000000000000
--- a/app-emulation/open-vm-tools/files/wiper-warning-fix.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/lib/wiper/wiperPosix.c
-+++ b/lib/wiper/wiperPosix.c
-@@ -998,8 +998,9 @@
- break;
- }
- }
-- } else {
-- fgets(deviceName, sizeof deviceName, fp);
-+ } else if (fgets(deviceName, sizeof deviceName, fp) != deviceName) {
-+ Warning("%s: Error reading device name from /proc/devices.", __func__);
-+ break;
- }
- }
-
diff --git a/app-emulation/open-vm-tools/metadata.xml b/app-emulation/open-vm-tools/metadata.xml
index 54f82e796658..4a729406e06a 100644
--- a/app-emulation/open-vm-tools/metadata.xml
+++ b/app-emulation/open-vm-tools/metadata.xml
@@ -15,6 +15,7 @@
<flag name='doc'>Generate API documantation</flag>
<flag name='fuse'>Build vmblock-fuse in favor of FUSE based blocking
mechanism for DnD</flag>
+ <flag name="pic">Force shared libraries to be build as PIC</flag>
<flag name='unity'>Enable host unity support</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
deleted file mode 100644
index 1cc7b84315e1..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090522.167859.ebuild,v 1.3 2009/06/30 12:27:06 vadimk Exp $
-
-EAPI="2"
-
-inherit eutils linux-mod pam versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama icu unity"
-DEPEND="
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- dev-cpp/gtkmm
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- xinerama? (
- x11-libs/libXinerama
- )
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- sys-process/procps
- dev-libs/libdnet
- >=dev-libs/glib-2
- icu? ( dev-libs/icu )
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- "
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="pvscsi vmblock vmci vmhgfs vmsync vmmemctl vmxnet vmxnet3 vsock"
-
-pkg_setup() {
- use unity && ! use xinerama && \
- die 'The Unity USE flag requires USE="xinerama" as well'
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [ "${mod}" == "vmxnet" -o "${mod}" == "vmxnet3" ];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- enewgroup vmware
-}
-
-src_prepare() {
- epatch "${FILESDIR}/default-scripts.patch"
- epatch "${FILESDIR}/wiper-warning-fix.patch"
- sed -e 's:VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)\\":VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)/plugins\\":g' -i services/vmtoolsd/Makefile.in
-}
-
-src_configure() {
- econf \
- --without-kernel-modules \
- $(use_with icu) \
- $(use_with X x) \
- $(use_with X gtkmm) \
- $(use_enable unity) \
- $(use_enable xinerama multimon)
-}
-
-src_compile() {
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
- linux-mod_src_install
-
- emake DESTDIR="${D}" install || die "Failed to install"
-
- rm "${D}"/etc/pam.d/vmtoolsd
- pamd_mimic_system vmtoolsd auth account
-
- newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- insinto /etc/xdg/autostart
- doins "${FILESDIR}/open-vm-tools.desktop"
-
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild
deleted file mode 100644
index fbe61a77663c..000000000000
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20090618.172495.ebuild,v 1.1 2009/06/30 12:27:06 vadimk Exp $
-
-EAPI="2"
-
-inherit eutils linux-mod pam versionator
-
-MY_DATE="$(get_version_component_range 3)"
-MY_BUILD="$(get_version_component_range 4)"
-MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
-MY_P="${PN}-${MY_PV}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="X xinerama icu unity"
-DEPEND="
- !app-emulation/vmware-workstation-tools
- !app-emulation/vmware-server-tools
- !app-emulation/vmware-esx-tools
- virtual/linux-sources
- sys-apps/ethtool
- X? (
- x11-libs/libX11
- x11-libs/gtk+
- dev-cpp/gtkmm
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- xinerama? (
- x11-libs/libXinerama
- )
- sys-process/procps
- dev-libs/libdnet
- >=dev-libs/glib-2
- icu? ( dev-libs/icu )
- "
-
-RDEPEND="${DEPEND/virtual\/linux\-sources/}
- virtual/pam
- X? (
- x11-base/xorg-server
- x11-drivers/xf86-video-vmware
- x11-drivers/xf86-input-vmmouse
- )
- unity? (
- x11-libs/libXScrnSaver
- dev-libs/uriparser
- )
- "
-
-VMWARE_MOD_DIR="modules/linux"
-VMWARE_MODULE_LIST="pvscsi vmblock vmci vmhgfs vmsync vmmemctl vmxnet vmxnet3 vsock"
-
-pkg_setup() {
- use unity && ! use xinerama && \
- die 'The Unity USE flag requires USE="xinerama" as well'
-
- linux-mod_pkg_setup
- MODULE_NAMES=""
- BUILD_TARGETS="auto-build HEADER_DIR=${KERNEL_DIR}/include BUILD_DIR=${KV_OUT_DIR} OVT_SOURCE_DIR=${S}"
-
- for mod in ${VMWARE_MODULE_LIST};
- do
- if [ "${mod}" == "vmxnet" -o "${mod}" == "vmxnet3" ];
- then
- MODTARGET="net"
- else
- MODTARGET="openvmtools"
- fi
- MODULE_NAMES="${MODULE_NAMES} ${mod}(${MODTARGET}:${S}/${VMWARE_MOD_DIR}/${mod})"
- done
-
- enewgroup vmware
-}
-
-src_prepare() {
- epatch "${FILESDIR}/default-scripts.patch"
- sed -e 's:VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)\\":VMTOOLSD_PLUGIN_ROOT=\\"\$(pkglibdir)/plugins\\":g' -i services/vmtoolsd/Makefile.in
-}
-
-src_configure() {
- econf \
- --without-kernel-modules \
- $(use_with icu) \
- $(use_with X x) \
- $(use_with X gtkmm) \
- $(use_enable unity) \
- $(use_enable xinerama multimon)
-}
-
-src_compile() {
- linux-mod_src_compile
-
- emake || die
-}
-
-src_install() {
- linux-mod_src_install
-
- emake DESTDIR="${D}" install || die "Failed to install"
-
- rm "${D}"/etc/pam.d/vmtoolsd
- pamd_mimic_system vmtoolsd auth account
-
- newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools
- newconfd "${FILESDIR}/open-vm.confd" vmware-tools
-
- if use X;
- then
- insinto /etc/xdg/autostart
- doins "${FILESDIR}/open-vm-tools.desktop"
-
- elog "To be able to use the drag'n'drop feature of VMware for file"
- elog "exchange, you need to do this:"
- elog " Add 'vmware-tools' to your default runlevel"
- elog " Add the users which should have access to this function"
- elog " to the group 'vmware'"
- fi
-}
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20091015.201664.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20091015.201664.ebuild
new file mode 100644
index 000000000000..cc0501252cc2
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20091015.201664.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20091015.201664.ebuild,v 1.1 2009/10/29 14:14:51 vadimk Exp $
+
+EAPI="2"
+
+inherit eutils pam versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu +pic unity xinerama"
+
+RDEPEND="app-emulation/open-vm-tools-kmod
+ >=dev-libs/glib-2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ virtual/pam
+ X? (
+ dev-cpp/gtkmm
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+
+ x11-libs/libnotify
+ x11-libs/libX11
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu )
+ unity? (
+ dev-libs/uriparser
+ x11-libs/libXScrnSaver
+ )
+ xinerama? ( x11-libs/libXinerama )
+ "
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ virtual/linux-sources
+ doc? ( app-doc/doxygen )
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use unity && ! use xinerama && die 'The Unity USE flag requires USE="xinerama" as well'
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/default-scripts1.patch"
+ #epatch "${FILESDIR}/checkvm-pie-safety.patch"
+ sed -i -e 's/proc-3.2.7/proc/g' configure || die "sed configure failed"
+ sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+}
+
+src_configure() {
+ econf \
+ --with-procps \
+ --with-dnet \
+ --without-kernel-modules \
+ $(use_with X x) \
+ $(use_with X gtk2) \
+ $(use_with X gtkmm) \
+ $(use_with icu) \
+ $(use_with pic) \
+ $(use_enable unity) \
+ $(use_enable xinerama multimon)
+}
+
+src_compile() {
+ emake || die "failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools || die "failed to newinitd"
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools || die "failed to newconfd"
+
+ if use X;
+ then
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop" || die "failed to install .desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, you need to do this:"
+ elog " Add 'vmware-tools' to your default runlevel."
+ elog " Add the users which should have access to this function"
+ elog " to the group 'vmware'."
+ fi
+}