summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-23 16:45:20 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-08-23 16:45:20 +0000
commit19782736a053b2bf31f840ba8a25b83e00b254e2 (patch)
tree755818e6e160550286de365f0c36e23aa89ea09d /app-emulation
parentRemoving old ebuilds (diff)
downloadgentoo-2-19782736a053b2bf31f840ba8a25b83e00b254e2.tar.gz
gentoo-2-19782736a053b2bf31f840ba8a25b83e00b254e2.tar.bz2
gentoo-2-19782736a053b2bf31f840ba8a25b83e00b254e2.zip
Run tools/make_requests if a user patch modifies the server protocol definition (bug #432348, thanks to Oliver 'oGGy' Ney).
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/ChangeLog10
-rw-r--r--app-emulation/wine/wine-1.2.3.ebuild7
-rw-r--r--app-emulation/wine/wine-1.3.28.ebuild7
-rw-r--r--app-emulation/wine/wine-1.4.1.ebuild7
-rw-r--r--app-emulation/wine/wine-1.4.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.0.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.1.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.10.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.11.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.2.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.3.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.4.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.5.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.6.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.7.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.8.ebuild7
-rw-r--r--app-emulation/wine/wine-1.5.9.ebuild7
-rw-r--r--app-emulation/wine/wine-9999.ebuild7
18 files changed, 111 insertions, 18 deletions
diff --git a/app-emulation/wine/ChangeLog b/app-emulation/wine/ChangeLog
index fead059aea02..e7b8ab809467 100644
--- a/app-emulation/wine/ChangeLog
+++ b/app-emulation/wine/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emulation/wine
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.426 2012/08/19 02:24:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/ChangeLog,v 1.427 2012/08/23 16:45:20 tetromino Exp $
+
+ 23 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.2.3.ebuild,
+ wine-1.3.28.ebuild, wine-1.4.ebuild, wine-1.4.1.ebuild, wine-1.5.0.ebuild,
+ wine-1.5.1.ebuild, wine-1.5.2.ebuild, wine-1.5.3.ebuild, wine-1.5.4.ebuild,
+ wine-1.5.5.ebuild, wine-1.5.6.ebuild, wine-1.5.7.ebuild, wine-1.5.8.ebuild,
+ wine-1.5.9.ebuild, wine-1.5.10.ebuild, wine-1.5.11.ebuild, wine-9999.ebuild:
+ Run tools/make_requests if a user patch modifies the server protocol
+ definition (bug #432348, thanks to Oliver 'oGGy' Ney).
19 Aug 2012; Alexandre Rostovtsev <tetromino@gentoo.org> wine-1.5.10.ebuild,
-files/wine-1.5.10-osmesa-check.patch, wine-1.5.11.ebuild,
diff --git a/app-emulation/wine/wine-1.2.3.ebuild b/app-emulation/wine/wine-1.2.3.ebuild
index 8b749b33bf1c..a367dc6ac406 100644
--- a/app-emulation/wine/wine-1.2.3.ebuild
+++ b/app-emulation/wine/wine-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.2.3.ebuild,v 1.18 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.2.3.ebuild,v 1.19 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -112,6 +112,7 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
if use pulseaudio ; then
EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
eautoreconf
@@ -119,6 +120,10 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.2.3-msxml3-libxml2-headers.patch #397993
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-1.3.28.ebuild b/app-emulation/wine/wine-1.3.28.ebuild
index b3be47830d2e..6eb67f673c3e 100644
--- a/app-emulation/wine/wine-1.3.28.ebuild
+++ b/app-emulation/wine/wine-1.3.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.28.ebuild,v 1.10 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.3.28.ebuild,v 1.11 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -110,8 +110,13 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
}
diff --git a/app-emulation/wine/wine-1.4.1.ebuild b/app-emulation/wine/wine-1.4.1.ebuild
index cde5e39c6d33..9d0350ecd6ba 100644
--- a/app-emulation/wine/wine-1.4.1.ebuild
+++ b/app-emulation/wine/wine-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.4.1.ebuild,v 1.4 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.4.1.ebuild,v 1.5 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.4.ebuild b/app-emulation/wine/wine-1.4.ebuild
index b98e9f9fb1da..5b16526e3d32 100644
--- a/app-emulation/wine/wine-1.4.ebuild
+++ b/app-emulation/wine/wine-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.4.ebuild,v 1.8 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.4.ebuild,v 1.9 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.0.ebuild b/app-emulation/wine/wine-1.5.0.ebuild
index 648775d3373e..4e0e1119801d 100644
--- a/app-emulation/wine/wine-1.5.0.ebuild
+++ b/app-emulation/wine/wine-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.0.ebuild,v 1.6 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.0.ebuild,v 1.7 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.1.ebuild b/app-emulation/wine/wine-1.5.1.ebuild
index 03cc7848146f..f8e3d9188dc0 100644
--- a/app-emulation/wine/wine-1.5.1.ebuild
+++ b/app-emulation/wine/wine-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.1.ebuild,v 1.5 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.1.ebuild,v 1.6 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.10.ebuild b/app-emulation/wine/wine-1.5.10.ebuild
index 93567a5c5cdd..92994f6a6491 100644
--- a/app-emulation/wine/wine-1.5.10.ebuild
+++ b/app-emulation/wine/wine-1.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.3 2012/08/19 02:24:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.10.ebuild,v 1.4 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -129,11 +129,16 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.11.ebuild b/app-emulation/wine/wine-1.5.11.ebuild
index 42ff29dcb3cf..4e731aefda65 100644
--- a/app-emulation/wine/wine-1.5.11.ebuild
+++ b/app-emulation/wine/wine-1.5.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.11.ebuild,v 1.2 2012/08/19 02:24:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.11.ebuild,v 1.3 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -129,11 +129,16 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.2.ebuild b/app-emulation/wine/wine-1.5.2.ebuild
index d1a268724ff1..ea498c91b178 100644
--- a/app-emulation/wine/wine-1.5.2.ebuild
+++ b/app-emulation/wine/wine-1.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.2.ebuild,v 1.5 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.2.ebuild,v 1.6 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.3.ebuild b/app-emulation/wine/wine-1.5.3.ebuild
index a6aa459fe9f3..7edb394b8ce3 100644
--- a/app-emulation/wine/wine-1.5.3.ebuild
+++ b/app-emulation/wine/wine-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.3.ebuild,v 1.5 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.3.ebuild,v 1.6 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.4.ebuild b/app-emulation/wine/wine-1.5.4.ebuild
index 3cd30f62f2f9..e6e5092b990c 100644
--- a/app-emulation/wine/wine-1.5.4.ebuild
+++ b/app-emulation/wine/wine-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.4.ebuild,v 1.3 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.4.ebuild,v 1.4 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.5.ebuild b/app-emulation/wine/wine-1.5.5.ebuild
index 25dd113172ba..ffd6338dae51 100644
--- a/app-emulation/wine/wine-1.5.5.ebuild
+++ b/app-emulation/wine/wine-1.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.5.ebuild,v 1.3 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.5.ebuild,v 1.4 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -121,9 +121,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.6.ebuild b/app-emulation/wine/wine-1.5.6.ebuild
index 8a5573ab6161..3aed13f2a124 100644
--- a/app-emulation/wine/wine-1.5.6.ebuild
+++ b/app-emulation/wine/wine-1.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.6.ebuild,v 1.2 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.6.ebuild,v 1.3 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -124,9 +124,14 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.7.ebuild b/app-emulation/wine/wine-1.5.7.ebuild
index 6feec2a56e69..d2bd789c4493 100644
--- a/app-emulation/wine/wine-1.5.7.ebuild
+++ b/app-emulation/wine/wine-1.5.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.7.ebuild,v 1.2 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.7.ebuild,v 1.3 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -127,10 +127,15 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.8.ebuild b/app-emulation/wine/wine-1.5.8.ebuild
index d56ccca85026..0be54a8db464 100644
--- a/app-emulation/wine/wine-1.5.8.ebuild
+++ b/app-emulation/wine/wine-1.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.8.ebuild,v 1.2 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.8.ebuild,v 1.3 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -127,10 +127,15 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-1.5.9.ebuild b/app-emulation/wine/wine-1.5.9.ebuild
index 0ac7d438435c..2ce1c1902646 100644
--- a/app-emulation/wine/wine-1.5.9.ebuild
+++ b/app-emulation/wine/wine-1.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.9.ebuild,v 1.2 2012/08/12 21:53:11 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.5.9.ebuild,v 1.3 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -127,10 +127,15 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 07a6a82541d4..b216b400cb22 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.113 2012/08/19 02:24:09 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-9999.ebuild,v 1.114 2012/08/23 16:45:20 tetromino Exp $
EAPI="4"
@@ -129,11 +129,16 @@ src_unpack() {
}
src_prepare() {
+ local md5="$(md5sum server/protocol.def)"
epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
epatch "${FILESDIR}"/${PN}-1.4_rc2-multilib-portage.patch #395615
epatch "${FILESDIR}"/${PN}-1.5.11-osmesa-check.patch #429386
epatch "${DISTDIR}/${PULSE_PATCH}" #421365
epatch_user #282735
+ if [[ "$(md5sum server/protocol.def)" != "${md5}" ]]; then
+ einfo "server/protocol.def was patched; running tools/make_requests"
+ tools/make_requests || die #432348
+ fi
eautoreconf
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
sed -i '/^MimeType/d' tools/wine.desktop || die #117785