summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <msterret@gentoo.org>2003-08-28 05:09:22 +0000
committerMichael Sterrett <msterret@gentoo.org>2003-08-28 05:09:22 +0000
commit0a328c700fe71550af4b32868dd4aeec155e80d7 (patch)
tree56999757632d5c4d259f044c1e5d003dc4afcf2b /app-emulation
parentinitial commit. ebuild based on one provided by Jeff Saucier via bug 27447 (diff)
downloadgentoo-2-0a328c700fe71550af4b32868dd4aeec155e80d7.tar.gz
gentoo-2-0a328c700fe71550af4b32868dd4aeec155e80d7.tar.bz2
gentoo-2-0a328c700fe71550af4b32868dd4aeec155e80d7.zip
initial commit. ebuild based on one provided by Jeff Saucier via bug 27447
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gtuxnes/ChangeLog9
-rw-r--r--app-emulation/gtuxnes/Manifest3
-rw-r--r--app-emulation/gtuxnes/files/digest-gtuxnes-0.751
-rw-r--r--app-emulation/gtuxnes/gtuxnes-0.75.ebuild36
4 files changed, 48 insertions, 1 deletions
diff --git a/app-emulation/gtuxnes/ChangeLog b/app-emulation/gtuxnes/ChangeLog
new file mode 100644
index 000000000000..4525b44d125c
--- /dev/null
+++ b/app-emulation/gtuxnes/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/gtuxnes
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gtuxnes/ChangeLog,v 1.1 2003/08/28 05:09:18 msterret Exp $
+
+*gtuxnes-0.75 (27 Aug 2003)
+
+ 27 Aug 2003; Michael Sterrett <msterret@gentoo.org> gtuxnes-0.75.ebuild:
+ initial commit. ebuild based on one provided by Jeff Saucier via bug 27447
+
diff --git a/app-emulation/gtuxnes/Manifest b/app-emulation/gtuxnes/Manifest
index 15dad6954420..36e1beba9e3d 100644
--- a/app-emulation/gtuxnes/Manifest
+++ b/app-emulation/gtuxnes/Manifest
@@ -1,2 +1,3 @@
-MD5 c0fa2fcb07f279eb24f78c7f2606a9b0 gtuxnes-0.75.ebuild 725
+MD5 c2f2d3412c1b61ecfc58ba01f0682ad4 gtuxnes-0.75.ebuild 855
+MD5 3781d67a8879c20bbbab74c491b4e7c7 ChangeLog 409
MD5 27220fa938dbcd142954d021c0a9aec1 files/digest-gtuxnes-0.75 63
diff --git a/app-emulation/gtuxnes/files/digest-gtuxnes-0.75 b/app-emulation/gtuxnes/files/digest-gtuxnes-0.75
new file mode 100644
index 000000000000..f80269c1879c
--- /dev/null
+++ b/app-emulation/gtuxnes/files/digest-gtuxnes-0.75
@@ -0,0 +1 @@
+MD5 19355f3c08dfa3a8b56dbececf22bfea gtuxnes-0.75.tar.gz 16805
diff --git a/app-emulation/gtuxnes/gtuxnes-0.75.ebuild b/app-emulation/gtuxnes/gtuxnes-0.75.ebuild
new file mode 100644
index 000000000000..5c8e8d0a6ca1
--- /dev/null
+++ b/app-emulation/gtuxnes/gtuxnes-0.75.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gtuxnes/gtuxnes-0.75.ebuild,v 1.1 2003/08/28 05:09:18 msterret Exp $
+
+DESCRIPTION='GTK frontend for tuxnes, the emulator for the 8-bit Nintendo Entertainment System'
+HOMEPAGE='http://www.scottweber.com/projects/gtuxnes/'
+SRC_URI="http://www.scottweber.com/projects/gtuxnes/${P}.tar.gz"
+
+LICENSE='GPL-2'
+KEYWORDS='x86'
+SLOT='0'
+IUSE=''
+
+DEPEND='x11-libs/gtk+
+ >=sys-apps/sed-4'
+RDEPEND='>=app-emulation/tuxnes-0.75'
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e 's/gcc/$(CC) $(CFLAGS)/' Makefile || \
+ die 'sed Makefile failed'
+}
+
+src_compile() {
+ emake || die 'emake failed'
+}
+
+src_install() {
+ dobin gtuxnes
+
+ # Install documentation
+ dodoc AUTHORS CHANGES INSTALL README TODO
+}