summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-04 03:53:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-04 03:53:39 +0000
commit096b7cb25ffaf89fd0b3ffea8fdeaf4819fb38d3 (patch)
tree193b59b3c48ec076727a731a8553eb1a109ec851 /app-emulation
parentportage 1.8.12 with emerge clean support (diff)
downloadgentoo-2-096b7cb25ffaf89fd0b3ffea8fdeaf4819fb38d3.tar.gz
gentoo-2-096b7cb25ffaf89fd0b3ffea8fdeaf4819fb38d3.tar.bz2
gentoo-2-096b7cb25ffaf89fd0b3ffea8fdeaf4819fb38d3.zip
New package to help wine users
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/winesetuptk/ChangeLog9
-rw-r--r--app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b1
-rw-r--r--app-emulation/winesetuptk/winesetuptk-0.6.0b.ebuild65
3 files changed, 75 insertions, 0 deletions
diff --git a/app-emulation/winesetuptk/ChangeLog b/app-emulation/winesetuptk/ChangeLog
new file mode 100644
index 000000000000..8cb591965eec
--- /dev/null
+++ b/app-emulation/winesetuptk/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-emulation/winesetuptk
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/ChangeLog,v 1.1 2002/04/04 03:53:39 seemant Exp $
+
+*winesetuptk-0.6.0b (3 Apr 2002)
+
+ 3 Apr 2002; Seemant Kulleen <seemant@gentoo.org> winesetuptk-0.6.0b.ebuild :
+
+ New package to help users set up wine on their systems.
diff --git a/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b b/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b
new file mode 100644
index 000000000000..953260f48d9f
--- /dev/null
+++ b/app-emulation/winesetuptk/files/digest-winesetuptk-0.6.0b
@@ -0,0 +1 @@
+MD5 e5ce908158445ee7defd38e8fcd8a7b3 winesetuptk_0.6.0b-1.tar.gz 6810670
diff --git a/app-emulation/winesetuptk/winesetuptk-0.6.0b.ebuild b/app-emulation/winesetuptk/winesetuptk-0.6.0b.ebuild
new file mode 100644
index 000000000000..2e7631a7677d
--- /dev/null
+++ b/app-emulation/winesetuptk/winesetuptk-0.6.0b.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Seemant Kulleen <seemant@rocketmail.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winesetuptk/winesetuptk-0.6.0b.ebuild,v 1.1 2002/04/04 03:53:39 seemant Exp $
+
+MY_P=${PN}_${PV}-1.tar.gz
+PRE=tcltk-winesetuptk-0.6.0b
+SEC=winesetuptk-0.6.0b
+S=${WORKDIR}/${P}
+DESCRIPTION="Setup tool for WiNE adapted from Codeweavers by Debian"
+SRC_URI="http://ftp.debian.org/debian/pool/main/w/winesetuptk/${MY_P}"
+HOMEPAGE="http://packages.debian.org/unstable/otherosfs/winesetuptk.html"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ >=dev-lang/tcl-8.3.3
+ >=dev-lang/tk-8.3.3"
+
+RDEPEND="app-emulation/wine"
+
+src_unpack() {
+
+ unpack ${MY_P}
+ cd ${S}
+
+ tar zxf ${PRE}.tar.gz
+ tar zxf ${SEC}.tar.gz
+
+}
+
+src_compile() {
+
+ cd ${S}/${PRE}
+ ./build.sh
+
+
+ cd ${S}/${SEC}
+
+ local myconf
+
+ myconf="${myconf} --with-tcltk=${S}/${PRE}"
+ myconf="${myconf} --with-launcher=/usr/bin --with-exe=/usr/bin"
+ myconf="${myconf} --with-doc=/usr/share/doc/${P}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/wine \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ cd ${S}/${SEC}
+ make \
+ PREFIX_LAUNCHER=${D}/usr/bin \
+ PREFIX_EXE=${D}/usr/bin \
+ PREFIX_DOC=${D}/usr/share/doc/${P} \
+ install || die
+
+}