summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Klar <phoenix@gentoo.org>2002-09-13 14:51:07 +0000
committerTilman Klar <phoenix@gentoo.org>2002-09-13 14:51:07 +0000
commitdc161b44f09d2edd7f27d35e28cacd9610b01313 (patch)
treed19c3493c643d991151a39bee9137a94ba0f7b51 /app-emulation/winex
parentMasked new revisions of winex and wine for testing (diff)
downloadgentoo-2-dc161b44f09d2edd7f27d35e28cacd9610b01313.tar.gz
gentoo-2-dc161b44f09d2edd7f27d35e28cacd9610b01313.tar.bz2
gentoo-2-dc161b44f09d2edd7f27d35e28cacd9610b01313.zip
New manpage setup.
Diffstat (limited to 'app-emulation/winex')
-rw-r--r--app-emulation/winex/ChangeLog19
-rw-r--r--app-emulation/winex/files/digest-winex-20020807-r12
-rw-r--r--app-emulation/winex/winex-20020807-r1.ebuild118
-rw-r--r--app-emulation/winex/winex-20020807.ebuild4
4 files changed, 136 insertions, 7 deletions
diff --git a/app-emulation/winex/ChangeLog b/app-emulation/winex/ChangeLog
index 60409c379905..a19b66feb091 100644
--- a/app-emulation/winex/ChangeLog
+++ b/app-emulation/winex/ChangeLog
@@ -1,23 +1,32 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.11 2002/09/04 06:06:23 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.12 2002/09/13 14:49:38 phoenix Exp $
+
+*winex-20020807-r1 (13 Sep 2002)
+
+ 13 Sep 2002; phoen][x <phoenix@gentoo.org> winex-20020807-r1.ebuild :
+
+ Added manpage installation. This installs the manpage of wine as ${PN}.
*winex-20020807 (19 Aug 2002)
+ 07 Sep 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild :
+ Renamed the regedit wrapper to "/usr/bin/regedit-winex".
+
04 Sep 2002; Nick Hadaway <raker@gentoo.org> files/81winex,
files/winex-20020807-config :
Updated LDPATH, PATH, and ROOTPATH in 81winex and added a drive H
to the default config.
+ 06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild:
+ Bumped to new CVS Version (WineX 2.1). Lets hope that this
+ will fix some of the weird winex issues.
+
*winex-20020804 (04 Aug 2002)
19 August 2002; Sascha Schwabbauer <cybersystem@gentoo.org> ChangeLog, winex-20020804.ebuild :
Added -ppc to the keywords.
- 06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020807.ebuild:
- Bumped to new CVS Version (WineX 2.1). Lets hope that this
- will fix some of the weird winex issues.
-
06 Aug 2002; phoen][x <phoenix@gentoo.org> winex-20020804.ebuild:
Fixed a typo (unset CFLAGS=""); patched tools/wineshelllink to use "winex"
instead of "wine" - Installation programs are now able to create working
diff --git a/app-emulation/winex/files/digest-winex-20020807-r1 b/app-emulation/winex/files/digest-winex-20020807-r1
new file mode 100644
index 000000000000..0d669dc87caf
--- /dev/null
+++ b/app-emulation/winex/files/digest-winex-20020807-r1
@@ -0,0 +1,2 @@
+MD5 19bb11e4b925b07cd21637d9493142f3 winex-20020807.tar.bz2 5865715
+MD5 af8da46a0e51578ff1e18e399141d628 winex-20020807-fake_windows.tar.bz2 500
diff --git a/app-emulation/winex/winex-20020807-r1.ebuild b/app-emulation/winex/winex-20020807-r1.ebuild
new file mode 100644
index 000000000000..aeed61a20a11
--- /dev/null
+++ b/app-emulation/winex/winex-20020807-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807-r1.ebuild,v 1.1 2002/09/13 14:49:38 phoenix Exp $
+
+S=${WORKDIR}/wine
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ mirror://gentoo/${P}-fake_windows.tar.bz2"
+HOMEPAGE="http://www.transgaming.com/"
+
+SLOT="0"
+KEYWORDS="x86 -ppc"
+LICENSE="Aladdin"
+
+DEPEND="virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ # Azarah's patches
+ #patch -p0 < ${FILESDIR}/${P}-opengl.patch || die "opengl-patch failed"
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+
+ # the folks at #winehq were really angry about custom optimization
+ unset CFLAGS
+ unset CXXFLAGS
+
+ ./configure --prefix=/usr/lib/winex \
+ --sysconfdir=/etc/winex \
+ --host=${CHOST} \
+ --enable-curses \
+ --with-x \
+ ${myconf} || die "configure failed"
+
+ # Fixes a winetest issue
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ # This persuades wineshelllink that "winex" is a better loader :)
+ cd ${S}/tools
+ cp wineshelllink 1
+ sed -e 's/\(WINE_LOADER=\)\(\${WINE_LOADER:-wine}\)/\1winex/' 1 > wineshelllink
+
+ cd ${S}
+ make depend all || die "make depend all failed"
+ cd programs && emake || die "emake died"
+}
+
+src_install () {
+
+ local WINEXMAKEOPTS="prefix=${D}/usr/lib/${PN}"
+
+ # Installs winex to ${D}/usr/lib/${PN}
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die "make install failed"
+
+ # Creates /usr/lib/${PN}/.data with fake_windows in it
+ # This is needed for ~/.${PN} initialization by our
+ # winex wrapper script
+ mkdir ${D}/usr/lib/${PN}/.data
+ cp -R ${WORKDIR}/fake_windows ${D}/usr/lib/${PN}/.data
+ cp ${FILESDIR}/${P}-config ${D}/usr/lib/${PN}/.data/config
+
+ # winedefault.reg -- standard registry setup
+ cp ${WORKDIR}/wine/winedefault.reg ${D}/usr/lib/${PN}/.data/winedefault.reg
+
+ # Install the wrapper script
+ mkdir ${D}/usr/bin
+ cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
+
+ # Take care of the other stuff
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /usr/lib/winex/.data/fake_windows/Windows
+ doins documentation/samples/system.ini
+ doins documentation/samples/generic.ppd
+
+ # Manpage setup
+ cp ${D}/usr/lib/${PN}/man/man1/wine.1 ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ doman ${D}/usr/lib/${PN}/man/man1/${PN}.1
+ rm ${D}/usr/lib/${PN}/man/man1/${PN}.1
+
+ # Remove the executable flag from those libraries.
+ cd ${D}/usr/lib/${PN}/bin
+ chmod a-x *.so
+
+}
+
+pkg_postinst() {
+ einfo "**********************************************************************"
+ einfo "* NOTE: Use /usr/bin/winex to start winex. *"
+ einfo "* This is a wrapper-script which will take care of everything *"
+ einfo "* else. If you have further questions, enhancements or patches *"
+ einfo "* send an email to phoenix@gentoo.org *"
+ einfo "* *"
+ einfo "* Manpage has been installed to the system. *"
+ einfo "* \"man winex\" should show it. *"
+ einfo "**********************************************************************"
+}
+
diff --git a/app-emulation/winex/winex-20020807.ebuild b/app-emulation/winex/winex-20020807.ebuild
index 1b48458067c4..3369248ff783 100644
--- a/app-emulation/winex/winex-20020807.ebuild
+++ b/app-emulation/winex/winex-20020807.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.2 2002/08/19 17:50:20 cybersystem Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020807.ebuild,v 1.3 2002/09/13 14:49:38 phoenix Exp $
S=${WORKDIR}/wine
DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
@@ -83,7 +83,7 @@ src_install () {
# Install the wrapper script
mkdir ${D}/usr/bin
cp ${FILESDIR}/${P}-winex ${D}/usr/bin/winex
- cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit
+ cp ${FILESDIR}/${P}-regedit ${D}/usr/bin/regedit-winex
# Take care of the other stuff
cd ${S}