summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alberto Suarez Lopez <bass@gentoo.org>2002-06-29 22:30:13 +0000
committerJose Alberto Suarez Lopez <bass@gentoo.org>2002-06-29 22:30:13 +0000
commit4b40610e44e64b52777fb117f7e57db65f71ff24 (patch)
tree128fae17f7005f3e0ec641fb9f6e62eddbf0d75d /app-emulation/winex
parentupdate ChangeLog (diff)
downloadgentoo-2-4b40610e44e64b52777fb117f7e57db65f71ff24.tar.gz
gentoo-2-4b40610e44e64b52777fb117f7e57db65f71ff24.tar.bz2
gentoo-2-4b40610e44e64b52777fb117f7e57db65f71ff24.zip
new version
Diffstat (limited to 'app-emulation/winex')
-rw-r--r--app-emulation/winex/ChangeLog8
-rw-r--r--app-emulation/winex/files/digest-winex-200207281
-rw-r--r--app-emulation/winex/winex-20020728.ebuild103
3 files changed, 111 insertions, 1 deletions
diff --git a/app-emulation/winex/ChangeLog b/app-emulation/winex/ChangeLog
index d09a35925057..3b12aa8ab20c 100644
--- a/app-emulation/winex/ChangeLog
+++ b/app-emulation/winex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/wine
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.1 2002/05/11 08:33:24 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/ChangeLog,v 1.2 2002/06/29 22:30:13 bass Exp $
+
+*winex-20020728 (28 Jun 2002)
+
+ 28 Jun 2002; J.Alberto Suárez L. <bass@gentoo.org> winex-20020728.ebuild
+
+ New CVS version
*winex-20020511 (11 May 2002)
diff --git a/app-emulation/winex/files/digest-winex-20020728 b/app-emulation/winex/files/digest-winex-20020728
new file mode 100644
index 000000000000..9e4f255875bd
--- /dev/null
+++ b/app-emulation/winex/files/digest-winex-20020728
@@ -0,0 +1 @@
+MD5 c694558d6ae526b5f53ce541952e96bf winex-20020728.tar.bz2 5993418
diff --git a/app-emulation/winex/winex-20020728.ebuild b/app-emulation/winex/winex-20020728.ebuild
new file mode 100644
index 000000000000..bf1d8656ae16
--- /dev/null
+++ b/app-emulation/winex/winex-20020728.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/winex/winex-20020728.ebuild,v 1.1 2002/06/29 22:30:13 bass Exp $
+
+S=${WORKDIR}/wine
+DESCRIPTION="WineX is a distribution of Wine with enhanced DirectX for gaming"
+SRC_URI="ftp:/www.ibiblio.org/gentoo/distfiles/${P}.tar.bz2"
+HOMEPAGE="http://www.transgaming.com/"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ sys-devel/gcc
+ sys-devel/flex
+ dev-util/yacc
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ dev-lang/tcl dev-lang/tk"
+
+src_compile() {
+
+ cd ${S}
+ local myconf
+
+ use opengl && myconf="--enable-opengl" || myconf="--disable-opengl"
+ [ -z $DEBUG ] && myconf="$myconf --disable-trace --disable-debug" || myconf="$myconf --enable-trace --enable-debug"
+ # there's no configure flag for cups, it's supposed to be autodetected
+
+ # the folks at #winehq were really angry about custom optimization
+ export CFLAGS=""
+ export CXXFLAGS=""
+
+ ./configure --prefix=/usr \
+ --exec_prefix=/usr/winex \
+ --sysconfdir=/etc/winex \
+ --mandir=/usr/winex/man \
+ --host=${CHOST} \
+ --enable-curses \
+ ${myconf} || die
+
+ cd ${S}/programs/winetest
+ cp Makefile 1
+ sed -e 's:wine.pm:include/wine.pm:' 1 > Makefile
+
+ cd ${S}
+ make depend all || die
+ cd programs && emake || die
+
+}
+
+src_install () {
+
+ local WINEXMAKEOPTS="prefix=${D}/usr \
+ mandir=${D}/usr/winex/man \
+ includedir=${D}/usr/winex/include \
+ exec_prefix=${D}/usr/winex"
+
+ cd ${S}
+ make ${WINEXMAKEOPTS} install || die
+ cd ${S}/programs
+ make ${WINEXMAKEOPTS} install || die
+
+ # these .so's are strange. they are from the make in programs/ above,
+ # and are for apps built with winelib (windows sources built directly
+ # against wine). Apparently the sources go into a <program name>.so file
+ # and you run it via a symlink <program name> -> wine. Unfortunately both
+ # the symlink and the .so apparently must reside in /usr/bin.
+ cd ${D}/usr/winex/bin
+ chmod a-x *.so
+
+ # bash script For users with both wine and winex
+ # TODO: find out why this doesn't work
+ DESTTREE=/usr/winex dobin ${FILESDIR}/winex
+
+ cd ${S}
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog DEVELOPERS-HINTS LICENSE README
+
+ insinto /etc/winex
+ doins documentation/samples/*
+ doins ${S}/winedefault.reg
+
+ dodir /etc/skel/.winex
+ dosym /etc/winex/config /etc/skel/.winex/config
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/81winex
+}
+
+pkg_postinst() {
+
+ einfo "If you are installing winex for the first time,
+copy /etc/winex/config (global configuration) to ~/.wine/config
+and edit that for per-user configuration. Otherwise, winex will
+not run.
+Also, run \"/usr/winex/bin/regapi setValue < /etc/winex/winedefault.reg\"
+to setup
+per-user registry for using winex. More info in
+/usr/share/doc/winex-${PV}."
+
+}
+