summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2014-10-19 16:19:15 +0000
committerIan Whyman <thev00d00@gentoo.org>2014-10-19 16:19:15 +0000
commit4b41c6098c37a1cc99afe30c84f9bb1a37a72d04 (patch)
tree5b61ecf149ec9234392d87fdb35cbb07faedde55 /app-emulation/virt-manager
parentBeta channel bump. (diff)
downloadgentoo-2-4b41c6098c37a1cc99afe30c84f9bb1a37a72d04.tar.gz
gentoo-2-4b41c6098c37a1cc99afe30c84f9bb1a37a72d04.tar.bz2
gentoo-2-4b41c6098c37a1cc99afe30c84f9bb1a37a72d04.zip
Version bump, fixes #522628
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-emulation/virt-manager')
-rw-r--r--app-emulation/virt-manager/ChangeLog7
-rw-r--r--app-emulation/virt-manager/virt-manager-1.1.0.ebuild87
2 files changed, 93 insertions, 1 deletions
diff --git a/app-emulation/virt-manager/ChangeLog b/app-emulation/virt-manager/ChangeLog
index 535c8c924134..4448d6e9e355 100644
--- a/app-emulation/virt-manager/ChangeLog
+++ b/app-emulation/virt-manager/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/virt-manager
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.107 2014/08/27 07:57:29 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/ChangeLog,v 1.108 2014/10/19 16:19:15 thev00d00 Exp $
+
+*virt-manager-1.1.0 (19 Oct 2014)
+
+ 19 Oct 2014; Ian Whyman <thev00d00@gentoo.org> +virt-manager-1.1.0.ebuild:
+ Version bump, fixes #522628
27 Aug 2014; Sergey Popov <pinkbyte@gentoo.org>
virt-manager-0.10.0-r2.ebuild:
diff --git a/app-emulation/virt-manager/virt-manager-1.1.0.ebuild b/app-emulation/virt-manager/virt-manager-1.1.0.ebuild
new file mode 100644
index 000000000000..f348b730684c
--- /dev/null
+++ b/app-emulation/virt-manager/virt-manager-1.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virt-manager/virt-manager-1.1.0.ebuild,v 1.1 2014/10/19 16:19:15 thev00d00 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="A graphical tool for administering virtual machines"
+HOMEPAGE="http://virt-manager.org"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.fedorahosted.org/virt-manager.git"
+else
+ SRC_URI="http://virt-manager.org/download/sources/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="gnome-keyring gtk policykit sasl"
+
+RDEPEND="!app-emulation/virtinst
+ || (
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ >=app-emulation/libvirt-0.7.0[python(-),${PYTHON_USEDEP}]
+ )
+ >=app-emulation/libvirt-glib-0.0.9[introspection,python,${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ dev-libs/libxml2[python,${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/urlgrabber[${PYTHON_USEDEP}]
+ sys-libs/libosinfo[introspection]
+ gtk? (
+ x11-libs/gtk+:3[introspection]
+ gnome-base/dconf
+ >=net-libs/gtk-vnc-0.3.8[gtk3,introspection]
+ net-misc/spice-gtk[gtk3,introspection,python,sasl?,${PYTHON_USEDEP}]
+ x11-libs/vte:2.90[introspection]
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ policykit? ( sys-auth/polkit[introspection] )
+ x11-themes/gnome-icon-theme
+ )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool"
+
+DOCS=( README NEWS )
+
+distutils-r1_python_compile() {
+ local defgraphics=
+
+ esetup.py configure \
+ --qemu-user=qemu \
+ --default-graphics=spice
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ python_fix_shebang \
+ "${ED}"/usr/share/virt-manager/virt-{clone,convert,image,install,manager}
+}
+
+pkg_preinst() {
+ if use gtk; then
+ gnome2_pkg_preinst
+
+ cd "${ED}"
+ export GNOME2_ECLASS_ICONS=$(find 'usr/share/virt-manager/icons' -maxdepth 1 -mindepth 1 -type d 2> /dev/null)
+ else
+ rm -rf "${ED}/usr/share/virt-manager/virtManager"
+ rm -f "${ED}/usr/share/virt-manager/virt-manager"
+ rm -rf "${ED}/usr/share/virt-manager/ui/"
+ rm -rf "${ED}/usr/share/virt-manager/icons/"
+ rm -rf "${ED}/usr/share/man/man1/virt-manager.1*"
+ rm -rf "${ED}/usr/share/icons/"
+ rm -rf "${ED}/usr/share/applications/virt-manager.desktop"
+ rm -rf "${ED}/usr/bin/virt-manager"
+ fi
+}