summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-11-12 07:59:49 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-11-12 07:59:49 +0000
commitc8fb704a60ffb83a7dd46a7604b244524506fd29 (patch)
tree70e850fa5e494da48351c82c6c84fba4090a3145 /app-emulation/vice
parentFix collision issues. Per bug #276966 and #282565. (diff)
downloadgentoo-2-c8fb704a60ffb83a7dd46a7604b244524506fd29.tar.gz
gentoo-2-c8fb704a60ffb83a7dd46a7604b244524506fd29.tar.bz2
gentoo-2-c8fb704a60ffb83a7dd46a7604b244524506fd29.zip
Fix X_ShmAttach not declared. Bug #292508
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog6
-rw-r--r--app-emulation/vice/files/vice-2.1-xshm.patch16
-rw-r--r--app-emulation/vice/vice-2.1.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index afc84431eb5c..ca9e7f6e9f59 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.64 2009/11/02 09:54:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.65 2009/11/12 07:59:49 tupone Exp $
+
+ 12 Nov 2009; Alfredo Tupone <tupone@gentoo.org> vice-2.1.ebuild,
+ +files/vice-2.1-xshm.patch:
+ Fix X_ShmAttach not declared. Bug #292508 by Cedric Godin
02 Nov 2009; Samuli Suominen <ssuominen@gentoo.org> vice-1.22.ebuild,
vice-2.1.ebuild:
diff --git a/app-emulation/vice/files/vice-2.1-xshm.patch b/app-emulation/vice/files/vice-2.1-xshm.patch
new file mode 100644
index 000000000000..1546da7b4818
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.1-xshm.patch
@@ -0,0 +1,16 @@
+--- src/arch/unix/x11/xaw/videoarch.h.old 2009-11-12 08:50:17.000000000 +0100
++++ src/arch/unix/x11/xaw/videoarch.h 2009-11-12 08:52:20.000000000 +0100
+@@ -44,6 +44,13 @@
+ #include <X11/extensions/XShm.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
++# ifndef X_ShmAttach
++# ifdef BYTE
++# undef BYTE
++# endif
++# include <X11/Xmd.h>
++# include <X11/extensions/shmproto.h>
++# endif
+ #endif
+
+ #include "types.h"
diff --git a/app-emulation/vice/vice-2.1.ebuild b/app-emulation/vice/vice-2.1.ebuild
index 7f0c79edecdf..92c40eef9107 100644
--- a/app-emulation/vice/vice-2.1.ebuild
+++ b/app-emulation/vice/vice-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.1.ebuild,v 1.4 2009/11/02 09:54:41 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.1.ebuild,v 1.5 2009/11/12 07:59:49 tupone Exp $
EAPI=2
inherit eutils games
@@ -53,7 +53,8 @@ DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-xshm.patch
}
src_configure() {