summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 19:30:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-11 19:30:01 +0000
commit0bc82ffd379ca988932c2a69848315fb73e63c45 (patch)
tree97d3225bda576c78194ccb82223295fbd0a2c41d /app-emulation/vice
parentVersion bump (diff)
downloadgentoo-2-0bc82ffd379ca988932c2a69848315fb73e63c45.tar.gz
gentoo-2-0bc82ffd379ca988932c2a69848315fb73e63c45.tar.bz2
gentoo-2-0bc82ffd379ca988932c2a69848315fb73e63c45.zip
version bump - bug #234043 with patches and ebuild submitted by Karl Aloritias
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog9
-rw-r--r--app-emulation/vice/files/vice-2.0-gnome-palemu.patch13
-rw-r--r--app-emulation/vice/files/vice-2.0-gtk-bigendian-fix.patch57
-rw-r--r--app-emulation/vice/metadata.xml4
-rw-r--r--app-emulation/vice/vice-2.0.ebuild94
5 files changed, 174 insertions, 3 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index adc8929cf73d..bd1efeb42af3 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.59 2008/07/28 20:39:39 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.60 2008/08/11 19:30:00 mr_bones_ Exp $
+
+*vice-2.0 (11 Aug 2008)
+
+ 11 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/vice-2.0-gnome-palemu.patch,
+ +files/vice-2.0-gtk-bigendian-fix.patch, +vice-2.0.ebuild:
+ version bump - bug #234043 with patches and ebuild submitted by Karl Aloritias
28 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-emulation/vice/files/vice-2.0-gnome-palemu.patch b/app-emulation/vice/files/vice-2.0-gnome-palemu.patch
new file mode 100644
index 000000000000..1f8a4a9ceb28
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.0-gnome-palemu.patch
@@ -0,0 +1,13 @@
+Index: src/video/video-resources-pal.c
+===================================================================
+--- src/video/video-resources-pal.c (revision 19048)
++++ src/video/video-resources-pal.c (working copy)
+@@ -180,7 +180,7 @@
+ &video_resources.pal_scanlineshade, set_pal_scanlineshade, NULL },
+ { "PALBlur", 500, RES_EVENT_NO, NULL,
+ &video_resources.pal_blur, set_pal_blur, NULL },
+- { "PALMode", VIDEO_RESOURCE_PAL_MODE_TRUE, RES_EVENT_NO, NULL,
++ { "PALMode", VIDEO_RESOURCE_PAL_MODE_FAST, RES_EVENT_NO, NULL,
+ &video_resources.pal_mode, set_pal_mode, NULL },
+ { "PALOddLinePhase", 1250, RES_EVENT_NO, NULL,
+ &video_resources.pal_oddlines_phase, set_pal_oddlinesphase, NULL },
diff --git a/app-emulation/vice/files/vice-2.0-gtk-bigendian-fix.patch b/app-emulation/vice/files/vice-2.0-gtk-bigendian-fix.patch
new file mode 100644
index 000000000000..e83b92439dbe
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.0-gtk-bigendian-fix.patch
@@ -0,0 +1,57 @@
+Index: src/arch/unix/x11/gnome/uicolor.c
+===================================================================
+--- src/arch/unix/x11/gnome/uicolor.c (revision 19058)
++++ src/arch/unix/x11/gnome/uicolor.c (working copy)
+@@ -101,14 +101,12 @@
+
+ for (i = 0; i < palette->num_entries; i++) {
+ palette_entry_t color = palette->entries[i];
+- DWORD color_pixel;
+-
+- unsigned char *col = (unsigned char *)&color_pixel;
+- col[0] = color.red ;
+- col[1] = color.green;
+- col[2] = color.blue ;
+- video_render_setphysicalcolor(((video_canvas_t*)c)->videoconfig, i,
+- color_pixel, 24);
++ DWORD color_pixel =
++ (DWORD)color.red |
++ (DWORD)color.green << 8 |
++ (DWORD)color.blue << 16;
++ video_render_setphysicalcolor(((video_canvas_t*)c)->videoconfig, i,
++ color_pixel, 24);
+ }
+ return 0;
+ }
+@@ -116,27 +114,11 @@
+ static void uicolor_init_video_colors()
+ {
+ short i;
+- DWORD pixelr, pixelg, pixelb;
+
+- for (i = 0; i < 256; i++)
+- {
+- unsigned char* pixelrbyte = (unsigned char*)&pixelr;
+- unsigned char* pixelgbyte = (unsigned char*)&pixelg;
+- unsigned char* pixelbbyte = (unsigned char*)&pixelb;
+- pixelrbyte[0] = i;
+- pixelrbyte[1] = 0;
+- pixelrbyte[2] = 0;
+- pixelgbyte[0] = 0;
+- pixelgbyte[1] = i;
+- pixelgbyte[2] = 0;
+- pixelbbyte[0] = 0;
+- pixelbbyte[1] = 0;
+- pixelbbyte[2] = i;
+-
+- video_render_setrawrgb(i,
+- pixelr,
+- pixelg,
+- pixelb);
++ for (i = 0; i < 256; i++) {
++ video_render_setrawrgb(i,
++ (DWORD)i, (DWORD)i << 8, (DWORD)i << 16
++ );
+ }
+
+ video_render_initraw();
diff --git a/app-emulation/vice/metadata.xml b/app-emulation/vice/metadata.xml
index a7086570f9a6..3ae153091e68 100644
--- a/app-emulation/vice/metadata.xml
+++ b/app-emulation/vice/metadata.xml
@@ -3,7 +3,7 @@
<pkgmetadata>
<herd>games</herd>
<use>
- <flag name='resid'>Enable support for ReSID
- <pkg>media-libs/resid</pkg></flag>
+ <flag name='resid'>Enable support for ReSID <pkg>media-libs/resid</pkg></flag>
+ <flag name='xrandr'>Enable support for the X xrandr extension</flag>
</use>
</pkgmetadata>
diff --git a/app-emulation/vice/vice-2.0.ebuild b/app-emulation/vice/vice-2.0.ebuild
new file mode 100644
index 000000000000..e40b79ee8d63
--- /dev/null
+++ b/app-emulation/vice/vice-2.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.0.ebuild,v 1.1 2008/08/11 19:30:00 mr_bones_ Exp $
+
+EAPI=1
+inherit eutils games
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://www.viceteam.org/"
+SRC_URI="http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="Xaw3d alsa arts esd gnome nls png readline resid sdl ffmpeg ipv6 mmap oss zlib X gif jpeg xv dga xrandr"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ x11-libs/libXxf86vm
+ x11-apps/xset
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( !gnome? ( x11-libs/libXaw ) )
+ alsa? ( media-libs/alsa-lib )
+ arts? ( kde-base/arts )
+ esd? ( media-sound/esound )
+ gnome? (
+ x11-libs/gtk+:2
+ dev-libs/atk
+ x11-libs/pango
+ )
+ nls? ( virtual/libintl )
+ png? ( media-libs/libpng )
+ readline? ( sys-libs/readline )
+ resid? ( media-libs/resid )
+ sdl? ( media-libs/libsdl )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ xv? ( x11-libs/libXv )
+ dga? ( x11-libs/libXxf86dga )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ x11-apps/bdftopcf
+ x11-apps/mkfontdir
+ x11-proto/xproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xextproto
+ dga? ( x11-proto/xf86dgaproto )
+ xv? ( x11-proto/videoproto )
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-gnome-palemu.patch \
+ "${FILESDIR}"/${P}-gtk-bigendian-fix.patch
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-fullscreen \
+ --enable-parsid \
+ --without-midas \
+ $(use_enable gnome gnomeui) \
+ $(use_enable nls) \
+ $(use_with Xaw3d xaw3d) \
+ $(use_with alsa) \
+ $(use_with arts) \
+ $(use_with esd) \
+ $(use_with png) \
+ $(use_with readline) \
+ $(use_with resid) \
+ $(use_with sdl) \
+ $(use_enable ffmpeg) \
+ $(use_enable ipv6) \
+ $(use_enable oss) \
+ $(use_enable mmap memmap) \
+ $(use_with zlib) \
+ $(use_with X x) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog FEEDBACK README
+ prepgamesdirs
+}