summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2007-02-17 07:44:59 +0000
committerHarald van Dijk <truedfx@gentoo.org>2007-02-17 07:44:59 +0000
commit94dad315decbaa2800bd69e839a12eb4d4669147 (patch)
tree778b30e7a2542a1d21dc51c34ac52414a13f4c17 /app-emulation/simh
parentredigest control-center for bug #167282 (diff)
downloadgentoo-2-94dad315decbaa2800bd69e839a12eb4d4669147.tar.gz
gentoo-2-94dad315decbaa2800bd69e839a12eb4d4669147.tar.bz2
gentoo-2-94dad315decbaa2800bd69e839a12eb4d4669147.zip
Version bump (#139631)
(Portage version: 2.1.2-r9)
Diffstat (limited to 'app-emulation/simh')
-rw-r--r--app-emulation/simh/ChangeLog7
-rw-r--r--app-emulation/simh/files/digest-simh-3.3.02
-rw-r--r--app-emulation/simh/files/digest-simh-3.5.22
-rw-r--r--app-emulation/simh/files/digest-simh-3.7.03
-rw-r--r--app-emulation/simh/simh-3.7.0.ebuild50
5 files changed, 63 insertions, 1 deletions
diff --git a/app-emulation/simh/ChangeLog b/app-emulation/simh/ChangeLog
index f6f8d7a745e2..9d0ce7755867 100644
--- a/app-emulation/simh/ChangeLog
+++ b/app-emulation/simh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/simh
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.6 2007/01/05 23:54:47 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/ChangeLog,v 1.7 2007/02/17 07:44:59 truedfx Exp $
+
+*simh-3.7.0 (17 Feb 2007)
+
+ 17 Feb 2007; Harald van Dijk <truedfx@gentoo.org> +simh-3.7.0.ebuild:
+ Version bump (#139631)
05 Jan 2007; Danny van Dyk <kugelfang@gentoo.org> -simh-3.5.0.ebuild:
QA: Removed unused versions.
diff --git a/app-emulation/simh/files/digest-simh-3.3.0 b/app-emulation/simh/files/digest-simh-3.3.0
index d378ff063629..49d94deb3378 100644
--- a/app-emulation/simh/files/digest-simh-3.3.0
+++ b/app-emulation/simh/files/digest-simh-3.3.0
@@ -1 +1,3 @@
MD5 a8262f17ddd24e63bfdf04e3e9fc442b simhv33-0.zip 2153444
+RMD160 778cc7836b4558b57f1b9ca54427f3d2e8da94a4 simhv33-0.zip 2153444
+SHA256 28fcdc8443f6e2460193eb6ed8d41be95d75226490926219a0dfd5028eaf051c simhv33-0.zip 2153444
diff --git a/app-emulation/simh/files/digest-simh-3.5.2 b/app-emulation/simh/files/digest-simh-3.5.2
index 4d950393a9dd..1797c02c1313 100644
--- a/app-emulation/simh/files/digest-simh-3.5.2
+++ b/app-emulation/simh/files/digest-simh-3.5.2
@@ -1 +1,3 @@
MD5 e3d2a168f2da62e10e0013f1f9111d82 simhv35-2.zip 2259795
+RMD160 27d3a95689aed7f0781137dbf158ba87716d04b3 simhv35-2.zip 2259795
+SHA256 12c6e6290b599b7f131027a533ee12add8d68735128805e012309db46f2ab9fb simhv35-2.zip 2259795
diff --git a/app-emulation/simh/files/digest-simh-3.7.0 b/app-emulation/simh/files/digest-simh-3.7.0
new file mode 100644
index 000000000000..a5ab2deeffb7
--- /dev/null
+++ b/app-emulation/simh/files/digest-simh-3.7.0
@@ -0,0 +1,3 @@
+MD5 5f5f037f8c710862bc7223d5be010c40 simhv37-0.zip 2362666
+RMD160 7ecd3177d17c871a4b33fae13111fa0a19678511 simhv37-0.zip 2362666
+SHA256 23ae538b7607d231d9e64c170b7a4cc7b7c9d0c1c8bbd662c565ac0a56d15069 simhv37-0.zip 2362666
diff --git a/app-emulation/simh/simh-3.7.0.ebuild b/app-emulation/simh/simh-3.7.0.ebuild
new file mode 100644
index 000000000000..a6a0c3212c67
--- /dev/null
+++ b/app-emulation/simh/simh-3.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/simh/simh-3.7.0.ebuild,v 1.1 2007/02/17 07:44:59 truedfx Exp $
+
+inherit eutils versionator
+
+MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
+DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
+HOMEPAGE="http://simh.trailing-edge.com/"
+SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-macos ~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
+
+
+src_unpack() {
+ mkdir "${WORKDIR}/BIN"
+ unpack ${A}
+
+ # convert makefile from dos format to unix format
+ sed -i 's/.$//' makefile
+
+ epatch "${FILESDIR}/makefile.patch"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ cd "${S}/BIN"
+ for BINFILE in *; do
+ newbin ${BINFILE} "simh-${BINFILE}"
+ done
+
+ cd ${S}
+ dodir /usr/share/simh
+ insinto /usr/share/simh
+ doins VAX/*.bin
+ dodoc *.txt */*.txt
+}