summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-21 08:21:22 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-21 08:21:22 +0000
commit8a9c44cf89e219882d86ee84ee026ba4d7be49f5 (patch)
tree42ca69befd5f661964fc4ad26e7be26c7046b37d /app-emulation/rex-client
parentuse dobin instead of exeinto /usr/bin/ && doexe (diff)
downloadgentoo-2-8a9c44cf89e219882d86ee84ee026ba4d7be49f5.tar.gz
gentoo-2-8a9c44cf89e219882d86ee84ee026ba4d7be49f5.tar.bz2
gentoo-2-8a9c44cf89e219882d86ee84ee026ba4d7be49f5.zip
use dobin instead of exeinto /usr/bin/ && doexe; make ebuild layout more readable; move to EAPI=5 and git-r3
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'app-emulation/rex-client')
-rw-r--r--app-emulation/rex-client/ChangeLog6
-rw-r--r--app-emulation/rex-client/rex-client-9999.ebuild27
2 files changed, 22 insertions, 11 deletions
diff --git a/app-emulation/rex-client/ChangeLog b/app-emulation/rex-client/ChangeLog
index 65af72355489..c4ff53d9471c 100644
--- a/app-emulation/rex-client/ChangeLog
+++ b/app-emulation/rex-client/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/rex-client
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/ChangeLog,v 1.4 2015/01/20 09:59:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/ChangeLog,v 1.5 2015/03/21 08:21:22 jlec Exp $
+
+ 21 Mar 2015; Justin Lecher <jlec@gentoo.org> rex-client-9999.ebuild:
+ use dobin instead of exeinto /usr/bin/ && doexe; make ebuild layout more
+ readable; move to EAPI=5 and git-r3
20 Jan 2015; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due to #213900
diff --git a/app-emulation/rex-client/rex-client-9999.ebuild b/app-emulation/rex-client/rex-client-9999.ebuild
index 9a2e7310ab36..e60d26c57116 100644
--- a/app-emulation/rex-client/rex-client-9999.ebuild
+++ b/app-emulation/rex-client/rex-client-9999.ebuild
@@ -1,16 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/rex-client-9999.ebuild,v 1.3 2014/04/11 09:21:35 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/rex-client/rex-client-9999.ebuild,v 1.4 2015/03/21 08:21:22 jlec Exp $
-EAPI="4"
+EAPI=5
-DESCRIPTION="REX - Remote EXexcution agent"
+DESCRIPTION="Remote EXexcution agent"
HOMEPAGE="http://mduft.github.io/rex/"
if [[ ${PV} == 9999 ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="https://github.com/mduft/rex.git"
- EGIT_PROJECT="${PN}"
else
SRC_URI=""
KEYWORDS="~x86-linux"
@@ -20,18 +19,26 @@ LICENSE="MIT"
SLOT="0"
IUSE=""
-REX_EXE=( "client/rex-exec.sh" "client/rex-register.sh" "client/rex-paths.sh" "client/rex-remote-pconv.sh" "client/winpath2unix" "client/unixpath2win" )
+REX_EXE=(
+ "client/rex-exec.sh"
+ "client/rex-register.sh"
+ "client/rex-paths.sh"
+ "client/rex-remote-pconv.sh"
+ "client/winpath2unix"
+ "client/unixpath2win"
+ )
src_prepare() {
for x in ${REX_EXE[@]}; do
- sed -i -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" "${x}"
+ sed \
+ -e "s,\. \${HOME}/rex-config.sh,\. ${EPREFIX}/etc/rex.conf,g" \
+ -i "${x}" || die
done
}
src_install() {
- exeinto /usr/bin
for x in ${REX_EXE[@]}; do
- doexe "${S}"/${x}
+ dobin "${S}"/${x}
done
insinto /etc