summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-05-12 09:13:55 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-05-12 09:13:55 +0000
commit6fe1fcff012a30465d2345c1c78f771a979aab83 (patch)
tree4678df08578cc5c33868a9978bc8e9812cc08084 /app-emulation/qemu
parentLots of cleanups and fixes - see ChangeLog in /usr/share/doc. (diff)
downloadgentoo-2-6fe1fcff012a30465d2345c1c78f771a979aab83.tar.gz
gentoo-2-6fe1fcff012a30465d2345c1c78f771a979aab83.tar.bz2
gentoo-2-6fe1fcff012a30465d2345c1c78f771a979aab83.zip
Hardened updates
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog5
-rw-r--r--app-emulation/qemu/qemu-0.7.0.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 3fb3d137622a..905c7b6fb59e 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.32 2005/05/07 09:23:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.33 2005/05/12 09:13:55 lu_zero Exp $
+
+ 12 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
+ Hardened updates from Kevin F. Quinn <co@kevquinn.com>
07 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
Some fixes here and there, thanks to Sok Ann Yap <sokann@gmail.com>
diff --git a/app-emulation/qemu/qemu-0.7.0.ebuild b/app-emulation/qemu/qemu-0.7.0.ebuild
index 44f7f5f5ad60..d8ea3e316db7 100644
--- a/app-emulation/qemu/qemu-0.7.0.ebuild
+++ b/app-emulation/qemu/qemu-0.7.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.5 2005/05/07 09:23:26 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.6 2005/05/12 09:13:55 lu_zero Exp $
-inherit eutils flag-o-matic linux-mod
+inherit eutils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
@@ -34,6 +34,9 @@ set_target_list() {
}
pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
# ( use kqemu || use qvm86 ) && linux-mod_pkg_setup
use kqemu && linux-mod_pkg_setup
}
@@ -60,7 +63,8 @@ src_unpack() {
# fi
cd ${S}
# Alter target makefiles to accept CFLAGS set via flag-o.
- sed -i 's/^CFLAGS=-Wall -O2 -g/CFLAGS+=-Wall/' Makefile Makefile.target
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
# Ensure mprotect restrictions are relaxed for emulator binaries
[[ -x /sbin/paxctl ]] && \
sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
@@ -70,9 +74,12 @@ src_unpack() {
}
src_compile() {
- #Let the application set it's cflags
+ #Let the application set its cflags
unset CFLAGS
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
myconf=""
set_target_list
# --interp-prefix=${RUNTIME_PATH}/qemu-%M