summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-07-14 18:22:56 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-07-14 18:22:56 +0000
commit130f7b1698dfe74e8a5f535c5915382e2a993637 (patch)
tree0cbc3b58d306e414c5ddc618222c2b1e04633050 /app-emulation/playonlinux
parentStable for x86, wrt bug #419767 (diff)
downloadgentoo-2-130f7b1698dfe74e8a5f535c5915382e2a993637.tar.gz
gentoo-2-130f7b1698dfe74e8a5f535c5915382e2a993637.tar.bz2
gentoo-2-130f7b1698dfe74e8a5f535c5915382e2a993637.zip
Add Ipv6 support thanks to Michael Mol <mikemol@gmail.com>. Bug #425330
(Portage version: 2.1.11.7/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/playonlinux')
-rw-r--r--app-emulation/playonlinux/ChangeLog10
-rw-r--r--app-emulation/playonlinux/files/playonlinux-4.1.1-not-exclude-ipv6.patch27
-rw-r--r--app-emulation/playonlinux/metadata.xml4
-rw-r--r--app-emulation/playonlinux/playonlinux-4.1.1-r1.ebuild111
4 files changed, 149 insertions, 3 deletions
diff --git a/app-emulation/playonlinux/ChangeLog b/app-emulation/playonlinux/ChangeLog
index aeb6f8a6f49f..c6ab9b9b6b13 100644
--- a/app-emulation/playonlinux/ChangeLog
+++ b/app-emulation/playonlinux/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/playonlinux
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.18 2012/06/16 19:12:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/ChangeLog,v 1.19 2012/07/14 18:22:55 hwoarang Exp $
+
+*playonlinux-4.1.1-r1 (14 Jul 2012)
+
+ 14 Jul 2012; Markos Chandras <hwoarang@gentoo.org>
+ +files/playonlinux-4.1.1-not-exclude-ipv6.patch, +playonlinux-4.1.1-r1.ebuild,
+ metadata.xml:
+ Add Ipv6 support thanks to Michael Mol <mikemol@gmail.com>. Bug #425330
*playonlinux-4.1.1 (16 Jun 2012)
@@ -93,4 +100,3 @@
16 May 2009; Mounir Lamouri <volkmar@gentoo.org> +metadata.xml,
+playonlinux-3.5.ebuild:
Initial commit. See bug 213287
-
diff --git a/app-emulation/playonlinux/files/playonlinux-4.1.1-not-exclude-ipv6.patch b/app-emulation/playonlinux/files/playonlinux-4.1.1-not-exclude-ipv6.patch
new file mode 100644
index 000000000000..c783173115c3
--- /dev/null
+++ b/app-emulation/playonlinux/files/playonlinux-4.1.1-not-exclude-ipv6.patch
@@ -0,0 +1,27 @@
+# Changes wget usage to _allow_ IPv6, but to prefer IPv4. This way, DNS64 and
+# IPv6-only http_proxy scenarios should work.
+# Patch written by Michael Mol <mikemol@gmail.com>
+# Patch based on dialog with upstream, ascertaining their purpose for using
+# -4, and coming up with an agreed-upon workaround. Upstream equivalent is
+# committed to their vcs, and will probably appear in release 4.1.4.
+
+*** python/lib/Variables.py 2012-07-10 20:43:56.968567114 -0400
+--- python/lib/Variables-patched.py 2012-07-10 20:44:21.491898941 -0400
+*************** if (os.environ["POL_OS"] == "Mac"):
+*** 26,28 ****
+ os_name = "darwin"
+! os.environ["POL_WGET"] = "wget -4 -q"
+
+--- 26,28 ----
+ os_name = "darwin"
+! os.environ["POL_WGET"] = "wget --prefer-family=IPv4 -q"
+
+*************** if (os.environ["POL_OS"] == "Linux"):
+*** 39,41 ****
+ else:
+! os.environ["POL_WGET"] = "wget -4 -q"
+
+--- 39,41 ----
+ else:
+! os.environ["POL_WGET"] = "wget --prefer-family=IPv4 -q"
+
diff --git a/app-emulation/playonlinux/metadata.xml b/app-emulation/playonlinux/metadata.xml
index 31b9eb325aad..598cfa299b71 100644
--- a/app-emulation/playonlinux/metadata.xml
+++ b/app-emulation/playonlinux/metadata.xml
@@ -1,8 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>mikemol@gmail.com</email>
+ <name>Michael Mol</name>
</maintainer>
<use>
<flag name="winbind">Enables support for the winbind auth daemon</flag>
diff --git a/app-emulation/playonlinux/playonlinux-4.1.1-r1.ebuild b/app-emulation/playonlinux/playonlinux-4.1.1-r1.ebuild
new file mode 100644
index 000000000000..ced9306fd9bc
--- /dev/null
+++ b/app-emulation/playonlinux/playonlinux-4.1.1-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/playonlinux/playonlinux-4.1.1-r1.ebuild,v 1.1 2012/07/14 18:22:55 hwoarang Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit eutils python games
+
+MY_PN="PlayOnLinux"
+
+DESCRIPTION="Set of scripts to easily install and use Windows games and software"
+HOMEPAGE="http://playonlinux.com/"
+SRC_URI="http://www.playonlinux.com/script_files/${MY_PN}/${PV}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="winbind"
+
+DEPEND=""
+RDEPEND="app-emulation/wine
+ app-arch/cabextract
+ app-arch/p7zip
+ app-arch/unzip
+ app-crypt/gnupg
+ dev-python/wxpython:2.8
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ net-misc/wget
+ x11-apps/mesa-progs
+ x11-terms/xterm
+ media-gfx/icoutils
+ winbind? ( net-fs/samba[winbind] ) "
+
+S=${WORKDIR}/${PN}
+
+# TODO:
+# Having a real install script and let playonlinux use standard filesystem
+# architecture to prevent having everything installed into GAMES_DATADIR
+# It will let using LANGUAGES easily
+# How to deal with Microsoft Fonts installation asked every time ?
+# How to deal with wine version installed ? (have a better mgmt of system one)
+# Look at debian pkg: http://packages.debian.org/sid/playonlinux
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-not-exclude-ipv6.patch"
+ sed -i -e "s/\(Categories=\).*/\1Game;Emulator;/" etc/PlayOnLinux.desktop \
+ || die
+ sed -e 's/PYTHON="python"/PYTHON="python2"/' -i lib/variables playonlinux || die
+ python_convert_shebangs -r 2 .
+}
+
+src_install() {
+ # all things without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r resources lang lib etc plugins
+
+ # bash/ install
+ exeinto "${GAMES_DATADIR}/${PN}/bash"
+ doexe bash/*
+ exeinto "${GAMES_DATADIR}/${PN}/bash/terminals"
+ doexe bash/terminals/*
+ exeinto "${GAMES_DATADIR}/${PN}/bash/expert"
+ doexe bash/expert/*
+
+ # python/ install
+ exeinto "${GAMES_DATADIR}/${PN}/python"
+ doexe python/*
+ # sub dir without exec permissions
+ insinto "${GAMES_DATADIR}/${PN}/python"
+ doins -r python/lib
+
+ # main executable files
+ exeinto "${GAMES_DATADIR}/${PN}"
+ doexe ${PN}{,-pkg,-bash,-shell,-url_handler}
+
+ # making a script to run playonlinux from ${GAMES_BINDIR}
+ echo "#!/bin/bash" > ${PN}_launcher
+ echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN} \$*" >> ${PN}_launcher
+ newgamesbin playonlinux_launcher playonlinux
+
+ # making a script to run playonlinux-cmd from ${GAMES_BINDIR}
+ echo "#!/bin/bash" > ${PN}_cmd_launcher
+ echo "cd \"${GAMES_DATADIR}/${PN}\" && ./${PN}-cmd \$*" >> ${PN}_cmd_launcher
+ newgamesbin playonlinux_cmd_launcher playonlinux-cmd
+
+ dodoc CHANGELOG
+
+ doicon etc/${PN}.png
+ domenu etc/${MY_PN}.desktop
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ python_mod_optimize "${GAMES_DATADIR}/${PN}"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "${GAMES_DATADIR}/${PN}"
+
+ elog "Installed softwares and games with playonlinux have not been removed."
+ elog "To remove them, you can re-install playonlinux and remove them using it"
+ elog "or do it manually by removing .PlayOnLinux/ in your home directory."
+}