summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-06-18 17:28:40 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-06-18 17:28:40 +0000
commit27942555e85e8866a213f55e14aad26aa63381b0 (patch)
tree69f9fc8cb50c5e021277b1842b8ccb8e25e768d9 /app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
parentMake mpris enabled by default for 9999 (diff)
downloadgentoo-2-27942555e85e8866a213f55e14aad26aa63381b0.tar.gz
gentoo-2-27942555e85e8866a213f55e14aad26aa63381b0.tar.bz2
gentoo-2-27942555e85e8866a213f55e14aad26aa63381b0.zip
Revbump for improved init script. Bug #420991, comment #17
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild')
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
new file mode 100644
index 000000000000..ad9e30413207
--- /dev/null
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild,v 1.1 2012/06/18 17:28:40 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator eutils webapp depend.php
+
+MY_PV="$(replace_version_separator 2 '-')"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Web-based administration for VirtualBox in PHP"
+HOMEPAGE="http://phpvirtualbox.googlecode.com"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-lang/php[session,unicode,soap,gd]
+"
+DEPEND="app-arch/unzip"
+
+need_php_httpd
+
+src_install() {
+ webapp_src_preinst
+
+ cd ${MY_P}
+
+ dodoc CHANGELOG.txt LICENSE.txt README.txt || die
+ rm -f CHANGELOG.txt LICENSE.txt README.txt
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php-example
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
+
+ webapp_src_install
+
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+}
+
+pkg_postinst() {
+ webapp_pkg_postinst
+ elog "Local or remote virtualbox hosts must be compiled with"
+ elog "'vboxwebsrv' useflag and the respective init script"
+ elog "must be running to use this interface"
+ elog " /etc/init.d/vboxwebsrv start"
+ elog
+ elog "To enable the automatic startup mode feature uncomment the"
+ elog "following line in the config.php file:"
+ elog " var \$startStopConfig = true;"
+ elog
+ elog "You should also add the /etc/init.d/vboxinit script to the"
+ elog "default runlevel on the virtualbox host:"
+ elog "\`rc-update add vboxinit default\`"
+ elog "If the server is on a remote host, than the script must be"
+ elog "copied manually."
+}