summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2013-05-21 21:58:20 +0000
committerDoug Goldstein <cardoe@gentoo.org>2013-05-21 21:58:20 +0000
commit5ff74086bbbbb54ecea748a31ef07ecb69883c4e (patch)
tree609701cae409e661e817428b4abb0cf5186000fe /app-emulation/libvirt
parentwww-client/httrack: 3.47.13 (diff)
downloadgentoo-2-5ff74086bbbbb54ecea748a31ef07ecb69883c4e.tar.gz
gentoo-2-5ff74086bbbbb54ecea748a31ef07ecb69883c4e.tar.bz2
gentoo-2-5ff74086bbbbb54ecea748a31ef07ecb69883c4e.zip
Add support for systemd unit files. bug #459372
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key D7DFA8D318FA9AEF!)
Diffstat (limited to 'app-emulation/libvirt')
-rw-r--r--app-emulation/libvirt/ChangeLog5
-rw-r--r--app-emulation/libvirt/libvirt-1.0.5.1.ebuild11
2 files changed, 12 insertions, 4 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 3fbec95ac089..dc3cd4d96374 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.268 2013/05/21 21:25:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.269 2013/05/21 21:58:20 cardoe Exp $
+
+ 21 May 2013; Doug Goldstein <cardoe@gentoo.org> libvirt-1.0.5.1.ebuild:
+ Add support for systemd unit files. bug #459372
*libvirt-1.0.5.1 (21 May 2013)
diff --git a/app-emulation/libvirt/libvirt-1.0.5.1.ebuild b/app-emulation/libvirt/libvirt-1.0.5.1.ebuild
index 55e4abe74678..0b305011f221 100644
--- a/app-emulation/libvirt/libvirt-1.0.5.1.ebuild
+++ b/app-emulation/libvirt/libvirt-1.0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.1.ebuild,v 1.1 2013/05/21 21:25:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-1.0.5.1.ebuild,v 1.2 2013/05/21 21:58:20 cardoe Exp $
EAPI=5
@@ -13,7 +13,7 @@ PYTHON_DEPEND="python? 2:2.5"
#RESTRICT_PYTHON_ABIS="3.*"
#SUPPORT_PYTHON_ABIS="1"
-inherit eutils python user autotools linux-info
+inherit eutils python user autotools linux-info systemd
if [[ ${PV} = *9999* ]]; then
inherit git-2
@@ -36,7 +36,8 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="audit avahi +caps firewalld fuse iscsi +libvirtd lvm +lxc +macvtap nfs \
nls numa openvz parted pcap phyp policykit python qemu rbd sasl \
- selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc"
+ selinux +udev uml +vepa virtualbox virt-network xen elibc_glibc \
+ systemd"
REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
lxc? ( caps libvirtd )
openvz? ( libvirtd )
@@ -302,6 +303,9 @@ src_configure() {
# locking support
myconf="${myconf} --without-sanlock"
+ # systemd unit files
+ use systemd && myconf="${myconf} --with-init-script=systemd"
+
# this is a nasty trick to work around the problem in bug
# #275073. The reason why we don't solve this properly is that
# it'll require us to rebuild autotools (and we don't really want
@@ -342,6 +346,7 @@ src_install() {
HTML_DIR=/usr/share/doc/${PF}/html \
DOCS_DIR=/usr/share/doc/${PF}/python \
EXAMPLE_DIR=/usr/share/doc/${PF}/python/examples \
+ SYSTEMD_UNIT_DIR="$(systemd_get_unitdir)" \
|| die "emake install failed"
find "${D}" -name '*.la' -delete || die